From c2fc19e61471b38fd48d002fedee21912e8f18c1 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 26 Mar 2009 11:18:32 -0500
Subject: Adding wxgtk

---
 abs/extra-testing/wxgtk/ChangeLog   | 18 ++++++++++++++++++
 abs/extra-testing/wxgtk/PKGBUILD    | 32 ++++++++++++++++++++++++++++++++
 abs/extra-testing/wxgtk/__changelog |  1 +
 3 files changed, 51 insertions(+)
 create mode 100644 abs/extra-testing/wxgtk/ChangeLog
 create mode 100644 abs/extra-testing/wxgtk/PKGBUILD
 create mode 100644 abs/extra-testing/wxgtk/__changelog

diff --git a/abs/extra-testing/wxgtk/ChangeLog b/abs/extra-testing/wxgtk/ChangeLog
new file mode 100644
index 0000000..03e9f96
--- /dev/null
+++ b/abs/extra-testing/wxgtk/ChangeLog
@@ -0,0 +1,18 @@
+2009-03-06  Eric Belanger  <eric@archlinux.org>
+
+	* wxgtk 2.8.9.2-1
+	* Upstream update
+	* Switched to wxpython source tarball
+
+2008-09-26  Eric Belanger  <eric@archlinux.org>
+
+	* wxgtk 2.8.9-1
+	* Upstream update
+	* Added mediactrl support (close FS#11220)
+
+2008-07-05  Eric Belanger  <eric@archlinux.org>
+
+	* wxgtk 2.8.8-1
+	* Upstream update
+	* Enabled gnomeprint - needed for wxpython to build
+	* Added ChangeLog
diff --git a/abs/extra-testing/wxgtk/PKGBUILD b/abs/extra-testing/wxgtk/PKGBUILD
new file mode 100644
index 0000000..dd0f344
--- /dev/null
+++ b/abs/extra-testing/wxgtk/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 29177 2009-03-06 09:02:47Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Original Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# New Version - Contributor: Bob Finch <w9ya@arrl.net>
+# with help from J. Santiago Hirschfeld <jsantiagoh@yahoo.com.ar> aka Angelus
+
+pkgname=wxgtk
+pkgver=2.8.9.2
+pkgrel=1
+pkgdesc="wxGTK - GTK+ implementation of wxWidgets API for GUI"
+arch=('i686' 'x86_64')
+url="http://wxwidgets.org"
+license=('custom:wxWindows')
+depends=('gtk2>=2.12.11' 'mesa')
+#makedepends=('libgnomeprintui')
+#source=(http://downloads.sourceforge.net/wxwindows/wxGTK-${pkgver}.tar.bz2)
+source=(http://downloads.sourceforge.net/wxpython/wxPython-src-${pkgver}.tar.bz2)
+md5sums=('e3d89746af98b9279e4ff39a57f6dc63')
+sha1sums=('a0d58d8b9606d04a35b9853da15eb7dfb08d5637')
+
+build() {
+  cd ${srcdir}/wxPython-src-${pkgver}
+  ./configure --prefix=/usr --libdir=/usr/lib --with-gtk=2 --with-opengl --enable-unicode \
+	  --enable-graphics_ctx --without-gnomeprint --disable-optimize || return 1
+  make || return 1
+  make -C locale allmo || return 1
+  make DESTDIR=${pkgdir} install || return 1
+  cd contrib/src
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+  install -D -m644 ../../docs/licence.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE || return 1
+}
diff --git a/abs/extra-testing/wxgtk/__changelog b/abs/extra-testing/wxgtk/__changelog
new file mode 100644
index 0000000..3bf8bed
--- /dev/null
+++ b/abs/extra-testing/wxgtk/__changelog
@@ -0,0 +1 @@
+remove libgnomeprint
-- 
cgit v0.12