From 0ddfab039265ac932a8a48b01e90ffdb434d7fb7 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 12 Jan 2009 17:32:57 -0600
Subject: Correct not ejecting the cd because it thinks it's not a cddrive.
 Moved break inside the loop, so the loop actually loops instead of stopping
 after the first device.

---
 abs/core-testing/linhes-live/PKGBUILD          | 3 ++-
 abs/core-testing/linhes-live/etc/live-shutdown | 6 +++---
 2 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/linhes-live/PKGBUILD b/abs/core-testing/linhes-live/PKGBUILD
index f718e22..b0da16a 100644
--- a/abs/core-testing/linhes-live/PKGBUILD
+++ b/abs/core-testing/linhes-live/PKGBUILD
@@ -2,7 +2,7 @@
 # 2008.09.25
 pkgname=linhes-live
 pkgver=5.3.3
-pkgrel=12
+pkgrel=15
 
 pkgdesc="LinHes compulsory components for the Live System."
 url="http://KnoppMyth.net"
@@ -29,3 +29,4 @@ build() {
 
 # End
 #change hook1 to wait for usb cdroms
+#add extra login to f_remountro for vmware/usb
diff --git a/abs/core-testing/linhes-live/etc/live-shutdown b/abs/core-testing/linhes-live/etc/live-shutdown
index 6e12d22..b105975 100644
--- a/abs/core-testing/linhes-live/etc/live-shutdown
+++ b/abs/core-testing/linhes-live/etc/live-shutdown
@@ -38,10 +38,10 @@ f_swapoff ()
 f_remountro ()
 {
     bootdev=`cat /.livesys/bootdevice`
-    bootdev=`basename $bootdev`
-    for i in `ls -H /dev/cd/*`
+    #bootdev=`basename $bootdev`
+    for i in `ls  /dev/cd/*`
     do
-        cdrom=`basename $i|cut -d- -f2`
+        cdrom=`readlink -f $i`
         if [ x$cdrom = x$bootdev ]
         then
             ejectdev=$cdrom
-- 
cgit v0.12