From 948970dc8ce2e250324747bf0499c78acfd78912 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 18 Mar 2010 16:50:32 -0500
Subject: php: remove open_basedir from the configuration. lighttpd already
 runs as a restricted user.

if the user wants to use open_basedir all they need todo is uncomment it in /ete/php/php.ini

closes 625
---
 abs/core-testing/php/PKGBUILD    | 14 +++++++++++++-
 abs/core-testing/php/__changelog |  2 ++
 abs/core-testing/php/php.ini     |  2 +-
 3 files changed, 16 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index 975716a..65862a9 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=php
 pkgver=5.2.6
-pkgrel=23
+pkgrel=29
 _suhosinver=0.9.6.2
 pkgdesc='A high-level scripting language'
 arch=('i686' 'x86_64')
@@ -174,3 +174,15 @@ build() {
 #	install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
 #	install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
 }
+
+
+md5sums=('7380ffecebd95c6edb317ef861229ebd'
+         'f2ec986341a314c271259dbe4d940858'
+         '0ba86d39163d577c195d57c9129149cd'
+         '96ca078be6729b665be8a865535a97bf'
+         '74e5ce5a02488ec91b1c59f539e42936')
+md5sums=('7380ffecebd95c6edb317ef861229ebd'
+         'f2ec986341a314c271259dbe4d940858'
+         '13795526fe1a5da17c0aa46d5ea1a5d8'
+         '96ca078be6729b665be8a865535a97bf'
+         '74e5ce5a02488ec91b1c59f539e42936')
diff --git a/abs/core-testing/php/__changelog b/abs/core-testing/php/__changelog
index aac14ba..375545c 100644
--- a/abs/core-testing/php/__changelog
+++ b/abs/core-testing/php/__changelog
@@ -4,3 +4,5 @@ added /data/srv/tmp to basedir
 added /usr/share/mythtv/mythweather/scripts/
 send errors to stderr 
 change .install file, timezone is modified on install
+php.ini -jm
+	remove open_basedir
diff --git a/abs/core-testing/php/php.ini b/abs/core-testing/php/php.ini
index 8cbcd56..0d3a568 100644
--- a/abs/core-testing/php/php.ini
+++ b/abs/core-testing/php/php.ini
@@ -249,7 +249,7 @@ safe_mode_protected_env_vars = LD_LIBRARY_PATH
 ; and below.  This directive makes most sense if used in a per-directory
 ; or per-virtualhost web server configuration file. This directive is
 ; *NOT* affected by whether Safe Mode is turned On or Off.
-open_basedir = /data/srv/httpd/htdocs/:/home/:/tmp/:/usr/share/pear/:/data/srv/tmp:/usr/share/mythtv/mythweather/scripts/:/data/srv/httpd/htdocs/mythweb/data/video:/myth/ipodfeed:/data/srv/httpd/htdocs/archive:/etc
+;open_basedir = /data/srv/httpd/htdocs/:/home/:/tmp/:/usr/share/pear/:/data/srv/tmp:/usr/share/mythtv/mythweather/scripts/:/data/srv/httpd/htdocs/mythweb/data/video:/myth/ipodfeed:/data/srv/httpd/htdocs/archive:/etc:/myth:/media
 
 ; This directive allows you to disable certain functions for security reasons.
 ; It receives a comma-delimited list of function names. This directive is
-- 
cgit v0.12