From 8a56d9ef0cf6ddd18fa9f1065d915c7688f54d17 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 22 Feb 2009 16:33:38 -0600
Subject: Bring MV-core myth packages up to date

---
 .../release-fixes/mythtv-release-fixes/PKGBUILD    | 13 ++++----
 .../release-fixes/plugins/mytharchive/PKGBUILD     |  2 +-
 .../release-fixes/plugins/mythbrowser/PKGBUILD     |  2 +-
 .../release-fixes/plugins/mythcontrols/PKGBUILD    |  2 +-
 .../myth/release-fixes/plugins/mythflix/PKGBUILD   |  2 +-
 .../release-fixes/plugins/mythgallery/PKGBUILD     |  2 +-
 .../myth/release-fixes/plugins/mythgame/PKGBUILD   |  2 +-
 .../release-fixes/plugins/mythmovietime/PKGBUILD   |  2 +-
 .../myth/release-fixes/plugins/mythmusic/PKGBUILD  | 24 +++++++-------
 .../release-fixes/plugins/mythmusic/gcc4.3.patch   | 37 ----------------------
 .../myth/release-fixes/plugins/mythnews/PKGBUILD   |  2 +-
 .../myth/release-fixes/plugins/mythphone/PKGBUILD  |  2 +-
 .../myth/release-fixes/plugins/mythsmolt/PKGBUILD  |  4 +--
 .../myth/release-fixes/plugins/mythvideo/PKGBUILD  |  2 +-
 .../release-fixes/plugins/mythweather/PKGBUILD     |  2 +-
 15 files changed, 31 insertions(+), 69 deletions(-)
 delete mode 100644 abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch

diff --git a/abs/mv-core/myth/release-fixes/mythtv-release-fixes/PKGBUILD b/abs/mv-core/myth/release-fixes/mythtv-release-fixes/PKGBUILD
index c210b55..0c14cfc 100755
--- a/abs/mv-core/myth/release-fixes/mythtv-release-fixes/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/mythtv-release-fixes/PKGBUILD
@@ -46,13 +46,12 @@ build() {
   	sed -i -e "s/\`(svnversion \$\${SVNTREEDIR} 2>\/dev\/null) || echo Unknown\`/$pkgver/" version.pro
          make distclean
 	 make clean
-	 ./configure --prefix=/usr/local --enable-xvmc --enable-xvmc-pro --enable-opengl-vsync --enable-dvb --enable-firewire --compile-type=release --with-bindings=perl --disable-audio-arts --disable-xrandr  --disable-audio-jack
-	 #./configure --prefix=/usr/local --enable-xvmc --enable-xvmc-pro --enable-opengl-vsync --enable-dvb --enable-firewire --compile-type=release  --disable-audio-arts --disable-xrandr --without-bindings=perl --disable-audio-jack
+	 ./configure --prefix=/usr --disable-xvmc --disable-xvmc-pro --enable-opengl-vsync --enable-dvb --enable-firewire --compile-type=release --with-bindings=perl --disable-audio-arts --disable-xrandr  --disable-audio-jack   --disable-directfb
 . /etc/profile
 
    make
    make INSTALL_ROOT=$startdir/pkg install
-   mkdir -p $startdir/pkg/usr/local/share/mythtv/contrib
+   mkdir -p $startdir/pkg/usr/share/mythtv/contrib
    mkdir -p $startdir/pkg/etc/rc.d
    mkdir -p $startdir/pkg/var/log/mythtv
    mkdir -p $startdir/pkg/etc/profile.d
@@ -70,10 +69,10 @@ build() {
 #   mv $startdir/pkg/usr/local/lib/perl5 $startdir/pkg/usr/lib/perl5
     cd $startdir/src/mythtv/contrib
     gcc -Wall -o firewire_tester firewire_tester.c -liec61883 -lraw1394
-    install -m0755 firewire_tester $startdir/pkg/usr/local/bin/firewire_tester
-    install -m0755  $startdir/pkg/usr/local/share/mythtv/contrib/optimize_mythdb.pl  $startdir/pkg/usr/local/bin/optimize_mythdb.pl
-    cp $startdir/src/myth.find_orphans.pl $startdir/pkg/usr/local/share/mythtv/contrib/myth.find_orphans.pl
-    install -m0755  $startdir/pkg/usr/local/share/mythtv/contrib/myth.find_orphans.pl  $startdir/pkg/usr/local/bin/myth.find_orphans.pl
+    install -m0755 firewire_tester $startdir/pkg/usr/bin/firewire_tester
+    install -m0755  $startdir/pkg/usr/share/mythtv/contrib/optimize_mythdb.pl  $startdir/pkg/usr/local/bin/optimize_mythdb.pl
+    cp $startdir/src/myth.find_orphans.pl $startdir/pkg/usr/share/mythtv/contrib/myth.find_orphans.pl
+    install -m0755  $startdir/pkg/usr/share/mythtv/contrib/myth.find_orphans.pl  $startdir/pkg/usr/bin/myth.find_orphans.pl
 
 
 }
diff --git a/abs/mv-core/myth/release-fixes/plugins/mytharchive/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mytharchive/PKGBUILD
index 2d6edc1..ad6b8fb 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mytharchive/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mytharchive/PKGBUILD
@@ -29,7 +29,7 @@ build() {
 	msg "Correcting configure    kde3 to kde"
 	 sed -i 's#kde3#kde#' configure || return 1
 	make distclean
-   	./configure  --enable-opengl --disable-all   --enable-create-archive --enable-create-dvd --enable-mytharchive || return 1
+   	./configure  --prefix=/usr --enable-opengl --disable-all   --enable-create-archive --enable-create-dvd --enable-mytharchive || return 1
 	qmake mythplugins.pro || return 1
 	make qmake || return 1
 	msg "Correcting Makefile    kde3 to kde"
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythbrowser/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythbrowser/PKGBUILD
index 0a1b29e..adfe87a 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythbrowser/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythbrowser/PKGBUILD
@@ -26,7 +26,7 @@ build() {
 			msg "appending program lib"
 		fi
 	make distclean
-   ./configure  --enable-opengl --disable-all --enable-mythbrowser || return 1
+   ./configure --prefix=/usr  --enable-opengl --disable-all --enable-mythbrowser || return 1
  #  sed -i 's#kde3#kde#' ./mythbrowser/mythbrowser/Makefile || return 1
    make || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythcontrols/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythcontrols/PKGBUILD
index 31b1e73..ea1109f 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythcontrols/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythcontrols/PKGBUILD
@@ -27,7 +27,7 @@ then
 			msg "appending program lib"
 		fi
 	make distclean
-   ./configure  --disable-all --enable-opengl --enable-mythcontrols
+   ./configure  --disable-all --enable-opengl --enable-mythcontrols --prefix=/usr
 
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythflix/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythflix/PKGBUILD
index 3e49073..a3a48fe 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythflix/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythflix/PKGBUILD
@@ -28,7 +28,7 @@ build() {
 				msg "appending program lib"
 			fi
 	make distclean
-   ./configure  --disable-all --enable-opengl --enable-mythflix 
+   ./configure --prefix=/usr  --disable-all --enable-opengl --enable-mythflix 
 
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythgallery/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythgallery/PKGBUILD
index 4469148..a12e22c 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythgallery/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythgallery/PKGBUILD
@@ -27,7 +27,7 @@ build() {
 				msg "appending program lib"
 			fi
 	make distclean
-   ./configure  --disable-all --enable-opengl --enable-mythgallery --enable-exif
+   ./configure  --prefix=/usr --disable-all --enable-opengl --enable-mythgallery --enable-exif
 
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD
index d572df1..8cf2f65 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythgame/PKGBUILD
@@ -27,7 +27,7 @@ then
 		fi
 	export QMAKESPEC='linux-g++'
 	make distclean
-   ./configure  --disable-all --enable-opengl --enable-mythgame 
+   ./configure  --disable-all --enable-opengl --enable-mythgame --prefix=/usr
 
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythmovietime/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythmovietime/PKGBUILD
index f6945af..5560410 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythmovietime/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythmovietime/PKGBUILD
@@ -26,7 +26,7 @@ then
 		fi
 	export QMAKESPEC='linux-g++'
 	make distclean
-   ./configure  --disable-all --enable-mythmovies 
+   ./configure  --prefix=/usr --disable-all --enable-mythmovies 
 
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
index de26f57..bfb1de5 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythmusic/PKGBUILD
@@ -5,12 +5,15 @@ pkgdesc="Music playing plugin for MythTV"
 url="http://www.mythtv.org"
 arch=('i686' 'x86_64')
 
-depends=('mythtv-release-fixes ' 'libid3tag' 'flac>=1.1.4 ' 'a52dec' 'libcdaudio' 'libcddb' 'libdvdread' 'libid3tag' 'libmad' 'libogg'  'libtheora' 'libvorbis' 'taglib' 'libvisual' 'cdparanoia'   'sdl' 'faad2' 'lame' 'fftw2')
+
+depends=("mythtv-release-fixes>=${pkgver}" 'libid3tag' 'libmad' 'libvorbis' 'flac>=1.1.4' 'libcdaudio' \
+         'cdparanoia' 'fftw2' 'sdl' 'faad2>=2.6.1' 'lame' 'taglib' \
+	 	 'libvisual-plugins' 'libvisual-projectm')
 
 conflicts=('mythtv-plugins-release-fixes')
 groups=('mythtv-all-plugins-release-fixes')
 license="GPL"
-source=(gcc4.3.patch)
+source=()
 _svntrunk=http://svn.mythtv.org/svn/branches/release-0-21-fixes/mythplugins
 _svnmod=mythplugins
 
@@ -20,20 +23,17 @@ build() {
 	echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
  	svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
 	cd $startdir/src/mythplugins/mythmusic
-	patch -p1 < ../../gcc4.3.patch
+#	patch -p1 < ../../gcc4.3.patch
 	cd $startdir/src/mythplugins
-     ./configure  --disable-all --enable-mythmusic --enable-fftw --enable-sdl --disable-aac --enable-opengl 
-PLUGIN=mythmusic
-grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
-if [ $? != 0 ]
-then
+     ./configure  --disable-all --enable-mythmusic --enable-fftw --enable-sdl --disable-aac --enable-opengl --prefix=/usr
+	PLUGIN=mythmusic
+	grep -q  programs-libs.pro  $PLUGIN/$PLUGIN/$PLUGIN.pro
+	if [ $? != 0 ]
+	then
 		echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
 			msg "appending program lib"
-		fi
-
-#   ./configure  --disable-all --enable-mythmusic  
+	fi
 
    make  || return 1
-
    make INSTALL_ROOT=$startdir/pkg install
 }
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch b/abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch
deleted file mode 100644
index 564c434..0000000
--- a/abs/mv-core/myth/release-fixes/plugins/mythmusic/gcc4.3.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Index: mythmusic/mythmusic/aacdecoder.cpp
-===================================================================
---- mythmusic/mythmusic/aacdecoder.cpp	(revision 17452)
-+++ mythmusic/mythmusic/aacdecoder.cpp	(working copy)
-@@ -19,6 +19,7 @@
- #include <qobject.h>
- #include <qiodevice.h>
- #include <qfile.h>
-+#include <stdlib.h>
- 
- #include "aacdecoder.h"
- #include "constants.h"
-Index: mythmusic/mythmusic/aacdecoder.h
-===================================================================
---- mythmusic/mythmusic/aacdecoder.h	(revision 17452)
-+++ mythmusic/mythmusic/aacdecoder.h	(working copy)
-@@ -51,7 +51,7 @@
-     bool done, finish;
-     long len, bitrate;
-     uchar channels;
--    unsigned long sample_rate;
-+    uint32_t sample_rate;
-     unsigned long output_size;
-     double totalTime, seekTime;
- 
-Index: mythmusic/mythmusic/metaiomp4.cpp
-===================================================================
---- mythmusic/mythmusic/metaiomp4.cpp	(revision 17452)
-+++ mythmusic/mythmusic/metaiomp4.cpp	(working copy)
-@@ -3,6 +3,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <sys/types.h>
-+#include <stdlib.h>
- 
- using namespace std;
- 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythnews/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythnews/PKGBUILD
index ef46fd9..90ae093 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythnews/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythnews/PKGBUILD
@@ -25,7 +25,7 @@ build() {
 				msg "appending program lib"
 			fi
 	make distclean
-   ./configure --disable-all --enable-mythnews
+   ./configure --disable-all --enable-mythnews --prefix=/usr
 
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythphone/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythphone/PKGBUILD
index 0311916..7227958 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythphone/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythphone/PKGBUILD
@@ -29,7 +29,7 @@ build() {
 	
 	msg "Correcting configure    kde3 to kde"
    	sed -i 's#kde3#kde#' configure || return 1
-   	./configure  --enable-opengl --disable-all --enable-mythphone || return 1
+   	./configure  --prefix=/usr --enable-opengl --disable-all --enable-mythphone || return 1
 	qmake mythplugins.pro || return 1
 	make qmake || return 1
 	
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythsmolt/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythsmolt/PKGBUILD
index 021d270..b8e421a 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythsmolt/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythsmolt/PKGBUILD
@@ -16,8 +16,8 @@ build() {
    
    # use QT3 qmake
    export PATH=$QTDIR/bin:$PATH
-   echo "INCLUDEPATH += /usr/local/include/mythtv" >> mythsmolt.pro.local 
-   qmake mythsmolt.pro.local
+   echo "INCLUDEPATH += /usr/include/mythtv" >> mythsmolt.pro.usr
+   qmake mythsmolt.pro.usr
    make qmake || return 1
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythvideo/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythvideo/PKGBUILD
index cdc8dea..2be63e3 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythvideo/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythvideo/PKGBUILD
@@ -27,7 +27,7 @@ build() {
 			echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
 				msg "appending program lib"
 			fi
-   ./configure  --disable-all --enable-mythvideo  --enable-transcode  
+   ./configure --prefix=/usr  --disable-all --enable-mythvideo  --enable-transcode  
 
    make -j 2 || return 1
 
diff --git a/abs/mv-core/myth/release-fixes/plugins/mythweather/PKGBUILD b/abs/mv-core/myth/release-fixes/plugins/mythweather/PKGBUILD
index 997f78a..2870928 100644
--- a/abs/mv-core/myth/release-fixes/plugins/mythweather/PKGBUILD
+++ b/abs/mv-core/myth/release-fixes/plugins/mythweather/PKGBUILD
@@ -28,7 +28,7 @@ build() {
 			echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
 				msg "appending program lib"
 			fi
-   ./configure  --enable-opengl --disable-all --enable-mythweather
+   ./configure  --enable-opengl --disable-all --enable-mythweather --prefix=/usr
  
    make -j 2 || return 1
 
-- 
cgit v0.12