From 87ee63ae6cc83c1d660a3fafe10d94ae06318e8e Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sat, 20 Jun 2009 12:47:20 +0930
Subject: tftp-hpa: added. runit-scripts: added run scripts for dhcpd and tftpd

---
 abs/core-testing/runit-scripts/PKGBUILD            |  2 +-
 .../runit-scripts/runitscripts/services/dhcpd/run  |  8 +++++
 .../runit-scripts/runitscripts/services/tftpd/run  |  8 +++++
 abs/core-testing/tftp-hpa/LICENSE                  | 32 ++++++++++++++++++
 abs/core-testing/tftp-hpa/PKGBUILD                 | 29 +++++++++++++++++
 abs/core-testing/tftp-hpa/tftpd.conf               |  4 +++
 abs/core-testing/tftp-hpa/tftpd.rc                 | 38 ++++++++++++++++++++++
 7 files changed, 120 insertions(+), 1 deletion(-)
 create mode 100755 abs/core-testing/runit-scripts/runitscripts/services/dhcpd/run
 create mode 100755 abs/core-testing/runit-scripts/runitscripts/services/tftpd/run
 create mode 100644 abs/core-testing/tftp-hpa/LICENSE
 create mode 100644 abs/core-testing/tftp-hpa/PKGBUILD
 create mode 100644 abs/core-testing/tftp-hpa/tftpd.conf
 create mode 100755 abs/core-testing/tftp-hpa/tftpd.rc

diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index efe7947..852c658 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit-scripts
 pkgver=1.8.0
-pkgrel=87
+pkgrel=88
 pkgdesc="collection of startup scripts for runit"
 url="http://smarden.org/runit/"
 license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/dhcpd/run b/abs/core-testing/runit-scripts/runitscripts/services/dhcpd/run
new file mode 100755
index 0000000..38ae40a
--- /dev/null
+++ b/abs/core-testing/runit-scripts/runitscripts/services/dhcpd/run
@@ -0,0 +1,8 @@
+#!/bin/sh
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting dhcpd"
+
+
+exec /usr/sbin/dhcpd -f &> /var/log/dhcpd.log
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/tftpd/run b/abs/core-testing/runit-scripts/runitscripts/services/tftpd/run
new file mode 100755
index 0000000..8f742ca
--- /dev/null
+++ b/abs/core-testing/runit-scripts/runitscripts/services/tftpd/run
@@ -0,0 +1,8 @@
+#!/bin/sh
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting tftpd"
+
+
+exec /usr/sbin/in.tftpd --foreground -s /tftpboot
diff --git a/abs/core-testing/tftp-hpa/LICENSE b/abs/core-testing/tftp-hpa/LICENSE
new file mode 100644
index 0000000..6dade69
--- /dev/null
+++ b/abs/core-testing/tftp-hpa/LICENSE
@@ -0,0 +1,32 @@
+/*
+ * Copyright (c) 1983, 1993
+ *      The Regents of the University of California.  All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ *    notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ *    notice, this list of conditions and the following disclaimer in the
+ *    documentation and/or other materials provided with the distribution.
+ * 3. All advertising materials mentioning features or use of this software
+ *    must display the following acknowledgement:
+ *      This product includes software developed by the University of
+ *      California, Berkeley and its contributors.
+ * 4. Neither the name of the University nor the names of its contributors
+ *    may be used to endorse or promote products derived from this software
+ *    without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED.  IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ */
diff --git a/abs/core-testing/tftp-hpa/PKGBUILD b/abs/core-testing/tftp-hpa/PKGBUILD
new file mode 100644
index 0000000..cf1c9e0
--- /dev/null
+++ b/abs/core-testing/tftp-hpa/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 37555 2009-05-02 22:51:20Z eric $
+# Maintainer: dorphell <dorphell@archlinux.org>
+# Contributor: Jose Javier  <jojapa@terra.es>
+pkgname=tftp-hpa
+pkgver=5.0
+pkgrel=2
+pkgdesc="Official tftp server"
+arch=('i686' 'x86_64')
+url="http://www.kernel.org/pub/software/network/tftp/"
+license=('BSD')
+depends=('tcp_wrappers')
+conflicts=('netkit-tftp')
+backup=('etc/conf.d/tftpd')
+source=(http://www.kernel.org/pub/software/network/tftp/$pkgname-$pkgver.tar.gz tftpd.rc tftpd.conf LICENSE)
+md5sums=('1ae813a94670f0d8c294aafa9f5ecf65' 'a974d02526f19222146c8e3d3b598871'\
+         '414a79dc891bced056d99a9bb790fc9e' '6ce21e27b6fdc1a1adf85c81e42aeecf')
+
+build() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  ./configure --prefix=/usr --mandir=/usr/share/man || return 1
+  make || return 1
+  make INSTALLROOT="${pkgdir}" install || return 1
+  install -d "${pkgdir}/etc/rc.d"
+  install -d "${pkgdir}/var/tftpboot"
+  install -m755 "${srcdir}/tftpd.rc" "${pkgdir}/etc/rc.d/tftpd" || return 1
+  install -D -m644 "${srcdir}/tftpd.conf" "${pkgdir}/etc/conf.d/tftpd" || return 1
+  rm "${pkgdir}/usr/share/man/man8/tftpd.8"
+  install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/core-testing/tftp-hpa/tftpd.conf b/abs/core-testing/tftp-hpa/tftpd.conf
new file mode 100644
index 0000000..4705cc3
--- /dev/null
+++ b/abs/core-testing/tftp-hpa/tftpd.conf
@@ -0,0 +1,4 @@
+#
+# Parameters to be passed to TFTPD
+#
+TFTPD_ARGS="-l -s /var/tftpboot" 
diff --git a/abs/core-testing/tftp-hpa/tftpd.rc b/abs/core-testing/tftp-hpa/tftpd.rc
new file mode 100755
index 0000000..b21f87f
--- /dev/null
+++ b/abs/core-testing/tftp-hpa/tftpd.rc
@@ -0,0 +1,38 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+TFTPD_ARGS=
+[ -f /etc/conf.d/tftpd ] && . /etc/conf.d/tftpd
+
+PID=$(pidof -o %PPID /usr/sbin/in.tftpd)
+case "$1" in
+  start)
+    stat_busy "Starting TFTPD"
+    [ -z "$PID" ] && /usr/sbin/in.tftpd ${TFTPD_ARGS}
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      add_daemon in.tftpd
+      stat_done
+    fi
+    ;;
+  stop)
+    stat_busy "Stopping TFTPD"
+    [ ! -z "$PID" ]  && kill $PID &> /dev/null
+    if [ $? -gt 0 ]; then
+      stat_fail
+    else
+      rm_daemon in.tftpd
+      stat_done
+    fi
+    ;;
+  restart)
+    $0 stop
+    $0 start
+    ;;
+  *)
+    echo "usage: $0 {start|stop|restart}"  
+esac
+exit 0
-- 
cgit v0.12