From e4afdb47407c28eb3616cd8878cf0955431a2bf4 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Thu, 30 Apr 2009 11:29:21 -0700
Subject: Should have been removed.

---
 abs/core-testing/glib/PKGBUILD            | 32 +++++++++++++++++++++++++++++++
 abs/core-testing/glib/aclocal-fixes.patch | 11 +++++++++++
 abs/core-testing/glib/gcc340.patch        | 15 +++++++++++++++
 3 files changed, 58 insertions(+)
 create mode 100644 abs/core-testing/glib/PKGBUILD
 create mode 100644 abs/core-testing/glib/aclocal-fixes.patch
 create mode 100644 abs/core-testing/glib/gcc340.patch

diff --git a/abs/core-testing/glib/PKGBUILD b/abs/core-testing/glib/PKGBUILD
new file mode 100644
index 0000000..0f76a1e
--- /dev/null
+++ b/abs/core-testing/glib/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+pkgname=glib
+pkgver=1.2.10
+pkgrel=7
+pkgdesc="Common C routines used by Gtk+ and other libs"
+arch=('i686' 'x86_64')
+url="http://www.gtk.org/"
+license=('LGPL')
+depends=('glibc')
+options=('!libtool')
+source=(ftp://ftp.gtk.org/pub/gtk/v1.2/$pkgname-$pkgver.tar.gz \
+	gcc340.patch \
+	aclocal-fixes.patch)
+md5sums=('6fe30dad87c77b91b632def29dd69ef9' '877b3330e822a4be69a0f8a8c268cfd7'\
+         'e52c4b88427b9785bb8049dbdc9ff6fb')
+sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'\
+          'a2cc224a66aeffdcac16ebd9e8af18143cf54918'\
+          'ae4438cf56c0c9264ee36f6973fb445f9a820be0')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  patch -Np1 -i ../gcc340.patch || return 1
+  patch -Np0 -i ../aclocal-fixes.patch || return 1
+
+  #Arch64 fixes --build/host
+  ./configure --prefix=/usr #--host=i686-pc-linux-gnu
+  make || return 1
+  make DESTDIR=$startdir/pkg install
+}
diff --git a/abs/core-testing/glib/aclocal-fixes.patch b/abs/core-testing/glib/aclocal-fixes.patch
new file mode 100644
index 0000000..b064074
--- /dev/null
+++ b/abs/core-testing/glib/aclocal-fixes.patch
@@ -0,0 +1,11 @@
+--- glib.m4.orig	2006-03-05 13:13:24.000000000 +0000
++++ glib.m4	2006-03-05 13:13:35.000000000 +0000
+@@ -5,7 +5,7 @@
+ dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or 
+ dnl gthread is specified in MODULES, pass to glib-config
+ dnl
+-AC_DEFUN(AM_PATH_GLIB,
++AC_DEFUN([AM_PATH_GLIB],
+ [dnl 
+ dnl Get the cflags and libraries from the glib-config script
+ dnl
diff --git a/abs/core-testing/glib/gcc340.patch b/abs/core-testing/glib/gcc340.patch
new file mode 100644
index 0000000..941111a
--- /dev/null
+++ b/abs/core-testing/glib/gcc340.patch
@@ -0,0 +1,15 @@
+diff -Naur glib-1.2.10.orig/glib.h glib-1.2.10/glib.h
+--- glib-1.2.10.orig/glib.h	2001-02-27 04:44:38.000000000 +0100
++++ glib-1.2.10/glib.h	2004-05-27 15:50:32.436527848 +0200
+@@ -271,8 +271,10 @@
+ 
+ /* Wrap the gcc __PRETTY_FUNCTION__ and __FUNCTION__ variables with
+  * macros, so we can refer to them as strings unconditionally.
++ *
++ * Unfortunately these are _not_ treated as strings anymore in GCC3.4.
+  */
+-#ifdef	__GNUC__
++#if	defined(__GNUC__) && (__GNUC__ == 3 && __GNUC_MINOR__ < 4)
+ #define	G_GNUC_FUNCTION		__FUNCTION__
+ #define	G_GNUC_PRETTY_FUNCTION	__PRETTY_FUNCTION__
+ #else	/* !__GNUC__ */
-- 
cgit v0.12