From e0745cb76cc8eda2decea99ea693354cfd9980bf Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Thu, 30 Jul 2009 22:44:48 -0700
Subject: Myth2iPod:Adds m2iweb.php to allow for deletion of unwanted videos.

---
 abs/extra-testing/myth2ipod/PKGBUILD          |   5 +-
 abs/extra-testing/myth2ipod/m2iweb.php        | 157 ++++++++++++++++++++++++++
 abs/extra-testing/myth2ipod/myth2ipod.install |   8 +-
 3 files changed, 162 insertions(+), 8 deletions(-)
 create mode 100755 abs/extra-testing/myth2ipod/m2iweb.php

diff --git a/abs/extra-testing/myth2ipod/PKGBUILD b/abs/extra-testing/myth2ipod/PKGBUILD
index 80a8613..bfb7c91 100755
--- a/abs/extra-testing/myth2ipod/PKGBUILD
+++ b/abs/extra-testing/myth2ipod/PKGBUILD
@@ -1,12 +1,12 @@
 pkgname=myth2ipod
 pkgver=0.2
-pkgrel=17
+pkgrel=18
 arch=("i686")
 pkgdesc="A multimedia framework based on the MPEG-4 Systems standard"
 url="myth2ipod.com"
 depends=('gpac' 'nuvexport' )
 install="myth2ipod.install"
-source=( myth2ipod iPod.pm myth2ipod-userjob.sh)
+source=( myth2ipod iPod.pm myth2ipod-userjob.sh m2iweb.php)
 
 
 build() {
@@ -14,6 +14,7 @@ build() {
 	install -D -m 755 myth2ipod $startdir/pkg/usr/bin/myth2ipod
 	install -D -m 755 myth2ipod-userjob.sh /$startdir/pkg/usr/bin/myth2ipod-userjob.sh
 	install -D -m755 iPod.pm $startdir/pkg/usr/share/nuvexport/export/ffmpeg/iPod.pm
+	install -D -m755 m2iweb.php $startdir/pkg/myth/ipodfeed
 
 
 }
diff --git a/abs/extra-testing/myth2ipod/m2iweb.php b/abs/extra-testing/myth2ipod/m2iweb.php
new file mode 100755
index 0000000..a8a9e4d
--- /dev/null
+++ b/abs/extra-testing/myth2ipod/m2iweb.php
@@ -0,0 +1,157 @@
+<?
+//archive.php
+// based on m2iweb.php by http://anthony.lusby.us/m2iweb/
+//release 0.1
+//10/05/07
+?>
+
+<html>
+<head>
+    <title>MythWeb - Archive Recordings</title>
+
+    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
+
+    <script type="text/javascript" src="/mythweb/js/init.js"></script>
+    <script type="text/javascript" src="/mythweb/js/browser.js"></script>
+    <script type="text/javascript" src="/mythweb/js/utils.js"></script>
+
+    <script type="text/javascript" src="/mythweb/js/mouseovers.js"></script>
+    <script type="text/javascript" src="/mythweb/js/visibility.js"></script>
+    <script type="text/javascript" src="/mythweb/js/ajax.js"></script>
+
+    <link rel="stylesheet" type="text/css" href="/mythweb/skins/default/style.css" />
+    <link rel="stylesheet" type="text/css" href="/mythweb/skins/default/header.css" />
+    <link rel="stylesheet" type="text/css" href="/mythweb/skins/default/menus.css" />
+    <link rel="stylesheet" type="text/css" href="/mythweb/skins/default/programming.css" />
+
+    <link rel="stylesheet" type="text/css" href="/mythweb/skins/default/status.css" />
+
+</head>
+
+<body>
+
+<div id="page_header" class="clearfix">
+    <div id="logo_box">
+        <a id="mythtv_logo" href="/mythweb/">
+        <img src="/mythweb/skins/default/img/mythtv-logo.png" 
+width="174" height="48" border="0" alt="MythTV" class="alpha_png">
+        </a>
+
+    </div>
+    <div id="sections">
+        <a id="tv_link" href="/mythweb/tv" onmouseover="return help_text('TV functions, including recorded programs.')" onmouseout="return help_text()">
+            <img src="/mythweb/skins/default/img/tv.png" width="48" height="48" class="alpha_png" alt="MythTV"/>
+        </a>
+        <a id="video_link" href="/mythweb/video" onmouseover="return help_text('MythVideo on the web.')" onmouseout="return help_text()">
+            <img src="/mythweb/skins/default/img/video.png" width="48" height="48" class="alpha_png" alt="MythVideo" />
+        </a>
+        <a id="weather_link" href="/mythweb/weather" onmouseover="return help_text('MythWeb Weather.')" onmouseout="return help_text()">
+            <img src="/mythweb/skins/default/img/weather.png" width="48" height="48" class="alpha_png" alt="MythWeather" />
+        </a>
+        <a id="settings_link" href="/mythweb/settings" onmouseover="return help_text('Edit MythWeb and some MythTV settings.')" onmouseout="return help_text()">
+            <img src="/mythweb/skins/default/img/settings.png" width="48" height="48" class="alpha_png" alt="Settings" />
+        </a>
+    </div>
+    <div id="extra_header">
+        <div id="help_wrapper">
+            <div id="help_box">
+
+                <div id="help_text_default">
+                MythWeb: Mon May 16, 2006, 09:09 PM                </div>
+                <div id="help_text">
+                </div>
+            </div>
+        </div>
+        <div id="search" >
+            <form action="/mythweb/tv/search" method="post">
+
+                <div id="simple_search">
+                    <input id="search_text" type="text" name="searchstr" size="15" value="">
+                    <input id="search_submit" type="submit" class="submit" value="Search"> (<a href="/mythweb/tv/search">Advanced</a>)
+                </div>
+                <div id="search_options">
+                </div>
+            </form>
+
+        </div>
+    </div>
+</div>
+
+
+<table width="100%" border="0" cellspacing="2" cellpadding="0">
+<tr>
+
+    <td colspan="2" class="menu menu_border_t menu_border_b"><table class="body" width="100%" border="0" 
+
+cellspacing="2" cellpadding="2">
+        <tr>
+            <td><div id="command_choices">
+                    <a href="/mythweb/" id="category_legend" onmouseover="popup('category_legend'); return true;">MythTV:</a> &nbsp; &nbsp;
+
+                    <a href="/mythweb/tv/list">Listings</a>
+                    &nbsp; | &nbsp;
+                    <a href="/mythweb/tv/searches">Searches</a>
+                    &nbsp; | &nbsp;
+                    <a href="/mythweb/tv/schedules">Recording Schedules</a>
+                    (<a href="/mythweb/tv/schedules/manual">Manual</a>,
+                    <a href="/mythweb/tv/schedules/custom">Custom</a>)
+                    &nbsp; | &nbsp;
+                    <a href="/mythweb/tv/upcoming">Upcoming Recordings</a>
+                    &nbsp; | &nbsp;
+                    <a href="/mythweb/tv/recorded">Recorded Programs</a>
+                    &nbsp; | &nbsp;
+                    <a href="/ipodfeed/m2iweb.php">Myth2iPod</a>
+                    &nbsp; | &nbsp;
+                    <a href="/archive/archive.php">Myt2XviD3</a>
+                    &nbsp; | &nbsp;
+                    <a href="/mythweb/status">Backend Status</a>
+                </div></td>
+        </tr>
+        </table></td>
+
+</tr>
+</table>
+<table width="100%" border="0" cellpadding="4" cellspacing="2" class="list small">
+<tr><td colspan="10" class="list_separator">View information and delete myth2ipod recordings.</td></tr>
+<?php
+if (isset($_REQUEST['delete'])){
+$delete = $_REQUEST['delete'];
+if ($delete AND substr($delete, -9) == ".ipod.xml") {
+  echo '<br><font color="red">';
+  echo $delete;
+  unlink($delete) or print(" failed to be ");
+  echo 'deleted<br>';
+  $deletetoo = substr($delete, 0, -3)."mp4";
+  echo $deletetoo;
+  unlink($deletetoo) or print(" failed to be ");
+  echo 'deleted<br><br><a href="?">Home</a>';
+}
+}
+else {
+  $i=1;
+  foreach (glob("*.ipod.xml") as $file) {
+    $lines = file($file);
+    echo '<tr class="recorded"><td class="list">&nbsp;</td><td>';
+    echo '<font color="';
+    if (!file_exists(substr($file, 0, -3)."mp4")) {
+      echo "red";
+    }
+    echo '">'.$i.'</font>';
+    echo "</td></td><td><a href=".'"'.substr($file, 0, -3)."mp4".'"'."style='color:white'>".strip_tags($lines[1])."</a></td><td>".strip_tags($lines[7])."</td><td>".strip_tags($lines[6])."</td><td nowrap>".filesizeparse(filesize(substr($file, 0, -3)."mp4"))."</td><td>".'<a href="?delete='.$file.'" onclick="return confirm('."'Are you sure you want to delete?'".')">Delete</a>'."</td>".'<td class="list">&nbsp;</td>'."</tr>";
+    $i++;
+  }
+}
+function filesizeparse($size){
+  $i=0;
+  $iec = array(" B", " KB", " MB", " GB", " TB");
+  while (($size/1024)>1) {
+   $size=$size/1024;
+   $i++;
+  }
+  return substr($size,0,strpos($size,'.')+3).$iec[$i];
+}
+?>
+</table>
+</body>
+</html>
+</code>
diff --git a/abs/extra-testing/myth2ipod/myth2ipod.install b/abs/extra-testing/myth2ipod/myth2ipod.install
index 43e3e78..4a7e046 100755
--- a/abs/extra-testing/myth2ipod/myth2ipod.install
+++ b/abs/extra-testing/myth2ipod/myth2ipod.install
@@ -18,21 +18,17 @@ post_install() {
 	ln -s /myth/ipodfeed /data/srv/httpd/htdocs/ipodfeed
 	cp /usr/bin/myth2ipod /tmp
 	sed -e "s/REPLACEME/$hostname/g" /tmp/myth2ipod > /usr/bin/myth2ipod
+	chown -R mythtv:http /myth/ipodfeed
 	
 	
 }
 
 post_upgrade() {
- 
-	
-	mkdir /myth/ipodfeed
-	chown mythtv:users /myth/ipodfeed
-	ln -s /myth/ipodfeed /data/srv/httpd/htdocs/ipodfeed
 	 /usr/bin/myth2ipod -rebuild
 }
 
 post_remove() {
-  post_install
+ 	rm -fr /data/srv/httpd/htdocs/ipodfeed 
 }
 
 op=$1
-- 
cgit v0.12