From 80973a1e434e479bc83f71ad4914addea4ef9f70 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 13 Oct 2008 12:31:29 -0500
Subject: Add check & delay for usb cdroms

---
 abs/core-testing/linhes-live/PKGBUILD                  | 3 ++-
 abs/core-testing/linhes-live/lib/initcpio/hooks/larch1 | 5 +++++
 2 files changed, 7 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/linhes-live/PKGBUILD b/abs/core-testing/linhes-live/PKGBUILD
index d497fcf..1c7fa71 100644
--- a/abs/core-testing/linhes-live/PKGBUILD
+++ b/abs/core-testing/linhes-live/PKGBUILD
@@ -2,7 +2,7 @@
 # 2008.09.25
 pkgname=linhes-live
 pkgver=5.3.3
-pkgrel=4
+pkgrel=5
 
 pkgdesc="LinHes compulsory components for the Live System."
 url="http://KnoppMyth.net"
@@ -28,3 +28,4 @@ build() {
 }
 
 # End
+#change hook1 to wait for usb cdroms
diff --git a/abs/core-testing/linhes-live/lib/initcpio/hooks/larch1 b/abs/core-testing/linhes-live/lib/initcpio/hooks/larch1
index e1a3753..88ccc3e 100644
--- a/abs/core-testing/linhes-live/lib/initcpio/hooks/larch1
+++ b/abs/core-testing/linhes-live/lib/initcpio/hooks/larch1
@@ -115,6 +115,11 @@ run_hook ()
                 test_live_data_dir "${d}" "${cdmount}"
                 if [ $? -eq 0 ]; then break 2; fi
             done
+            msg_ ":: Searching for usb cdroms .."
+            for d in /dev/sr[0-9]*; do
+                test_live_data_dir "${d}" "${cdmount}"
+                if [ $? -eq 0 ]; then break 2; fi
+            done
         done
     fi
 }
-- 
cgit v0.12