From 234112a91175666fe6395e6f2164b915b6208aed Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 28 Jun 2009 16:36:43 -0700
Subject: Bumped version to recompile for ntfs-3g support.

---
 abs/core-testing/udev/PKGBUILD           |   5 +-
 abs/core-testing/udev/udev-ntfs-3g.patch | 217 +++++++++++++++++++++++++++++++
 2 files changed, 220 insertions(+), 2 deletions(-)
 create mode 100644 abs/core-testing/udev/udev-ntfs-3g.patch

diff --git a/abs/core-testing/udev/PKGBUILD b/abs/core-testing/udev/PKGBUILD
index bd4c394..15c514c 100644
--- a/abs/core-testing/udev/PKGBUILD
+++ b/abs/core-testing/udev/PKGBUILD
@@ -4,7 +4,7 @@
 # Maintainer: Thomas Bächler <thomas@archlinux.org>
 pkgname=udev
 pkgver=135
-pkgrel=2
+pkgrel=3
 pkgdesc="The userspace dev tools (udev)"
 arch=(i686 x86_64)
 url="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
@@ -24,7 +24,7 @@ conflicts=('initscripts<2008.02')
 options=(!makeflags)
 source=(http://www.kernel.org/pub/linux/utils/kernel/hotplug/$pkgname-$pkgver.tar.bz2
         81-arch.rules load-modules.sh resolve-modalias.c cdsymlinks.sh root-link.sh
-        arch-udev-rules.patch readme-udev-arch.txt usb-storage.rules)
+        arch-udev-rules.patch readme-udev-arch.txt usb-storage.rules udev-ntfs-3g.patch)
 md5sums=('661b9df34e1304dad10f595d95b472bb'
          '3a955ca8e2122a48a223f9d8adf87b70'
          'f4951f61438d69894b728212dac7318b'
@@ -37,6 +37,7 @@ md5sums=('661b9df34e1304dad10f595d95b472bb'
 
 build() {
   cd $srcdir/$pkgname-$pkgver
+  patch -p1 < ../udev-ntfs-3g.patch || return 1
   ./configure --prefix="" --mandir=/usr/share/man --includedir=/usr/include
   make || return 1
   make DESTDIR=$startdir/pkg install
diff --git a/abs/core-testing/udev/udev-ntfs-3g.patch b/abs/core-testing/udev/udev-ntfs-3g.patch
new file mode 100644
index 0000000..366c41f
--- /dev/null
+++ b/abs/core-testing/udev/udev-ntfs-3g.patch
@@ -0,0 +1,217 @@
+diff -ruaN udev-135.orig/extras/volume_id/lib/ntfs.c udev-135/extras/volume_id/lib/ntfs.c
+--- udev-135.orig/extras/volume_id/lib/ntfs.c	2008-11-13 20:42:56.000000000 +0000
++++ udev-135/extras/volume_id/lib/ntfs.c	2009-06-28 23:31:01.000000000 +0000
+@@ -194,7 +194,7 @@
+ 	}
+ 
+ 	volume_id_set_usage(id, VOLUME_ID_FILESYSTEM);
+-	id->type = "ntfs";
++	id->type = "ntfs-3g";
+ 	/* we think this is ntfs, but we make sure no other signatures are found */
+ 	id->force_unique_result = 1;
+ 	return 0;
+diff -ruaN udev-135.orig/extras/volume_id/lib/ntfs.c~ udev-135/extras/volume_id/lib/ntfs.c~
+--- udev-135.orig/extras/volume_id/lib/ntfs.c~	1970-01-01 00:00:00.000000000 +0000
++++ udev-135/extras/volume_id/lib/ntfs.c~	2008-11-13 20:42:56.000000000 +0000
+@@ -0,0 +1,201 @@
++/*
++ * volume_id - reads filesystem label and uuid
++ *
++ * Copyright (C) 2004 Kay Sievers <kay.sievers@vrfy.org>
++ *
++ * This program is free software: you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation, either version 2 of the License, or
++ * (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ * GNU General Public License for more details.
++ *
++ * You should have received a copy of the GNU General Public License
++ * along with this program.  If not, see <http://www.gnu.org/licenses/>.
++ */
++
++#ifndef _GNU_SOURCE
++#define _GNU_SOURCE 1
++#endif
++
++#include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <string.h>
++#include <errno.h>
++#include <ctype.h>
++
++#include "libvolume_id.h"
++#include "libvolume_id-private.h"
++
++static struct ntfs_super_block {
++	uint8_t		jump[3];
++	uint8_t		oem_id[8];
++	uint16_t	bytes_per_sector;
++	uint8_t		sectors_per_cluster;
++	uint16_t	reserved_sectors;
++	uint8_t		fats;
++	uint16_t	root_entries;
++	uint16_t	sectors;
++	uint8_t		media_type;
++	uint16_t	sectors_per_fat;
++	uint16_t	sectors_per_track;
++	uint16_t	heads;
++	uint32_t	hidden_sectors;
++	uint32_t	large_sectors;
++	uint16_t	unused[2];
++	uint64_t	number_of_sectors;
++	uint64_t	mft_cluster_location;
++	uint64_t	mft_mirror_cluster_location;
++	int8_t		cluster_per_mft_record;
++	uint8_t		reserved1[3];
++	int8_t		cluster_per_index_record;
++	uint8_t		reserved2[3];
++	uint8_t		volume_serial[8];
++	uint16_t	checksum;
++} PACKED *ns;
++
++static struct master_file_table_record {
++	uint8_t		magic[4];
++	uint16_t	usa_ofs;
++	uint16_t	usa_count;
++	uint64_t	lsn;
++	uint16_t	sequence_number;
++	uint16_t	link_count;
++	uint16_t	attrs_offset;
++	uint16_t	flags;
++	uint32_t	bytes_in_use;
++	uint32_t	bytes_allocated;
++} PACKED *mftr;
++
++static struct file_attribute {
++	uint32_t	type;
++	uint32_t	len;
++	uint8_t		non_resident;
++	uint8_t		name_len;
++	uint16_t	name_offset;
++	uint16_t	flags;
++	uint16_t	instance;
++	uint32_t	value_len;
++	uint16_t	value_offset;
++} PACKED *attr;
++
++static struct volume_info {
++	uint64_t	reserved;
++	uint8_t		major_ver;
++	uint8_t		minor_ver;
++} PACKED *info;
++
++#define MFT_RECORD_VOLUME			3
++#define MFT_RECORD_ATTR_VOLUME_NAME		0x60
++#define MFT_RECORD_ATTR_VOLUME_INFO		0x70
++#define MFT_RECORD_ATTR_OBJECT_ID		0x40
++#define MFT_RECORD_ATTR_END			0xffffffffu
++
++int volume_id_probe_ntfs(struct volume_id *id, uint64_t off, uint64_t size)
++{
++	unsigned int sector_size;
++	unsigned int cluster_size;
++	uint64_t mft_cluster;
++	uint64_t mft_off;
++	unsigned int mft_record_size;
++	unsigned int attr_type;
++	unsigned int attr_off;
++	unsigned int attr_len;
++	unsigned int val_off;
++	unsigned int val_len;
++	const uint8_t *buf;
++	const uint8_t *val;
++
++	info("probing at offset 0x%" PRIx64 "\n", off);
++
++	ns = (struct ntfs_super_block *) volume_id_get_buffer(id, off, 0x200);
++	if (ns == NULL)
++		return -1;
++
++	if (memcmp(ns->oem_id, "NTFS", 4) != 0)
++		return -1;
++
++	volume_id_set_uuid(id, ns->volume_serial, 0, UUID_64BIT_LE);
++
++	sector_size = le16_to_cpu(ns->bytes_per_sector);
++	if (sector_size < 0x200)
++		return -1;
++
++	cluster_size = ns->sectors_per_cluster * sector_size;
++	mft_cluster = le64_to_cpu(ns->mft_cluster_location);
++	mft_off = mft_cluster * cluster_size;
++
++	if (ns->cluster_per_mft_record < 0)
++		/* size = -log2(mft_record_size); normally 1024 Bytes */
++		mft_record_size = 1 << -ns->cluster_per_mft_record;
++	else
++		mft_record_size = ns->cluster_per_mft_record * cluster_size;
++
++	dbg("sectorsize  0x%x\n", sector_size);
++	dbg("clustersize 0x%x\n", cluster_size);
++	dbg("mftcluster  %" PRIu64 "\n", mft_cluster);
++	dbg("mftoffset  0x%" PRIx64 "\n", mft_off);
++	dbg("cluster per mft_record  %i\n", ns->cluster_per_mft_record);
++	dbg("mft record size  %i\n", mft_record_size);
++
++	buf = volume_id_get_buffer(id, off + mft_off + (MFT_RECORD_VOLUME * mft_record_size),
++			 mft_record_size);
++	if (buf == NULL)
++		return -1;
++
++	mftr = (struct master_file_table_record*) buf;
++	dbg("mftr->magic '%c%c%c%c'\n", mftr->magic[0], mftr->magic[1], mftr->magic[2], mftr->magic[3]);
++	if (memcmp(mftr->magic, "FILE", 4) != 0)
++		return -1;
++
++	attr_off = le16_to_cpu(mftr->attrs_offset);
++	dbg("file $Volume's attributes are at offset %i\n", attr_off);
++
++	while (1) {
++		attr = (struct file_attribute*) &buf[attr_off];
++		attr_type = le32_to_cpu(attr->type);
++		attr_len = le16_to_cpu(attr->len);
++		val_off = le16_to_cpu(attr->value_offset);
++		val_len = le32_to_cpu(attr->value_len);
++		attr_off += attr_len;
++
++		if (attr_len == 0)
++			break;
++
++		if (attr_off >= mft_record_size)
++			break;
++
++		if (attr_type == MFT_RECORD_ATTR_END)
++			break;
++
++		dbg("found attribute type 0x%x, len %i, at offset %i\n",
++		    attr_type, attr_len, attr_off);
++
++		if (attr_type == MFT_RECORD_ATTR_VOLUME_INFO) {
++			dbg("found info, len %i\n", val_len);
++			info = (struct volume_info*) (((uint8_t *) attr) + val_off);
++			snprintf(id->type_version, sizeof(id->type_version)-1,
++				 "%u.%u", info->major_ver, info->minor_ver);
++		}
++
++		if (attr_type == MFT_RECORD_ATTR_VOLUME_NAME) {
++			dbg("found label, len %i\n", val_len);
++			if (val_len > VOLUME_ID_LABEL_SIZE)
++				val_len = VOLUME_ID_LABEL_SIZE;
++
++			val = ((uint8_t *) attr) + val_off;
++			volume_id_set_label_raw(id, val, val_len);
++			volume_id_set_label_unicode16(id, val, LE, val_len);
++		}
++	}
++
++	volume_id_set_usage(id, VOLUME_ID_FILESYSTEM);
++	id->type = "ntfs";
++	/* we think this is ntfs, but we make sure no other signatures are found */
++	id->force_unique_result = 1;
++	return 0;
++}
-- 
cgit v0.12


From 58db8115919893836ab272390a21f1fcd61b3009 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 28 Jun 2009 21:20:25 -0500
Subject: linhes-config: revert changes that break the build & remove
 config_diskless as it moved to diskless-legacy.

---
 abs/core-testing/LinHES-config/PKGBUILD | 42 +++------------------------------
 1 file changed, 3 insertions(+), 39 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 2998dfc..8a17408 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,14 +1,12 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=28
+pkgrel=29
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
 arch=('i686')
 
-source=(mv_install.py mv_config.py 
-#mythinstall.bin 
-myth_user_call file_time_offset.py install-ui.xml install_proxy.sh install_functions.sh systemconfig.sh install_db_chroot.sh restore_default_settings.sh xconfig.sh timezip.py soundconfig.sh LinHES-release issue MythVantage.sh create_master.sh build_diskless.sh networkconfig.sh timezone.bin autocard.py restore_km_db_chroot.sh README  mv_advanced.py  mv_common.py   mv_ir.py  mv_misc.py  mv_network.py  mv_screensaver.py  mv_smolt.py  mv_software.py  mv_webuser.py mv_hostype.py systemconfig.py)
+source=(mv_install.py mv_config.py mythinstall.bin myth_user_call file_time_offset.py install-ui.xml install_proxy.sh install_functions.sh systemconfig.sh install_db_chroot.sh restore_default_settings.sh xconfig.sh timezip.py soundconfig.sh LinHES-release issue MythVantage.sh create_master.sh build_diskless.sh networkconfig.sh timezone.bin autocard.py restore_km_db_chroot.sh README  mv_advanced.py  mv_common.py   mv_ir.py  mv_misc.py  mv_network.py  mv_screensaver.py  mv_smolt.py  mv_software.py  mv_webuser.py mv_hostype.py systemconfig.py)
 
 install=LinHES.install
 build() {
@@ -65,44 +63,10 @@ build() {
     install -m 0755 install-ui.xml $startdir/pkg/usr/share/mythtv/themes/default/
 
     #copy in the binaries
-#    install  -m 4755 mythinstall.bin $MVDIR/bin/MythVantage
+    install  -m 4755 mythinstall.bin $MVDIR/bin/MythVantage
     cd $MVDIR/bin
     ln -s MythVantage mythvantage
     ln -s MythVantage mythinstall
     cd -
 }
 
-md5sums=('97a75e1c2d780881566d3388532ac0f7'
-         '40e3173b3f98beb1d94320eef3b60854'
-         'e36da536dd651ef182e7642337889e77'
-         '3baa23764e1b6bcb2d66d7d859096940'
-         'd6009f9a4ff3238aa911d6e61a8c675a'
-         'd7a8cd4a0060399ae22e69f74e04eb07'
-         '0abe8d207147eeb306743640e33e4757'
-         'f88d2fb88339a4bf8ec9217a3fbcdef7'
-         '8ac1cfd2eca0f641737da0d0aca416a7'
-         'd8a4a1699e04eed9ee69d58616069f33'
-         '3a91b587179be4fecb2549e46821708e'
-         'a02a7c0c59a1cc96d88137a41354c96a'
-         'e459ed069317bccb20351f037a9df3d2'
-         'd092238975aafaac4ec576d34303f762'
-         '6aff504ed5e860adc1b7317cd0780900'
-         '55fccb1da0417a896b724f7cfc32dd5a'
-         'ab2aa42c2947148c2b1cac0ade6d1d55'
-         'd429b59d3cfb37b0624c6a4a71a7c2c0'
-         'a225143e3df6f56d451c2875e54ddbae'
-         '1ee558ee9efec54016cb4c87c61e569c'
-         '687555968d4ca688d8f95c8f13e1d8d4'
-         '3d1e4a119f38cff0498bf8a67e94e4b3'
-         'e9cfd0ccad3a984520780947b2f420bd'
-         '5ad4a57fe6bd53ea6a5820751c476e4d'
-         'cf0113438a4916a8d815a3b7bde50c42'
-         '4aa795a1f5d789d5532a752606eca4df'
-         '65d93f15ac85adf8299552581789a731'
-         'a6c9cd6cf243daea737e4ed601c88567'
-         '32385482ecc1275409b71f08d8b03acc'
-         'da0a2fb1e3cdbabac1f62e8b908c5d7f'
-         '30e527552ae86eb90d5c2169c6316fd1'
-         'f19917bed3a1e00cbe08838bee18b4b7'
-         '08282647ebf7e563cb9f3bc2ad8aee14'
-         'd53f305749abdf5fca176f50b40df4fc')
-- 
cgit v0.12


From 7679baf94f5951e1dae312f4f64487f3d2d61d66 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 28 Jun 2009 21:22:32 -0500
Subject: test commit

---
 abs/core-testing/LinHES-config/live-install.sh | 1 +
 1 file changed, 1 insertion(+)

diff --git a/abs/core-testing/LinHES-config/live-install.sh b/abs/core-testing/LinHES-config/live-install.sh
index 573bb1f..0f8301e 100755
--- a/abs/core-testing/LinHES-config/live-install.sh
+++ b/abs/core-testing/LinHES-config/live-install.sh
@@ -1,4 +1,5 @@
 #!/bin/bash
+#
 #redirect stderr to stdout, then rediret stdout to file
 . /etc/profile
 exec 2>&1
-- 
cgit v0.12


From 756512a2e8a41dc2c29d910a5911e8b625de7a99 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 28 Jun 2009 21:27:51 -0500
Subject: remove test commit

---
 abs/core-testing/LinHES-config/live-install.sh | 1 -
 1 file changed, 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/live-install.sh b/abs/core-testing/LinHES-config/live-install.sh
index 0f8301e..573bb1f 100755
--- a/abs/core-testing/LinHES-config/live-install.sh
+++ b/abs/core-testing/LinHES-config/live-install.sh
@@ -1,5 +1,4 @@
 #!/bin/bash
-#
 #redirect stderr to stdout, then rediret stdout to file
 . /etc/profile
 exec 2>&1
-- 
cgit v0.12


From 7b8ad87e6071e6aada4f190b7b6cb7b77baef742 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 28 Jun 2009 21:51:14 -0500
Subject: ntfs-3g: bumped version to avoid conflict on the next sync.

---
 abs/core-testing/ntfs-3g/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/ntfs-3g/PKGBUILD b/abs/core-testing/ntfs-3g/PKGBUILD
index 738f131..9529a86 100644
--- a/abs/core-testing/ntfs-3g/PKGBUILD
+++ b/abs/core-testing/ntfs-3g/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=ntfs-3g
 pkgver=2009.4.4
-pkgrel=1
+pkgrel=2
 pkgdesc="Stable read and write NTFS driver"
 url="http://www.ntfs-3g.org/"
 arch=('i686' 'x86_64')
-- 
cgit v0.12


From 27eacb8e624358f8fd3f3795ed3ab432194e88ee Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 28 Jun 2009 20:16:00 -0700
Subject: Added install file for ntfs-3g.

---
 abs/core-testing/ntfs-3g/PKGBUILD        |  3 ++-
 abs/core-testing/ntfs-3g/ntfs-3g.install | 15 +++++++++++++++
 2 files changed, 17 insertions(+), 1 deletion(-)
 create mode 100644 abs/core-testing/ntfs-3g/ntfs-3g.install

diff --git a/abs/core-testing/ntfs-3g/PKGBUILD b/abs/core-testing/ntfs-3g/PKGBUILD
index 738f131..d25ce4a 100644
--- a/abs/core-testing/ntfs-3g/PKGBUILD
+++ b/abs/core-testing/ntfs-3g/PKGBUILD
@@ -4,11 +4,12 @@
 
 pkgname=ntfs-3g
 pkgver=2009.4.4
-pkgrel=1
+pkgrel=2
 pkgdesc="Stable read and write NTFS driver"
 url="http://www.ntfs-3g.org/"
 arch=('i686' 'x86_64')
 license=('GPL2')
+install=ntfs-3g.install
 depends=('glibc')
 makedepends=('pkgconfig')
 options=('!libtool')
diff --git a/abs/core-testing/ntfs-3g/ntfs-3g.install b/abs/core-testing/ntfs-3g/ntfs-3g.install
new file mode 100644
index 0000000..ad8cc1b
--- /dev/null
+++ b/abs/core-testing/ntfs-3g/ntfs-3g.install
@@ -0,0 +1,15 @@
+# arg 1:  the new package version
+post_install() {
+	ln -s /sbin/mount.ntfs-3g /sbin/mount.ntfs
+}
+# arg 1:  the new package version
+# arg 2:  the old package version
+
+# arg 1:  the old package version
+post_remove() {
+	rm -fr /sbin/mount.ntfs
+}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12


From cc5a2ac4040db2f70e72a4f3bb3d6d21a8d18440 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 28 Jun 2009 20:17:59 -0700
Subject: Bumped to recompile.

---
 abs/core-testing/ntfs-3g/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/ntfs-3g/PKGBUILD b/abs/core-testing/ntfs-3g/PKGBUILD
index d25ce4a..a8ae6e5 100644
--- a/abs/core-testing/ntfs-3g/PKGBUILD
+++ b/abs/core-testing/ntfs-3g/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=ntfs-3g
 pkgver=2009.4.4
-pkgrel=2
+pkgrel=3
 pkgdesc="Stable read and write NTFS driver"
 url="http://www.ntfs-3g.org/"
 arch=('i686' 'x86_64')
-- 
cgit v0.12


From a3ad759091d9d59ba9663394b685f2d676f9d1c5 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 28 Jun 2009 20:23:13 -0700
Subject: Redirects to the right port for fuppes.

---
 abs/core-testing/local-website/PKGBUILD          | 2 +-
 abs/core-testing/local-website/htdocs/fuppes.php | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/abs/core-testing/local-website/PKGBUILD b/abs/core-testing/local-website/PKGBUILD
index 6ce813c..a47c062 100644
--- a/abs/core-testing/local-website/PKGBUILD
+++ b/abs/core-testing/local-website/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=local-website
 pkgver=2
-pkgrel=7
+pkgrel=8
 pkgdesc="Contents of http://localhost"
 arch=(i686 x86_64)
 license=('GPL')
diff --git a/abs/core-testing/local-website/htdocs/fuppes.php b/abs/core-testing/local-website/htdocs/fuppes.php
index f082f31..44129d2 100644
--- a/abs/core-testing/local-website/htdocs/fuppes.php
+++ b/abs/core-testing/local-website/htdocs/fuppes.php
@@ -1,4 +1,4 @@
 <?php
 $HTTP_HOST = getenv('HTTP_HOST');
-header("Location: http://$HTTP_HOST:81/");
+header("Location: http://$HTTP_HOST:8100/");
 ?>
-- 
cgit v0.12


From 649b5da147f6d2107142c596c915f23b06f9bea1 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 29 Jun 2009 11:28:57 -0500
Subject: linhes-config: set first parition to active on new installs.

---
 abs/core-testing/LinHES-config/PKGBUILD      |  2 +-
 abs/core-testing/LinHES-config/mv_install.py | 14 ++++++++++++++
 2 files changed, 15 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 8a17408..984926b 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.0
-pkgrel=29
+pkgrel=31
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index 9d70a55..e96dd56 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -307,6 +307,19 @@ def create_partitions(diskdevice, size, ptype, startsector):
                 (newpart.getDeviceNodeName(),  newpart.getSize(),  diskdevice))
     return newpart.getDeviceNodeName()
 
+def set_active_parition(diskdevice):
+        """ Set the bootable flag for this partition. """
+        logging.debug("    Setting active parition")
+        device = parted.getDevice(diskdevice)
+        partdisk = parted.Disk(device)
+        try:
+            for partition in partdisk.partitions:
+                partition.setFlag(parted.PARTITION_BOOT)
+            partdisk.commit()
+        except:
+            logging.info("    Couldn't set the active partition")
+            logging.info("    Depending on your system this may not matter")
+
 
 def partition_disk():
     global hostoptions
@@ -319,6 +332,7 @@ def partition_disk():
     label = "data"
     partitions_removeall("/dev/"+datadisk, label)
     hostoptions["rootpartition"] = create_partitions("/dev/"+rootdisk, hostoptions["rootsize"], "NORMAL", 0)
+    set_active_parition("/dev/"+rootdisk)
     hostoptions["swappartition"] = create_partitions("/dev/"+rootdisk, hostoptions["swapsize"], "SWAP", 1)
     if datadisk != rootdisk:
         hostoptions["datapartition"] = create_partitions("/dev/"+datadisk, hostoptions["datasize"], "NORMAL", 0)
-- 
cgit v0.12