From 2e70bd6665c0348df10050a0d2c88f98bad6741c Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 4 Sep 2010 16:01:09 -0700
Subject: imlib2:Bumped/Updated for LinHES 7.

---
 abs/core-testing/imlib2/PKGBUILD | 44 +++++++++++++++++++++++-----------------
 1 file changed, 25 insertions(+), 19 deletions(-)

diff --git a/abs/core-testing/imlib2/PKGBUILD b/abs/core-testing/imlib2/PKGBUILD
index b465ca2..0307519 100644
--- a/abs/core-testing/imlib2/PKGBUILD
+++ b/abs/core-testing/imlib2/PKGBUILD
@@ -1,28 +1,34 @@
-# $Id: PKGBUILD 2921 2008-06-15 20:14:02Z eric $
-# Maintainer: arjan <arjan@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# $Id: PKGBUILD 79752 2010-05-06 13:39:04Z ronald $
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Arjan Timmerman <arjan.archlinux.org>
+# Contributor: Tom Newsom <Jeepster.gmx.co.uk>
+
 pkgname=imlib2
-pkgver=1.4.1
-pkgrel=2
-pkgdesc="Imlib2 is the successor to Imlib. It is NOT a newer version -- Imlib 2 can be installed alongside Imlib 1.x"
-arch=(i686 x86_64)
-url="http://sourceforge.net/projects/enlightenment"
+pkgver=1.4.4
+pkgrel=1
+pkgdesc="Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support"
+url="http://sourceforge.net/projects/enlightenment/"
+arch=('i686' 'x86_64')
 license=('BSD')
-depends=('libtiff' 'giflib' 'bzip2' 'freetype2' 'libxext' 'libpng' 'libid3tag')
+depends=('libtiff>=3.9.2-2' 'giflib' 'bzip2' 'freetype2' 'libxext' 'libpng>=1.4.0' 'libid3tag' 'libjpeg>=8')
 options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/enlightenment/$pkgname-$pkgver.tar.gz)
-md5sums=('16a3d885e523303be794282c0ed90841')
+source=("http://downloads.sourceforge.net/enlightenment/$pkgname-$pkgver.tar.bz2")
+sha1sums=('aca2cf5d40ddcd8a3acfde605f319fccce7c2a2b')
 
 build() {
-  cd $startdir/src/$pkgname-$pkgver
+  cd $srcdir/$pkgname-$pkgver
 
-  # Enable x86 MMX optimizations for i686 (32-bit assembler code not compatible with x86_64)
-  [ "${CARCH}" = "i686" ] && EXTRAOPTS="--disable-mmx"
-  # Disable AMD64 optimizations due to bug in assembler code
-  [ "${CARCH}" = "x86_64" ] && EXTRAOPTS="--disable-amd64"
+  # disable optimizations, they cause problems (e.g. FS#12268)
+  [ $CARCH = "i686" ] && EXTRAOPTS="--disable-mmx"
+  [ $CARCH = "x86_64" ] && EXTRAOPTS="--disable-amd64"
 
-  ./configure --prefix=/usr --sysconfdir=/etc/imlib2 --x-libraries=/usr/lib $EXTRAOPTS
+  # Configure and Build
+  ./configure --prefix=/usr \
+              --sysconfdir=/etc/imlib2 \
+              --x-libraries=/usr/lib $EXTRAOPTS || return 1
   make || return 1
-  make DESTDIR=$startdir/pkg install
-  install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/LICENSE.txt
+  make DESTDIR=$pkgdir install || return 1
+
+  # Install License
+  install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
 }
-- 
cgit v0.12