From 7cfb5b2b2731f9b05f0490ae2e4ee828788b6347 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 29 Mar 2010 18:37:14 -0500
Subject: mythsmolt: This is  fix for the smolt prompt on logout, and the
 opening of any bash shell that my last smolt commit caused.

---
 .../mythtv/stable-0.22/mythsmolt/PKGBUILD          |  4 +-
 .../stable-0.22/mythsmolt/smolt_init_login.sh      | 47 ++++++++++++++--------
 2 files changed, 33 insertions(+), 18 deletions(-)

diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
index 42674dd..d970cd9 100644
--- a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythsmolt
 pkgver=0.22
-pkgrel=17
+pkgrel=26
 pkgdesc="mythsmolt, a hardware profileing tool"
 arch=('i686' 'x86_64')
 url="http://www.mythvantage.com"
@@ -18,4 +18,4 @@ build() {
    install -D -m 755 $srcdir/smolt_init_login.sh $pkgdir/etc/profile.d/smolt_init_login.sh
 }
 md5sums=('fdf68ec5c78827aefca6f09ad82296a4'
-         'c6789befd70278a453dc6be73ed240e7')
+         '57a3416d90e59abbd5062436583c17e1')
diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
index f22a09e..0b76305 100644
--- a/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
@@ -1,24 +1,39 @@
 if [ $UID = 0  -o  $UID = 1000 ]
 then
-    if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+    INIT=`ps -p 1 -o comm=`
+    if [ x$INIT = xrunit ]
     then
-        echo ""
-        echo "####################################################"
-        echo "It appears you have not yet run smolt"
-        echo "Please take the time to submit your hardware profile"
-        echo ""
-        echo "press any key to continue:"
-        echo "####################################################"
-        read a
-        if [ $UID = 0 ]
+        if [[ -f /home/mythtv/.configure  &&  $- = *i* ]]
         then
-            su   mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py"
-            su mythtv -c "touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid"
-        else
-            /usr/share/mythtv/mythsmolt/scripts/sendProfile.py
-            touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid
+            if  [ ! -z "$PS1" ]
+            then
+                if  [ $0 = "-bash" ]
+                then
+                    if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+                    then
+                        echo ""
+                        echo "####################################################"
+                        echo "It appears you have not yet run smolt"
+                        echo "Please take the time to submit your hardware profile"
+                        echo ""
+                        echo "press any key to continue:"
+                        echo "####################################################"
+                        read a
+                        mkdir -p /home/mythtv/.mythtv/MythSmolt
+                        chown -R mythtv:users /home/mythtv/.mythtv/MythSmolt
+
+                        if [ $UID = 0 ]
+                        then
+                            su   mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py" &&   su mythtv -c "touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid"
+                        else
+                            /usr/share/mythtv/mythsmolt/scripts/sendProfile.py &&  touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid
+                        fi
+                    fi
+                fi
+            fi
         fi
-        
     fi
 fi
 
+
+
-- 
cgit v0.12