From d4bacc96648622c1f755d3e4e2f7462f1b644d83 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 2 Nov 2008 13:46:23 -0600
Subject: create the .configure file for use on firstboot config stuff.

---
 abs/core-testing/live-installer/PKGBUILD         | 2 +-
 abs/core-testing/live-installer/install_proxy.sh | 3 +++
 2 files changed, 4 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/live-installer/PKGBUILD b/abs/core-testing/live-installer/PKGBUILD
index 7851c4a..d6addaa 100755
--- a/abs/core-testing/live-installer/PKGBUILD
+++ b/abs/core-testing/live-installer/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=live-installer
 pkgver=1.0
-pkgrel=58
+pkgrel=59
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan)
 arch=('i686')
diff --git a/abs/core-testing/live-installer/install_proxy.sh b/abs/core-testing/live-installer/install_proxy.sh
index f39b3d4..a9b52a5 100755
--- a/abs/core-testing/live-installer/install_proxy.sh
+++ b/abs/core-testing/live-installer/install_proxy.sh
@@ -138,6 +138,8 @@ full_install () {
             fi
     fi
     chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh advanced
+    touch $mountpoint/home/mythtv/.configure && chmod 777 $mountpoint/home/mythtv/.configure
+    
     echo "Done" > /tmp/.install_state
     cp /tmp/mythvantage_install.log  $mountpoint/var/log/
     $run unmount_it $disk
@@ -224,6 +226,7 @@ function upgrade () {
         chmod -R 755 ${mountpoint}/root
         chown root:mythtv "$mountpoint"/etc/systemconfig
         chmod 775 "$mountpoint"/etc/systemconfig
+	touch $mountpoint/home/mythtv/.configure && chmod 777 $mountpoint/home/mythtv/.configure
         #mount /proc and /dev
          mount --bind /dev "$mountpoint/dev"
          mount --bind /proc "$mountpoint/proc"
-- 
cgit v0.12