From 48d52bfd8aa711b7e184124f238b2a3cea512318 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 20 Jan 2016 21:33:23 +0000
Subject: gtk3: update to 3.18.6

---
 ...o-cursor-name-fallback-for-standard-names.patch | 85 +++++++++++++++++++
 ...y-do-cursor-name-fallback-for-standard-na.patch | 94 ++++++++++++++++++++++
 abs/extra/gtk3/PKGBUILD                            | 53 +++++++++---
 abs/extra/gtk3/gtk-update-icon-cache.install       |  3 +
 abs/extra/gtk3/settings.ini                        |  2 +-
 abs/extra/gtk3/wacom.patch                         | 12 ---
 6 files changed, 224 insertions(+), 25 deletions(-)
 create mode 100644 abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
 create mode 100644 abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
 create mode 100644 abs/extra/gtk3/gtk-update-icon-cache.install
 delete mode 100644 abs/extra/gtk3/wacom.patch

diff --git a/abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch b/abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
new file mode 100644
index 0000000..d187d40
--- /dev/null
+++ b/abs/extra/gtk3/0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
@@ -0,0 +1,85 @@
+From affd6e70734d7897324409d6fc0beb7b4eb7235a Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Wed, 6 Jan 2016 14:54:33 -0500
+Subject: [PATCH 1/2] x11: Only do cursor name fallback for standard names
+
+Always returning a left_ptr if we can't find anything better
+broke firefox application-specific fallback for missing cursors.
+Keep that working by only doing the fallback for the CSS cursor
+names, not for things like hashes.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=760141
+---
+ gdk/x11/gdkcursor-x11.c | 24 ++++++++++++++++++++----
+ 1 file changed, 20 insertions(+), 4 deletions(-)
+
+diff --git a/gdk/x11/gdkcursor-x11.c b/gdk/x11/gdkcursor-x11.c
+index 540f48e..d619f58 100644
+--- a/gdk/x11/gdkcursor-x11.c
++++ b/gdk/x11/gdkcursor-x11.c
+@@ -611,17 +611,23 @@ static const struct {
+   const gchar *css_name, *traditional_name;
+ } name_map[] = {
+   { "default",      "left_ptr" },
++  { "help",         "left_ptr" },
++  { "context-menu", "left_ptr" },
+   { "pointer",      "hand" },
+   { "progress",     "left_ptr_watch" },
+   { "wait",         "watch" },
+   { "cell",         "crosshair" },
+   { "crosshair",    "cross" },
+   { "text",         "xterm" },
++  { "vertical-text","xterm" },
+   { "alias",        "dnd-link" },
+   { "copy",         "dnd-copy" },
++  { "move",         "dnd-move" },
+   { "no-drop",      "dnd-none" },
+   { "not-allowed",  "crossed_circle" },
+   { "grab",         "hand2" },
++  { "grabbing",     "hand2" },
++  { "all-scroll",   "left_ptr" },
+   { "col-resize",   "h_double_arrow" },
+   { "row-resize",   "v_double_arrow" },
+   { "n-resize",     "top_side" },
+@@ -636,6 +642,8 @@ static const struct {
+   { "ns-resize",    "v_double_arrow" },
+   { "nesw-resize",  "fd_double_arrow" },
+   { "nwse-resize",  "bd_double_arrow" },
++  { "zoom-in",      "left_ptr" },
++  { "zoom-out",     "left_ptr" },
+   { NULL, NULL }
+ };
+ 
+@@ -650,7 +658,7 @@ name_fallback (const gchar *name)
+         return name_map[i].traditional_name;
+     }
+ 
+-  return "left_ptr";
++  return NULL;
+ }
+ 
+ GdkCursor*
+@@ -683,9 +691,17 @@ _gdk_x11_display_get_cursor_for_name (GdkDisplay  *display,
+       xdisplay = GDK_DISPLAY_XDISPLAY (display);
+       xcursor = XcursorLibraryLoadCursor (xdisplay, name);
+       if (xcursor == None)
+-        xcursor = XcursorLibraryLoadCursor (xdisplay, name_fallback (name));
+-      if (xcursor == None)
+-        xcursor = XcursorLibraryLoadCursor (xdisplay, "left_ptr");
++        {
++          const char *fallback;
++
++          fallback = name_fallback (name);
++          if (fallback)
++            {
++              xcursor = XcursorLibraryLoadCursor (xdisplay, fallback);
++              if (xcursor == None)
++                xcursor = XcursorLibraryLoadCursor (xdisplay, "left_ptr");
++            }
++        }
+       if (xcursor == None)
+         return NULL;
+     }
+-- 
+2.7.0
+
diff --git a/abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch b/abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
new file mode 100644
index 0000000..94b69fb
--- /dev/null
+++ b/abs/extra/gtk3/0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
@@ -0,0 +1,94 @@
+From 81a287478a4db9ce650cc764474b9c173b137dee Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Wed, 6 Jan 2016 14:56:06 -0500
+Subject: [PATCH 2/2] wayland: Only do cursor name fallback for standard names
+
+Always returning a left_ptr if we can't find anything better
+broke firefox application-specific fallback for missing cursors.
+Keep that working by only doing the fallback for the CSS cursor
+names, not for things like hashes.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=760141
+---
+ gdk/wayland/gdkcursor-wayland.c | 29 +++++++++++++++++++++--------
+ 1 file changed, 21 insertions(+), 8 deletions(-)
+
+diff --git a/gdk/wayland/gdkcursor-wayland.c b/gdk/wayland/gdkcursor-wayland.c
+index 8aee5ae..bdfa316 100644
+--- a/gdk/wayland/gdkcursor-wayland.c
++++ b/gdk/wayland/gdkcursor-wayland.c
+@@ -87,17 +87,23 @@ static const struct {
+   const gchar *css_name, *traditional_name;
+ } name_map[] = {
+   { "default",      "left_ptr" },
++  { "help",         "left_ptr" },
++  { "context-menu", "left_ptr" },
+   { "pointer",      "hand" },
+   { "progress",     "left_ptr_watch" },
+   { "wait",         "watch" },
+   { "cell",         "crosshair" },
+   { "crosshair",    "cross" },
+   { "text",         "xterm" },
++  { "vertical-text","xterm" },
+   { "alias",        "dnd-link" },
+   { "copy",         "dnd-copy" },
++  { "move",         "dnd-move" },
+   { "no-drop",      "dnd-none" },
+   { "not-allowed",  "crossed_circle" },
+   { "grab",         "hand2" },
++  { "grabbing",     "hand2" },
++  { "all-scroll",   "left_ptr" },
+   { "col-resize",   "h_double_arrow" },
+   { "row-resize",   "v_double_arrow" },
+   { "n-resize",     "top_side" },
+@@ -112,6 +118,8 @@ static const struct {
+   { "ns-resize",    "v_double_arrow" },
+   { "nesw-resize",  "fd_double_arrow" },
+   { "nwse-resize",  "bd_double_arrow" },
++  { "zoom-in",      "left_ptr" },
++  { "zoom-out",     "left_ptr" },
+   { NULL, NULL }
+ };
+ 
+@@ -126,7 +134,7 @@ name_fallback (const gchar *name)
+         return name_map[i].traditional_name;
+     }
+ 
+-  return "left_ptr";
++  return NULL;
+ }
+ 
+ static gboolean
+@@ -144,17 +152,22 @@ _gdk_wayland_cursor_update (GdkWaylandDisplay *wayland_display,
+                                                         cursor->scale);
+   c = wl_cursor_theme_get_cursor (theme, cursor->name);
+   if (!c)
+-    c = wl_cursor_theme_get_cursor (theme, name_fallback (cursor->name));
++    {
++      const char *fallback;
++
++      fallback = name_fallback (cursor->name);
++      if (fallback)
++        {
++          c = wl_cursor_theme_get_cursor (theme, name_fallback (cursor->name));
++          if (!c)
++            c = wl_cursor_theme_get_cursor (theme, "left_ptr");
++        }
++    }
+ 
+   if (!c)
+     {
+       g_warning (G_STRLOC ": Unable to load %s from the cursor theme", cursor->name);
+-
+-      /* return the left_ptr cursor as a fallback */
+-      c = wl_cursor_theme_get_cursor (theme, "left_ptr");
+-
+-      if (!c)
+-        return FALSE;
++      return FALSE;
+     }
+ 
+   cursor->wl_cursor = c;
+-- 
+2.7.0
+
diff --git a/abs/extra/gtk3/PKGBUILD b/abs/extra/gtk3/PKGBUILD
index 5557008..15dc342 100644
--- a/abs/extra/gtk3/PKGBUILD
+++ b/abs/extra/gtk3/PKGBUILD
@@ -2,23 +2,34 @@
 # Maintainer: Ionut Biru <ibiru@archlinux.org>
 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
 
-pkgname=gtk3
-pkgver=3.14.5
-pkgrel=1
-pkgdesc="GObject-based multi-platform GUI toolkit (v3)"
+pkgbase=gtk3
+pkgname=(gtk3 gtk-update-icon-cache)
+pkgver=3.18.6
+pkgrel=2
+pkgdesc="GObject-based multi-platform GUI toolkit"
 arch=(i686 x86_64)
 url="http://www.gtk.org/"
-install=gtk3.install
-depends=(atk cairo gtk-update-icon-cache libcups libxcursor libxinerama libxrandr libxi
+depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
          libxcomposite libxdamage pango shared-mime-info colord at-spi2-atk wayland libxkbcommon
-         adwaita-icon-theme json-glib rest)
-makedepends=(gobject-introspection python2)
+         adwaita-icon-theme json-glib rest librsvg)
+makedepends=(gobject-introspection libcanberra)
 license=(LGPL)
-source=(http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz)
-sha256sums=('ba70f5ccde6646c6d8aa5a6398794b7bcf23fc45af22580a215d258f392dbbe2')
+source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
+        0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
+        0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
+        settings.ini)
+sha256sums=('78cabf0fd5a662f8723f62d5ac633072c76c557c1d700454c9c3deaa37e441ef'
+            '0402c3b7801810beb0f24ad20e4fb2eb7519cf3984f39e093a6e2752a0f7d9de'
+            '94722b06284e76f628fc8933617ac19c14f6775a5250fe3c382defab63d7b10e'
+            '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202')
 
 prepare() {
     cd gtk+-$pkgver
+
+    # Fix zoom in/out cursors in GTK3 builds of Firefox
+    # https://bugzilla.gnome.org/show_bug.cgi?id=760141
+    patch -Np1 -i ../0001-x11-Only-do-cursor-name-fallback-for-standard-names.patch
+    patch -Np1 -i ../0002-wayland-Only-do-cursor-name-fallback-for-standard-na.patch
 }
 
 build() {
@@ -27,7 +38,6 @@ build() {
     CXX=/bin/false ./configure --prefix=/usr \
         --sysconfdir=/etc \
         --localstatedir=/var \
-        --enable-gtk2-dependency \
         --disable-schemas-compile \
         --enable-x11-backend \
         --enable-broadway-backend \
@@ -39,7 +49,26 @@ build() {
     make
 }
 
-package() {
+package_gtk3() {
+    depends+=(gtk-update-icon-cache)
+    optdepends=('libcanberra: gtk3-widget-factory demo')
+    install=gtk3.install
+
     cd "gtk+-$pkgver"
     make DESTDIR="$pkgdir" install
+    install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
+
+    # split this out to use with gtk2 too
+    rm "$pkgdir/usr/bin/gtk-update-icon-cache"
 }
+
+package_gtk-update-icon-cache() {
+    pkgdesc="GTK+ icon cache updater"
+    depends=(gdk-pixbuf2 hicolor-icon-theme)
+    install=gtk-update-icon-cache.install
+
+    cd gtk+-$pkgver/gtk
+    install -Dm755 gtk-update-icon-cache "$pkgdir/usr/bin/gtk-update-icon-cache"
+}
+
+# vim:set et sw=4:
diff --git a/abs/extra/gtk3/gtk-update-icon-cache.install b/abs/extra/gtk3/gtk-update-icon-cache.install
new file mode 100644
index 0000000..1afcc72
--- /dev/null
+++ b/abs/extra/gtk3/gtk-update-icon-cache.install
@@ -0,0 +1,3 @@
+post_install() {
+  gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
diff --git a/abs/extra/gtk3/settings.ini b/abs/extra/gtk3/settings.ini
index 6a0643b..921d1dd 100644
--- a/abs/extra/gtk3/settings.ini
+++ b/abs/extra/gtk3/settings.ini
@@ -1,4 +1,4 @@
 [Settings]
-gtk-icon-theme-name = gnome
+gtk-icon-theme-name = Adwaita
 gtk-theme-name = Adwaita
 gtk-font-name = Cantarell 11
diff --git a/abs/extra/gtk3/wacom.patch b/abs/extra/gtk3/wacom.patch
deleted file mode 100644
index 79ad84f..0000000
--- a/abs/extra/gtk3/wacom.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -r gtk+-3.4.2/gdk/x11/gdkdevicemanager-xi2.c gtk+-3.4.2-wacom/gdk/x11/gdkdevicemanager-xi2.c
---- gtk+-3.4.2/gdk/x11/gdkdevicemanager-xi2.c	2012-05-02 14:45:04.000000000 +0200
-+++ gtk+-3.4.2-wacom/gdk/x11/gdkdevicemanager-xi2.c	2012-05-03 18:34:18.034807644 +0200
-@@ -331,6 +331,8 @@
-         input_source = GDK_SOURCE_ERASER;
-       else if (strstr (tmp_name, "cursor"))
-         input_source = GDK_SOURCE_CURSOR;
-+      else if (strstr (tmp_name, "finger"))
-+        input_source = GDK_SOURCE_TOUCHSCREEN;
-       else if (strstr (tmp_name, "wacom") ||
-                strstr (tmp_name, "pen"))
-         input_source = GDK_SOURCE_PEN;
-- 
cgit v0.12