From b41855ed0f9cd489fe3d9af1acd6e6b2fd80e922 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 5 Jan 2014 15:34:14 -0600
Subject: LinHES-config:add call to sfdisk to set the active partition refs
 #952

---
 abs/core/LinHES-config/PKGBUILD      | 4 ++--
 abs/core/LinHES-config/mv_install.py | 9 +++++++++
 2 files changed, 11 insertions(+), 2 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 5ca210b..a47d7ea 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=8.1
-pkgrel=9
+pkgrel=11
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -133,7 +133,7 @@ package() {
     install -o root -g root  -D -m 0755 blacklist_nouveau.conf $pkgdir/etc/modprobe.d/blacklist_nouveau.conf
 }
 
-md5sums=('8ee14247b04ab4152d4919d4d4b8d869'
+md5sums=('e4faaa3d5f180d796e200b701048b008'
          '3f6855b7bb860a44f96a972c2e80f497'
          'f6e9dd7bc6cf0aaa3bd203dab4cb79b9'
          '2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index ba88ade..fe4a395 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -506,6 +506,15 @@ def partition_disk():
     else:
         create_partitions_gpt(datadisk, start_sector, hostoptions["datasize"], "primary")
     
+    #set active
+    logging.debug("setting active partition for mbr")
+    
+    cmd = "parted %s set 1 boot on" %rootdisk
+    runcmd(cmd)
+
+    cmd = "sfdisk --force -A1 %s" %rootdisk
+    runcmd(cmd)
+    
     logging.debug("sleeping for 5 seconds")
     time.sleep(5)
 
-- 
cgit v0.12