From ee8ea9e2cca5abc7ab5c185b14caccd7df28fc3a Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sun, 16 May 2010 19:59:11 -0700
Subject: mysql:changes to my.cnf based on installing and running
 mysqltuner.pl.

---
 abs/core-testing/mysql/PKGBUILD    |  8 +++++++-
 abs/core-testing/mysql/__changelog |  5 +++++
 abs/core-testing/mysql/my.cnf      | 11 ++++++-----
 3 files changed, 18 insertions(+), 6 deletions(-)

diff --git a/abs/core-testing/mysql/PKGBUILD b/abs/core-testing/mysql/PKGBUILD
index 11df8fb..c91ac41 100644
--- a/abs/core-testing/mysql/PKGBUILD
+++ b/abs/core-testing/mysql/PKGBUILD
@@ -3,7 +3,7 @@
 # Contributor: judd <jvinet@zeroflux.org>
 pkgname=mysql
 pkgver=5.0.75
-pkgrel=3
+pkgrel=4
 pkgdesc="A fast SQL database server"
 arch=(i686 x86_64)
 backup=(etc/my.cnf etc/conf.d/mysqld)
@@ -48,3 +48,9 @@ build() {
   install -D -m644 ../mysqld.conf.d ${startdir}/pkg/etc/conf.d/mysqld
   rm -f ${startdir}/pkg/usr/bin/mysql_config
 }
+
+md5sums=('a234f0a60a7f8c290d9875cba3a2c5a2'
+         'e892aac36cbeb57f0e003ec0936afb3b'
+         'cfff3585dd70cde3ac1ce69e64008733'
+         '078f6e824d6097d558bcf7c16d508d92'
+         'd81d1f51e9ee6941425a63456d07cb21')
diff --git a/abs/core-testing/mysql/__changelog b/abs/core-testing/mysql/__changelog
index 4fa7078..aa066aa 100644
--- a/abs/core-testing/mysql/__changelog
+++ b/abs/core-testing/mysql/__changelog
@@ -1,6 +1,11 @@
 my.cnf
 -enable networking
 -datadir /data/srv/mysql
+-query_cache_size
+-tmp_table_size
+-max_heap_table_size
+-thread_cache_size
+-table_cache
 
 mysqld
 	-redirect output to /dev/null
diff --git a/abs/core-testing/mysql/my.cnf b/abs/core-testing/mysql/my.cnf
index 7202fcd..e13331e 100644
--- a/abs/core-testing/mysql/my.cnf
+++ b/abs/core-testing/mysql/my.cnf
@@ -1,8 +1,4 @@
-# mysql config file for medium systems.
-#
-# This is for a system with little memory (32M - 64M) where MySQL plays
-# a important part and systems up to 128M where MySQL is used together with
-# other programs (like a web server)
+# mysql config file for LinHES.
 #
 # One can in this file use all long options that the program supports.
 # If you want to know which options a program support, run the program
@@ -28,6 +24,11 @@ table_cache = 64
 sort_buffer_size = 512K
 net_buffer_length = 16K
 myisam_sort_buffer_size = 8M
+query_cache_size = 8M
+tmp_table_size = 36M
+max_heap_table_size = 24M
+thread_cache_size = 4
+table_cache = 96
 
 # Don't listen on a TCP/IP port at all. This can be a security enhancement,
 # if all processes that need to connect to mysqld run on the same host.
-- 
cgit v0.12