From b393d6fd2288b3a35480234c29a6e3939194a6a5 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 16 Jul 2017 04:14:58 +0000
Subject: python2-ndg-httpsclient: initial inclusion. dep of flexget

---
 .../python_modules/python-ndg-httpsclient/PKGBUILD | 48 ++++++++++++++++++++++
 .../python-ndg-httpsclient/__changelog             |  2 +
 2 files changed, 50 insertions(+)
 create mode 100644 abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
 create mode 100644 abs/core/python_modules/python-ndg-httpsclient/__changelog

diff --git a/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD b/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
new file mode 100644
index 0000000..7b0047f
--- /dev/null
+++ b/abs/core/python_modules/python-ndg-httpsclient/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id: PKGBUILD 134777 2015-06-04 13:33:01Z mtorromeo $
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Hugo Osvaldo Barrera <hugo@osvaldobarrera.com.ar>
+
+pkgbase=python-ndg-httpsclient
+pkgname=(python2-ndg-httpsclient)
+_pkgname=ndg_httpsclient
+pkgver=0.4.2
+pkgrel=2
+pkgdesc="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+arch=(any)
+url="https://pypi.python.org/pypi/ndg-httpsclient"
+license=('BSD')
+makedepends=(python2-setuptools python2-pyopenssl python2-pyasn1)
+options=(!emptydirs)
+source=(https://files.pythonhosted.org/packages/source/n/ndg-httpsclient/$_pkgname-$pkgver.tar.gz)
+sha256sums=('580987ef194334c50389e0d7de885fccf15605c13c6eecaabd8d6c43768eb8ac')
+
+build() {
+  cd "$srcdir"/$_pkgname-$pkgver
+
+#  rm -rf ../buildpy3; mkdir ../buildpy3
+#  python setup.py build -b ../buildpy3
+
+  rm -rf ../buildpy2; mkdir ../buildpy2
+  python2 setup.py build -b ../buildpy2
+}
+
+package_python-ndg-httpsclient() {
+  depends=(python-pyopenssl python-pyasn1)
+  _site_packages=$(python -sSc 'import site; print(site.getsitepackages()[0])')
+
+  cd "$srcdir"/$_pkgname-$pkgver
+  rm -rf build; ln -s ../buildpy3 build
+  python setup.py install --skip-build -O1 --root="$pkgdir"
+  install -Dm0644 "$pkgdir$_site_packages"/ndg/httpsclient/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-ndg-httpsclient() {
+  depends=(python2-pyopenssl python2-pyasn1)
+  _site_packages=$(python2 -sSc 'import site; print(site.getsitepackages()[0])')
+
+  cd "$srcdir"/$_pkgname-$pkgver
+  rm -rf build; ln -s ../buildpy2 build
+  python2 setup.py install --skip-build -O1 --root="$pkgdir"
+  install -Dm0644 "$pkgdir$_site_packages"/ndg/httpsclient/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+  mv "$pkgdir"/usr/bin/ndg_httpclient{,2}
+}
diff --git a/abs/core/python_modules/python-ndg-httpsclient/__changelog b/abs/core/python_modules/python-ndg-httpsclient/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-ndg-httpsclient/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+
-- 
cgit v0.12