From 897051449a9bd6636e1d247152ce37760a7b1497 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 21 Nov 2013 16:12:22 -0600
Subject: linhes-theme: add Tux bubble for menu descriptions. refs #940.

Move menu to top of screen. Change size of popup menu to match size of video osd popup menu. Widen clock field to avoid trunkation.
---
 abs/core/linhes-theme/PKGBUILD          |  17 +--
 abs/core/linhes-theme/base.xml.patch    | 176 +++++++++++++++++++++++++++++++-
 abs/core/linhes-theme/menu-ui.xml.patch |  67 ++++++++++++
 abs/core/linhes-theme/tux_thoughts.png  | Bin 0 -> 50666 bytes
 4 files changed, 253 insertions(+), 7 deletions(-)
 create mode 100644 abs/core/linhes-theme/menu-ui.xml.patch
 create mode 100755 abs/core/linhes-theme/tux_thoughts.png

diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index 4424d21..7f58de5 100644
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,17 +1,18 @@
 pkgname=linhes-theme
 pkgver=8.1
-pkgrel=1
+pkgrel=2
 pkgdesc="Default LinHES MythTV theme"
 arch=('i686' 'x86_64')
 license=('GPL2')
 url="http://linhes.org/"
 
-patches=('readme.txt.patch' 'osd.xml.patch' 'base.xml.patch')
+patches=('readme.txt.patch' 'osd.xml.patch' 'base.xml.patch'
+         'menu-ui.xml.patch')
 
 #The LinHES theme is based on TintedGlass by Harley Peters
 source=("git://github.com/MythTV-Themes/TintedGlass.git"
         `echo ${patches[@]:0}` 'themeinfo.xml'
-        'background.png' 'qt-background.png')
+        'background.png' 'qt-background.png' 'tux_thoughts.png')
 
 package() {
     THEMEROOT=usr/share/mythtv/themes
@@ -31,10 +32,12 @@ package() {
     cd $startdir
     msg "--------------------------done applying patches-------------------------"
 
-    msg "Copy themeinfo.xml and adding backgrounds for LinHES"
+    msg "Copy themeinfo.xml and adding backgrounds and images for LinHES"
     rsync -pL $srcdir/themeinfo.xml $pkgdir/$THEMEROOT/LinHES/
     rm -r $pkgdir/$THEMEROOT/LinHES/images/backgrounds/*
     rsync -pL $srcdir/*background.png $pkgdir/$THEMEROOT/LinHES/images/backgrounds/
+    #tux_thoughts.png is the thought bubble for the menu descriptions
+    rsync -pL $srcdir/tux_thoughts.png $pkgdir/$THEMEROOT/LinHES/images/
 
     msg "Modifying yellows and blue to LinHES yellow and blue"
     #yellow
@@ -48,7 +51,9 @@ package() {
 md5sums=('SKIP'
          '9c2fc68864cbedb6e449056972b457aa'
          '15b4462932b7be0e56b2e69e0214823a'
-         'fce30678cb5903aada8466ce7004abea'
+         '2fb0990e8fef2c70e9bd8cfb36689b2b'
+         '83b03852c6f46bc791bfa6e8c894ca01'
          '7d7bc458a8f4af408700609f3e1f412e'
          'cbe5f663ebb5d51abe811f81dafec303'
-         '12d26a786fde397348653128a6d7676a')
+         '12d26a786fde397348653128a6d7676a'
+         '2bd09b8049aaf5ba21db5baf3a0ce077')
diff --git a/abs/core/linhes-theme/base.xml.patch b/abs/core/linhes-theme/base.xml.patch
index d230f05..5dde5ea 100644
--- a/abs/core/linhes-theme/base.xml.patch
+++ b/abs/core/linhes-theme/base.xml.patch
@@ -1,5 +1,62 @@
 --- base.xml.orig	2013-11-19 01:06:47.555458106 +0000
-+++ base.xml	2013-11-19 01:29:11.310340235 +0000
++++ base.xml	2013-11-21 21:56:09.218085998 +0000
+@@ -431,19 +431,19 @@
+     <group name="base_heading_group">
+         <area>0,0,1280,720</area>
+         <shape name="base_heading_backdrop" from="base_backdrop">
+-            <area>500,-7,280,32</area>
++            <area>490,-7,300,32</area>
+         </shape>
+         <shape name="base_heading_backdrop_line" from="base_backdrop_line">
+-            <area>500,-7,280,32</area>
++            <area>490,-7,300,32</area>
+         </shape>
+         <shape name="heading-left-line" from="base_highlight_vertical_line">
+-            <area>501,0,2,22</area>
++            <area>491,0,2,22</area>
+         </shape>
+         <shape name="heading-right-line" from="base_highlight_vertical_line">
+-            <area>777,0,2,22</area>
++            <area>787,0,2,22</area>
+         </shape>
+         <shape name="heading-bottom-line" from="base_highlight_line">
+-            <area>501,22,278,2</area>
++            <area>491,22,298,2</area>
+         </shape>
+     </group>
+ 
+@@ -463,25 +463,25 @@
+     <!-- Base definition of a clock  group -->
+     <group name="base_clock_backdrop_group">
+         <shape name="base_clock_backdrop" from="base_backdrop">
+-            <area>500,695,280,32</area>
++            <area>490,695,300,32</area>
+         </shape>
+         <shape name="base_clock_backdrop_line" from="base_backdrop_line">
+-            <area>500,695,280,32</area>
++            <area>490,695,300,32</area>
+         </shape>
+         <shape name="base_clock_backdrop_top_line" from="base_highlight_line">
+-            <area>501,696,278,2</area>
++            <area>491,696,298,2</area>
+         </shape>
+         <shape name="base_clock_backdrop_left_line" from="base_highlight_vertical_line">
+-            <area>501,698,2,22</area>
++            <area>491,698,2,22</area>
+         </shape>
+         <shape name="clock_right_line" from="base_highlight_vertical_line">
+-            <area>777,698,2,22</area>
++            <area>787,698,2,22</area>
+         </shape>
+     </group>
+ 
+     <!-- Base denfinition of a clock -->
+     <clock name="base_clock">
+-        <area>529,698,219,22</area>
++        <area>499,698,282,22</area>
+         <font>baseextrasmall</font>
+         <template>%DATE%, %TIME%</template>
+         <align>allcenter</align>
 @@ -539,8 +539,8 @@
  
      <!-- Base definition of a active button list background -->
@@ -20,3 +77,120 @@
                      <cutdown>yes</cutdown>
                      <align>allcenter</align>
                  </textarea>
+@@ -1235,15 +1235,13 @@
+ 
+         <group name="clock-backdrop-group" from="base_clock_backdrop_group" />
+ 
+-	<clock name="time" from="base_clock">
+-            <area>529,698,219,22</area>
+-        </clock>
++	<clock name="time" from="base_clock" />
+ 
+     </window>
+ 
+     <!-- Popup Dialogue Box -->
+     <window name="MythPopupBox">
+-        <area>-1,-1,400,463</area>
++        <area>-1,-1,602,488</area>
+ 
+         <animation trigger="AboutToShow">
+             <section>
+@@ -1260,76 +1258,77 @@
+         </animation>
+ 
+         <shape name="popup-backdrop" from="base_popup_backdrop">
+-            <area>0,0,400,463</area>
++            <area>0,0,602,488</area>
++            <fill color="#0a0a0e" alpha="235" />
+         </shape>
+ 
+         <shape name="popup-backdrop-line" from="base_backdrop_line">
+-            <area>1,1,398,461</area>
++            <area>1,1,600,486</area>
+         </shape>
+ 
+         <shape name="popup-first-line" from="base_highlight_line">
+-            <area>2,2,396,2</area>
++            <area>2,2,596,2</area>
+         </shape>
+ 
+         <shape name="popup-second-line" from="base_line">
+-            <area>23,174,354,2</area>
++            <area>23,212,552,2</area>
+         </shape>
+ 
+         <shape name="popup-third-line" from="base_highlight_line">
+-            <area>2,459,396,2</area>
++            <area>2,484,596,2</area>
+         </shape>
+ 
+         <shape name="popup-left-line" from="base_highlight_vertical_line">
+-            <area>2,4,2,455</area>
++            <area>2,4,2,480</area>
+         </shape>
+ 
+         <shape name="popup-right-line" from="base_highlight_vertical_line">
+-            <area>396,4,2,455</area>
++            <area>598,4,2,480</area>
+         </shape>
+ 
+         <textarea name="messagearea" from="basetextarea">
+-            <area>16,8,368,162</area>
+-            <font>basesmalldarkyellow</font>
++            <area>10,8,582,196</area>
++            <font>basesmall</font>
+             <multiline>yes</multiline>
+             <align>allcenter</align>     
+         </textarea>
+ 
+         <buttonlist name="list" from="base_button_list">
+-            <area>15,191,370,264</area>
++            <area>15,222,570,252</area>
+             <statetype name="buttonitem">
+                 <state name="active">
+-                    <area>0,0,370,40</area>
++                    <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>8,0,354,40</area>
++                        <area>8,0,570,34</area>
+                     </textarea>
+                     <imagetype name="buttonarrow">
+-                        <position>347,11</position>
++                        <position>544,8</position>
+                     </imagetype>
+                 </state>
+                 <state name="selectedactive">
+-                    <area>0,0,370,40</area>
++                    <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>8,0,354,40</area>
++                        <area>8,0,570,34</area>
+                     </textarea>
+                     <imagetype name="buttonarrow">
+-                        <position>347,11</position>
++                        <position>544,8</position>
+                     </imagetype>
+                 </state>
+                 <state name="selectedinactive">
+-                    <area>0,0,370,40</area>
++                    <area>0,0,100%,34</area>
+                     <textarea name="buttontext">
+-                        <area>8,0,354,40</area>
++                        <area>8,0,570,34</area>
+                     </textarea>
+                     <imagetype name="buttonarrow">
+-                        <position>347,11</position>
++                        <position>544,8</position>
+                     </imagetype>
+                 </state>
+             </statetype>
+         <statetype name="upscrollarrow">
+-            <position>0,255</position>
++            <position>0,251</position>
+         </statetype>
+         <statetype name="downscrollarrow">
+-            <position>20,255</position>
++            <position>20,251</position>
+         </statetype>
+         </buttonlist>
+     </window>
diff --git a/abs/core/linhes-theme/menu-ui.xml.patch b/abs/core/linhes-theme/menu-ui.xml.patch
new file mode 100644
index 0000000..c099db6
--- /dev/null
+++ b/abs/core/linhes-theme/menu-ui.xml.patch
@@ -0,0 +1,67 @@
+--- menu-ui.xml.orig	2013-11-21 19:05:04.920817617 +0000
++++ menu-ui.xml	2013-11-21 20:03:45.474172898 +0000
+@@ -9,16 +9,16 @@
+         </textarea>
+ 
+         <shape name="menuscroll-background" from="base_backdrop">
+-            <area>0,525,1280,70</area>
++            <area>0,94,1280,70</area>
+             <type>box</type>
+         </shape>
+ 
+         <shape name="menuscroll-top-line" from="base_line">
+-            <area>0,526,1280,2</area>
++            <area>0,95,1280,2</area>
+         </shape>
+ 
+         <shape name="menuscroll-bottom-line" from="base_line">
+-            <area>0,592,1280,2</area>
++            <area>0,161,1280,2</area>
+         </shape>
+ 
+         <statetype name="titles">
+@@ -135,7 +135,7 @@
+         </statetype>
+ 
+         <buttonlist name="menu">
+-            <area>20,528,1240,64</area>
++            <area>20,98,1240,64</area>
+             <layout>horizontal</layout>
+             <spacing>20</spacing>
+             <scrollstyle>center</scrollstyle>
+@@ -157,6 +157,14 @@
+                 <state name="selectedactive"> 
+                     <area>0,0,232,64</area>
+                     <imagetype name="background" />
++
++                    <shape name="menu-left-line" from="base_highlight_vertical_line">
++                        <area>-10,-2,2,66</area>
++                    </shape>
++                    <shape name="menu-right-line" from="base_highlight_vertical_line">
++                        <area>240,-2,2,66</area>
++                    </shape>
++
+                     <textarea name="buttontext">
+                         <area>0,0,232,64</area>
+                         <font>basemediumlargerdarkyellow</font>
+@@ -168,6 +176,20 @@
+                         <cutdown>yes</cutdown>
+                         <case>upper</case>
+                     </textarea>
++
++                    <imagetype name="description_background">
++                        <area>-100,100,410,180</area>
++                        <filename>images/tux_thoughts.png</filename>
++                    </imagetype>
++                    
++                    <textarea name="description">
++                        <area>12,87,210,130</area>
++                        <align>allcenter</align>
++                        <font>basesmallyellow</font>
++                        <alpha>225</alpha>
++                        <multiline>yes</multiline>
++                    </textarea>
++
+                 </state>
+             </statetype>
+         </buttonlist>
diff --git a/abs/core/linhes-theme/tux_thoughts.png b/abs/core/linhes-theme/tux_thoughts.png
new file mode 100755
index 0000000..c36c7a6
Binary files /dev/null and b/abs/core/linhes-theme/tux_thoughts.png differ
-- 
cgit v0.12