From 307eb233df908c5b979bfbe8bc76211cd3ff59b4 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Wed, 17 Aug 2011 21:46:06 +0000
Subject: runit: fixes to install file to help ensure halt/reboot work.

---
 abs/core/runit/PKGBUILD      | 12 +--------
 abs/core/runit/runit.install | 60 +++++++++++++++++++++++++++++---------------
 2 files changed, 41 insertions(+), 31 deletions(-)

diff --git a/abs/core/runit/PKGBUILD b/abs/core/runit/PKGBUILD
index a3b202e..f1b1bb2 100644
--- a/abs/core/runit/PKGBUILD
+++ b/abs/core/runit/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit
 pkgver=2.1.1
-pkgrel=3
+pkgrel=4
 pkgdesc="A replacement for sysvinit, and other init schemes, with service supervision"
 url="http://smarden.org/runit/"
 license=('BSD')
@@ -46,18 +46,8 @@ package() {
   install -m0644 ../man/*.8 $pkgdir/usr/man/man8
   gzip -9 $pkgdir/usr/man/man8/*.8 || return 1
 
-#  rsync -a --exclude=.svn $startdir/runitscripts $srcdir
-#  cd $srcdir/runitscripts
-
   install -d $pkgdir/etc/
   install -d $pkgdir/etc/runit/
-  install -d $pkgdir/var/service
-
-#  install -m0700 1 2 3 ctrlaltdel $pkgdir/etc/runit
-#  install -m0755 reboot-runit halt-runit logger $pkgdir/sbin
-
- # install -d $pkgdir/etc/sv
- # rsync -a --exclude=.svn services/* $pkgdir/etc/sv
 
   cd $startdir
   install -d $pkgdir/usr/bin
diff --git a/abs/core/runit/runit.install b/abs/core/runit/runit.install
index 392d7be..b62e94e 100755
--- a/abs/core/runit/runit.install
+++ b/abs/core/runit/runit.install
@@ -1,38 +1,58 @@
 # arg 1:  the new package version
 
 pre_install () {
-if [ ! -f /sbin/halt-init ]
-then
-   mv /sbin/halt  /sbin/halt-init
-   mv /sbin/shutdown  /sbin/shutdown-init
+if [ ! -L /sbin/halt ] ; then
+  if [ -f /sbin/halt ] ; then
+    mv /sbin/halt /sbin/halt-init
+  fi
+fi
+
+if [ ! -L /sbin/shutdown ] ; then
+  if [ -f /sbin/shutdown ] ; then
+    mv /sbin/shutdown /sbin/shutdown-init
+  fi
+fi
+
+if [ -e /sbin/reboot ] ; then
+  rm -f /sbin/reboot
+fi
+
+if [ -e /sbin/poweroff ] ; then
+  rm -f /sbin/poweroff
 fi
-   rm -f /sbin/reboot
-   rm -f /sbin/poweroff
 
 }
 
 pre_upgrade () {
-if [ ! -f /sbin/halt-init ]
-then
-   mv /sbin/halt  /sbin/halt-init
+if [ ! -f /sbin/halt-init ] ; then
+  if [ ! -L /sbin/halt ] ; then
+    mv /sbin/halt /sbin/halt-init
+  fi
+fi
+
+if [ ! -f /sbin/shutdown-init ] ; then
+  if [ ! -L /sbin/shutdown ] ; then
+    mv /sbin/shutdown  /sbin/shutdown-init
+  fi
+fi
+
+if [ -e /sbin/reboot ] ; then
+  rm -f /sbin/reboot
 fi
 
-if [ ! -f /sbin/shutdown-init ]
-then
-   mv /sbin/shutdown  /sbin/shutdown-init
+if [ -e /sbin/poweroff ] ; then
+  rm -f /sbin/poweroff
 fi
-   rm -f /sbin/reboot
-   rm -f /sbin/poweroff
 
 }
 
 post_install () {
-   [ -e /sbin/halt ] || ln -s /sbin/halt.script /sbin/halt
-   [ -e /sbin/reboot ] || ln -s /sbin/reboot.script /sbin/reboot
-   [ -e /sbin/poweroff ] ||  ln -s /sbin/poweroff.script /sbin/poweroff
-   [ -e /sbin/reboot.init ] || ln -s /sbin/halt-init /sbin/reboot.init
-   [ -e /sbin/poweroff.init ] || ln -s /sbin/halt-init /sbin/poweroff.init
-   [ -e /sbin/shutdown ] || ln -s /sbin/shutdown.script /sbin/shutdown
+   [ -e /sbin/halt ] || ln -sf /sbin/halt.script /sbin/halt
+   [ -e /sbin/reboot ] || ln -sf /sbin/reboot.script /sbin/reboot
+   [ -e /sbin/poweroff ] ||  ln -sf /sbin/poweroff.script /sbin/poweroff
+   [ -e /sbin/reboot.init ] || ln -sf /sbin/halt-init /sbin/reboot.init
+   [ -e /sbin/poweroff.init ] || ln -sf /sbin/halt-init /sbin/poweroff.init
+   [ -e /sbin/shutdown ] || ln -sf /sbin/shutdown.script /sbin/shutdown
 }
 
 # arg 1:  the new package version
-- 
cgit v0.12