From 1134708f1cf2458008410dea8cfc8ff33bd4df1d Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Mon, 3 Jan 2011 23:39:54 +0000
Subject: glew: upgrade. Dep of mesa-demo

---
 abs/extra/glew/PKGBUILD | 28 +++++++++++++++++-----------
 1 file changed, 17 insertions(+), 11 deletions(-)

diff --git a/abs/extra/glew/PKGBUILD b/abs/extra/glew/PKGBUILD
index 1db995d..389b4d4 100644
--- a/abs/extra/glew/PKGBUILD
+++ b/abs/extra/glew/PKGBUILD
@@ -1,23 +1,29 @@
-# $Id: PKGBUILD 27226 2009-02-17 05:43:56Z eric $
-# AUR-Maintainer: William Rea <sillywilly@gmail.com>
+# $Id$
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
 # Contributor: SleepyDog
 
 pkgname=glew
-pkgver=1.5.5
+pkgver=1.5.7
 pkgrel=1
-pkgdesc="A cross-platform C/C++ extension loading library"
+pkgdesc="The OpenGL Extension Wrangler Library"
 arch=('i686' 'x86_64')
 url="http://glew.sourceforge.net"
 license=('BSD' 'MIT' 'GPL')
 depends=('libxmu' 'libxi' 'mesa')
-makedepends=('hd2u')
 source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tgz)
+sha1sums=('4adc816afbfb65a4969484d10343a88c117ca989')
 
 build() {
-  cd ${startdir}/src/${pkgname}-${pkgver}
-  dos2unix config/config.guess
-  make || return 1
-  make GLEW_DEST=${startdir}/pkg/usr LIBDIR=${startdir}/pkg/usr/lib install || return 1
-  install -D -m644 LICENSE.txt ${startdir}/pkg/usr/share/licenses/${pkgname}/LICENSE.txt || return 1
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  sed -i 's|lib64|lib|' config/Makefile.linux
+  make
 }
-md5sums=('3621f27cfd3e33d5dbcc1111ecb5b762')
+
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make GLEW_DEST="${pkgdir}/usr" install
+  install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: set noexpandtab tabstop=8 shiftwidth=8 textwidth=132 autoindent
+
-- 
cgit v0.12


From b84192583f3f18cd45e976c76d62741f09ef40f0 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Mon, 3 Jan 2011 23:46:44 +0000
Subject: mesa-demos: initial include. Dep of xbmc

---
 abs/core/mesa-demos/LICENSE  | 83 ++++++++++++++++++++++++++++++++++++++++++++
 abs/core/mesa-demos/PKGBUILD | 31 +++++++++++++++++
 2 files changed, 114 insertions(+)
 create mode 100644 abs/core/mesa-demos/LICENSE
 create mode 100644 abs/core/mesa-demos/PKGBUILD

diff --git a/abs/core/mesa-demos/LICENSE b/abs/core/mesa-demos/LICENSE
new file mode 100644
index 0000000..26a04af
--- /dev/null
+++ b/abs/core/mesa-demos/LICENSE
@@ -0,0 +1,83 @@
+Disclaimer
+
+Mesa is a 3-D graphics library with an API which is very similar to
+that of OpenGL*
+To the extent that Mesa utilizes the OpenGL command syntax or state
+machine, it is being used with authorization from Silicon Graphics,
+Inc.(SGI). However, the author does not possess an OpenGL license
+from SGI, and makes no claim that Mesa is in any way a compatible
+replacement for OpenGL or associated with SGI. Those who want a
+licensed implementation of OpenGL should contact a licensed
+vendor.
+
+Please do not refer to the library as MesaGL (for legal
+reasons). It's just Mesa or The Mesa 3-D graphics
+library
+
+* OpenGL is a trademark of Silicon Graphics Incorporated.
+
+License / Copyright Information
+
+The Mesa distribution consists of several components.  Different copyrights
+and licenses apply to different components.  For example, GLUT is copyrighted
+by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
+device drivers are copyrighted by their authors.  See below for a list of
+Mesa's main components and the license for each.
+
+The core Mesa library is licensed according to the terms of the MIT license.
+This allows integration with the XFree86, Xorg and DRI projects.
+
+The default Mesa license is as follows:
+
+Copyright (C) 1999-2007  Brian Paul   All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
+BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Attention, Contributors
+
+When contributing to the Mesa project you must agree to the licensing terms
+of the component to which you're contributing.
+The following section lists the primary components of the Mesa distribution
+and their respective licenses.
+
+
+Mesa Component Licenses
+
+Component         Location               Primary Author      License
+----------------------------------------------------------------------------
+Main Mesa code    src/mesa/              Brian Paul          Mesa (MIT)
+
+Device drivers    src/mesa/drivers/*     See drivers         See drivers
+
+Ext headers       include/GL/glext.h     SGI                 SGI Free B
+                  include/GL/glxext.h
+
+GLUT              src/glut/              Mark Kilgard        Mark's copyright
+
+Mesa GLU library  src/glu/mesa/          Brian Paul          GNU-LGPL
+
+SGI GLU library   src/glu/sgi/           SGI                 SGI Free B
+
+demo programs     progs/demos/           various             see source files
+
+X demos           progs/xdemos/          Brian Paul          see source files
+
+SGI demos         progs/samples/         SGI                 SGI copyright
+
+RedBook demos     progs/redbook/         SGI                 SGI copyright
+
diff --git a/abs/core/mesa-demos/PKGBUILD b/abs/core/mesa-demos/PKGBUILD
new file mode 100644
index 0000000..8961103
--- /dev/null
+++ b/abs/core/mesa-demos/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=('mesa-demos')
+pkgver=8.0.1
+pkgrel=1
+arch=(i686 x86_64)
+pkgdesc="Mesa demos and tools"
+url="http://mesa3d.sourceforge.net"
+license=('custom')
+depends=('glew>=1.5.6')
+conflicts=('mesa<7.9')
+source=(ftp://ftp.freedesktop.org/pub/mesa/demos/${pkgver}/mesa-demos-${pkgver}.tar.bz2
+        LICENSE)
+
+build() {
+  cd "${srcdir}/mesa-demos-${pkgver}"
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd "${srcdir}/mesa-demos-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+  install -m755 -d "${pkgdir}/usr/share/licenses/mesa-demos"
+  install -m755 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa-demos/"
+}
+
+md5sums=('320c2a4b6edc6faba35d9cb1e2a30bf4'
+         '10a9d94c27477a9f9afed27f7d1c4476')
-- 
cgit v0.12


From 9dd56269ce4d6d2b4bb6785bb46a36476064b442 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Tue, 4 Jan 2011 01:18:35 +0000
Subject: mesa-demos: bump

---
 abs/core/mesa-demos/PKGBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/abs/core/mesa-demos/PKGBUILD b/abs/core/mesa-demos/PKGBUILD
index 8961103..2f71ce6 100644
--- a/abs/core/mesa-demos/PKGBUILD
+++ b/abs/core/mesa-demos/PKGBUILD
@@ -2,10 +2,10 @@
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
 
-pkgname=('mesa-demos')
+pkgname=mesa-demos
 pkgver=8.0.1
-pkgrel=1
-arch=(i686 x86_64)
+pkgrel=2
+arch=('i686' 'x86_64')
 pkgdesc="Mesa demos and tools"
 url="http://mesa3d.sourceforge.net"
 license=('custom')
-- 
cgit v0.12