From b2ad14ffbef9ee223c4ce41235aa0af77d61053c Mon Sep 17 00:00:00 2001
From: James Meyer <jams@linhes.org>
Date: Mon, 13 Dec 2010 01:11:37 +0000
Subject: rpcbind: apply patch so that it registers as sunrpc in /etc/services

---
 abs/core/rpcbind/PKGBUILD             | 14 +++++++++-----
 abs/core/rpcbind/rpcbind-sunrpc.patch | 22 ++++++++++++++++++++++
 2 files changed, 31 insertions(+), 5 deletions(-)
 create mode 100644 abs/core/rpcbind/rpcbind-sunrpc.patch

diff --git a/abs/core/rpcbind/PKGBUILD b/abs/core/rpcbind/PKGBUILD
index 11d8a91..81d6254 100644
--- a/abs/core/rpcbind/PKGBUILD
+++ b/abs/core/rpcbind/PKGBUILD
@@ -1,24 +1,28 @@
-# $Id: PKGBUILD 54912 2009-10-11 20:12:23Z giovanni $
+# $Id: PKGBUILD 86473 2010-08-02 07:44:00Z tpowa $
 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
 pkgname=rpcbind
 pkgver=0.2.0
-pkgrel=1
+pkgrel=2
 pkgdesc="portmap replacement which supports RPC over various protocols"
 arch=(i686 x86_64)
 depends=('bash' 'glibc' 'libtirpc')
 url="http://rpcbind.sourceforge.net"
 license=('custom')
 replaces=('portmap')
-source=(http://downloads.sourceforge.net/sourceforge/rpcbind/rpcbind-0.2.0.tar.bz2 
+source=(http://downloads.sourceforge.net/sourceforge/rpcbind/rpcbind-0.2.0.tar.bz2
+        rpcbind-sunrpc.patch
         rpcbind)
 md5sums=('1a77ddb1aaea8099ab19c351eeb26316'
+         'c02ac36a98baac70b8a26190524b7b73'
          '78a963654f57cbb209e228884767836e')
 
 build() {
   cd $srcdir/$pkgname-$pkgver
+  # patch for iana services file
+  patch -Np1 -i ../rpcbind-sunrpc.patch
   ./configure --prefix=/usr
-  make || return 1
-  make DESTDIR=$pkgdir install || return 1
+  make
+  make DESTDIR=$pkgdir install
   # install daemon 
   install -D -m755 $srcdir/rpcbind $pkgdir/etc/rc.d/rpcbind
   # install license
diff --git a/abs/core/rpcbind/rpcbind-sunrpc.patch b/abs/core/rpcbind/rpcbind-sunrpc.patch
new file mode 100644
index 0000000..76cf54b
--- /dev/null
+++ b/abs/core/rpcbind/rpcbind-sunrpc.patch
@@ -0,0 +1,22 @@
+--- rpcbind-0.1.7/src/rpcbind.c.orig	2008-11-19 14:17:34.000000000 +0100
++++ rpcbind-0.1.7/src/rpcbind.c	2010-01-07 13:03:37.416632894 +0100
+@@ -114,7 +114,7 @@
+ char *udp_uaddr;	/* Universal UDP address */
+ char *tcp_uaddr;	/* Universal TCP address */
+ #endif
+-static char servname[] = "rpcbind";
++static char servname[] = "sunrpc";
+ static char superuser[] = "superuser";
+ 
+ int main __P((int, char *[]));
+--- rpcbind-0.1.7/src/rpcinfo.c~	2010-01-08 16:14:24.592156602 +0000
++++ rpcbind-0.1.7/src/rpcinfo.c	2010-01-08 16:14:31.578838609 +0000
+@@ -633,7 +633,7 @@
+ 	{
+ 	  memset (&hints, 0, sizeof hints);
+ 	  hints.ai_family = AF_INET;
+-	  if ((error = getaddrinfo (host, "rpcbind", &hints, &res)) != 0 &&
++	  if ((error = getaddrinfo (host, "sunrpc", &hints, &res)) != 0 &&
+               (error = getaddrinfo (host, "portmapper", &hints, &res)) != 0)
+ 	    {
+ 	      fprintf (stderr, "rpcinfo: %s: %s\n",
-- 
cgit v0.12