From f5b2e9b0a4d64593c831e9efbf1d26c0ca1958e3 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 3 Nov 2012 15:57:06 -0500
Subject: LinHES-config: mv_vnc.py   vncsvc/.mythtv is now a symlink to
 mythtv/.vncsvc

refs #860
closes #860
---
 abs/core/LinHES-config/PKGBUILD  |  4 ++--
 abs/core/LinHES-config/mv_vnc.py | 18 ++++++++++++++----
 2 files changed, 16 insertions(+), 6 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index daacaf2..69470a5 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=2.3
-pkgrel=177
+pkgrel=178
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab'  'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -159,7 +159,7 @@ md5sums=('6a9a22b3c3cb74d9f1ac595cf437a7b7'
          '087a0ef743bc8af915503f8773536ce4'
          '1aa69e89034def751177cbd96c64e4ef'
          'b4900090d841d3e390cb840cf16afd85'
-         '6dd202ec664ede468e42edf600f7913d'
+         'f2a19e3e864984ec95ac5ea090cbfa69'
          'c9c9390ac12145169dfe9a76896db328'
          'f48b04d714c93146d8711531c266800a'
          '2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_vnc.py b/abs/core/LinHES-config/mv_vnc.py
index 7dbc986..bc7a201 100755
--- a/abs/core/LinHES-config/mv_vnc.py
+++ b/abs/core/LinHES-config/mv_vnc.py
@@ -48,12 +48,22 @@ exec wmaker
         logging.critical("*    vncsvc not found")
         vncuid = '78'
         vncgid = '78'
-    mv_common.mkdir_mythhome(data_config.VNCHOME,vncuid,vncgid)
 
 
-    home_xml_file=data_config.VNCHOME + "/.mythtv/config.xml"
-    configxml_file="/usr/share/mythtv/config.xml"
-    mv_common.link_file(configxml_file,home_xml_file)
+    cmd="setfacl -m u:vncsvc:x %s" %data_config.MYTHHOME
+    mv_common.runcmd(cmd)
+
+    srcmyth="%s/.mythtv" %data_config.MYTHHOME
+    destmyth="%s/.mythtv" %data_config.VNCHOME
+
+    mv_common.link_file(srcmyth,destmyth)
+
+
+
+    #mv_common.mkdir_mythhome(data_config.VNCHOME,vncuid,vncgid)
+    #home_xml_file=data_config.VNCHOME + "/.mythtv/config.xml"
+    #configxml_file="/usr/share/mythtv/config.xml"
+    #mv_common.link_file(configxml_file,home_xml_file)
 
     logging.info("    Writing out password")
     vncpassfile="%s/passwd" %vncdir
-- 
cgit v0.12