From fff07199375007511e2b51ecb34b785dfe81df37 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 26 Mar 2009 12:44:01 -0500
Subject: LinHES-config: Modify php.ini to match systemtimezone

---
 abs/core-testing/LinHES-config/PKGBUILD        |  2 +-
 abs/core-testing/LinHES-config/systemconfig.sh | 12 +++++++++---
 2 files changed, 10 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index c4418a0..db6314f 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=345
+pkgrel=346
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates )
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index ec5c749..2cb1a0c 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -162,9 +162,15 @@ echo $timezone
 ln -s "/usr/share/zoneinfo/$timezone"  ${BASE}/etc/localtime
         sed -e "s~^TIMEZONE=.*$~TIMEZONE=\"${timezone}\"~" ${BASE}/etc/rc.conf > $TEMPLATES/rc.conf
 
-    # echo CLOCK="UTC" > ${BASE}/etc/conf.dclock
-    # echo CLOCK_SYSTOCH="yes" >> ${BASE}/etc/conf.d/clock
-    # echo TIMEZONE="$timezone" >> ${BASE}/etc/conf.d/clock
+
+if [ -f ${BASE}/etc/php/php.ini ]
+then
+    echo "changing timezone in php.ini"
+    sed -i "s/^.*date.timezone.*$/date.timezone=${timezone}/" ${BASE}/etc/php/php.ini
+fi
+
+
+
 cp_and_log $TEMPLATES/rc.conf ${BASE}/etc/rc.conf
 #Check for Atomic Ant
 if grep disablemodules=agpart,intel_agp /proc/cmdline >/dev/null
-- 
cgit v0.12