From ee1b62e0ec35160835ed065d87a4bb0ce920656f Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 25 Apr 2018 20:43:58 +0000
Subject: smpeg: update to 0.4.5

---
 abs/extra/smpeg/PKGBUILD                | 47 ++++++++++++++++-----------------
 abs/extra/smpeg/smpeg-0.4.4-gcc41.patch | 41 ----------------------------
 2 files changed, 23 insertions(+), 65 deletions(-)
 delete mode 100644 abs/extra/smpeg/smpeg-0.4.4-gcc41.patch

diff --git a/abs/extra/smpeg/PKGBUILD b/abs/extra/smpeg/PKGBUILD
index fe2acfe..3b8ee65 100644
--- a/abs/extra/smpeg/PKGBUILD
+++ b/abs/extra/smpeg/PKGBUILD
@@ -1,35 +1,34 @@
-# $Id: PKGBUILD 168611 2012-10-13 11:49:26Z andyrtr $
-# Maintainer: Eric Belanger <eric@archlinux.org>
+# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Eric Belanger <eric@archlinux.org>
 # Contributor: Jan de Groot <jgc@archlinux.org>
 
 pkgname=smpeg
-pkgver=0.4.4
-pkgrel=7
+pkgver=0.4.5
+pkgrel=3
 pkgdesc="SDL MPEG Player Library"
-arch=('i686' 'x86_64')
-url="http://icculus.org/smpeg/"
-license=('LGPL')
-depends=('sdl')
-#makedepends=('gtk' 'mesa' 'glu')
-makedepends=('gtk' 'mesa' )
-optdepends=('gtk: to use gtv ' 'glu: to use glmovie')
-options=('!libtool' '!makeflags')
-source=(http://mirrors.dotsrc.org/lokigames/open-source/smpeg/${pkgname}-${pkgver}.tar.gz
-        smpeg-0.4.4-gcc41.patch)
-sha1sums=('6d7f4449472e6270ab435b2224f3fad951c35259'
-          '7d9a2ad7f6b702dfe3adcb87601d9b55022bbd1e')
+arch=(x86_64)
+url="https://icculus.org/smpeg/"
+license=(LGPL)
+depends=(sdl)
+makedepends=(mesa glu subversion)
+optdepends=('glu: to use glmovie')
+source=("$pkgname-$pkgver::svn://svn.icculus.org/smpeg/tags/release_${pkgver//./_}")
+sha256sums=('SKIP')
+
+prepare() {
+  cd $pkgname-$pkgver
+  ./autogen.sh
+}
 
 build() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  patch -p1 -i $srcdir/smpeg-0.4.4-gcc41.patch
+  cd $pkgname-$pkgver
+  CFLAGS+=" -Wno-error=narrowing"
   ./configure --prefix=/usr --mandir=/usr/share/man --disable-static
-  make LDFLAGS+=-lstdc++
+  make
 }
 
 package() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  make DESTDIR=${pkgdir} install
-  
-  # fix aclocal warnings
-  sed -i "s#(AM_PATH_SMPEG#([AM_PATH_SMPEG]#" ${pkgdir}/usr/share/aclocal/smpeg.m4
+  cd $pkgname-$pkgver
+  make DESTDIR="$pkgdir" install
 }
diff --git a/abs/extra/smpeg/smpeg-0.4.4-gcc41.patch b/abs/extra/smpeg/smpeg-0.4.4-gcc41.patch
deleted file mode 100644
index 4a0eeb4..0000000
--- a/abs/extra/smpeg/smpeg-0.4.4-gcc41.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-Index: MPEGaudio.h
-===================================================================
-RCS file: /cvs/cvsroot/smpeg/MPEGaudio.h,v
-retrieving revision 1.23
-diff -u -p -r1.23 MPEGaudio.h
---- smpeg/MPEGaudio.h	17 Jul 2001 19:52:24 -0000	1.23
-+++ smpeg/MPEGaudio.h	6 Dec 2005 06:10:43 -0000
-@@ -151,12 +151,6 @@ private:
- /* The actual MPEG audio class */
- class MPEGaudio : public MPEGerror, public MPEGaudioaction {
- 
--    friend void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
--    friend int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
--#ifdef THREADED_AUDIO
--    friend int Decode_MPEGaudio(void *udata);
--#endif
--
- public:
-     MPEGaudio(MPEGstream *stream, bool initSDL = true);
-     virtual ~MPEGaudio();
-@@ -367,6 +361,20 @@ public:
- #define N_TIMESTAMPS 5
- 
-   double timestamp[N_TIMESTAMPS];
-+
-+  /* Functions which access MPEGaudio internals */
-+  friend void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
-+  friend int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
-+#ifdef THREADED_AUDIO
-+  friend int Decode_MPEGaudio(void *udata);
-+#endif
- };
- 
-+/* Need to duplicate the prototypes, this is not a typo :) */
-+void Play_MPEGaudioSDL(void *udata, Uint8 *stream, int len);
-+int Play_MPEGaudio(MPEGaudio *audio, Uint8 *stream, int len);
-+#ifdef THREADED_AUDIO
-+int Decode_MPEGaudio(void *udata);
-+#endif
-+
- #endif /* _MPEGAUDIO_H_ */
-- 
cgit v0.12