From f0706652cec2eb979517744d3f07daa00bff2c69 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 20 Jan 2015 22:23:22 +0000
Subject: xymon: xymon-gputemp.sh: update temp grep for newer nvidia-smi

---
 abs/core/xymon/PKGBUILD         |  4 +--
 abs/core/xymon/gpu-temp.sh      | 76 -----------------------------------------
 abs/core/xymon/xymon-gputemp.sh |  4 +--
 3 files changed, 4 insertions(+), 80 deletions(-)
 delete mode 100644 abs/core/xymon/gpu-temp.sh

diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index e8b73ac..2ee5cdb 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=xymon
 pkgname=('xymonserver' 'xymonclient')
 pkgver=4.3.17
-pkgrel=9
+pkgrel=10
 pkgdesc="Xymon is a system for monitoring of hosts and networks"
 license="GPL"
 arch=('i686' 'x86_64')
@@ -170,7 +170,7 @@ md5sums=('d8d119a777e7b7204d1292fb27314312'
          '22d4c9065fd959efe82f121dcb511305'
          '9af2ad60ac4c3cb653754618f603e311'
          'b8eb10070f2ad6a245d3da15091694ba'
-         'e8f2ac43a1e3b28f5af438d787c86db2'
+         '6452d891d88bb46d07bcf7790a523ad0'
          'b4e8641e97e6b689dbc634af785e6799'
          'e2844513e2c92e8b5084818f3b2a478d'
          '98e9242ae346f729b14cb195786571f2'
diff --git a/abs/core/xymon/gpu-temp.sh b/abs/core/xymon/gpu-temp.sh
deleted file mode 100644
index 09f79ca..0000000
--- a/abs/core/xymon/gpu-temp.sh
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/bin/bash
-
-
-
-gpu_temp=0
-gpu_color="clear"
-
-if ! test -x /usr/bin/nvidia-smi ; then
-
-  $XYMON $XYMSRV "status $MACHINE.gputemp $gpu_color `date`
-  GPUTEMP:$gpu_temp
-  Couldn't find nvidia-smi
-  "
-  exit 0
-fi
-
-# Use NVidia SMI to determine the model
-gpu_model=`nvidia-smi -L`
-if test -z "$gpu_model" ; then
-  $XYMON $XYMSRV "status $MACHINE.gputemp $gpu_color `date`
-  GPUTEMP:$gpu_temp
-  Couldn't find nvidia card
-  "
-  exit 0
-fi
-
-# Determine GPU maximum temperature based on GPU model
-if test $(echo $gpu_model | grep -c -i 'GeForce 210') -eq 0 ; then
-  # GT 210 maximum GPU temperature is 105 C
-  max_temp=105
-elif test $(echo $gpu_model | grep -c -i 'GeForce 220') -eq 0 ; then
-  # GT 220 maximum GPU temperature is 105 C
-  max_temp=105
-elif test $(echo $gpu_model | grep -c -i 'GeForce 240') -eq 0 ; then
-  # GT 240 maximum GPU temperature is 105 C
-  max_temp=105
-elif test $(echo $gpu_model | grep -c -i 'GeForce 430') -eq 0 ; then
-  # GT 430 maximum GPU temperature is  98 C
-  max_temp=98
-elif test $(echo $gpu_model | grep -c -i 'GeForce GTS 450') -eq 0 ; then
-  # GTS 450 maximum GPU temperature is  100 C
-  max_temp=100
-elif test $(echo $gpu_model | grep -c -i 'GeForce GT 520') -eq 0 ; then
-  # GT 520 maximum GPU temperature is  102 C
-  max_temp=102
-else
-  # Assume 100 is the maximum
-  max_temp=100
-fi
-crit_temp=`expr $max_temp - 5`
-warn_temp=`expr $crit_temp - 10`
-
-if test -x /usr/bin/nvidia-smi ; then
-  temp=`nvidia-smi -q -g 0 -d TEMPERATURE | grep -Ei 'Gpu[[:space:]]+:[[:space:]]+[[:digit:]]+ C'`
-  gpu_temp=`echo $temp | sed -e 's/[^0-9]*//g'`
-  #echo "GPUTEMP:$gpu_temp" > /tmp/gputemp.txt
-  if test -n "$gpu_temp" ; then
-    # Have some type of number
-    if test $gpu_temp -lt $warn_temp ; then
-      gpu_color=green
-    elif test $gpu_temp -lt $crit_temp ; then
-      gpu_color=yellow
-    else
-      gpu_color=red
-    fi
-    #echo gputemp $gpu_temp $gpu_color
-    #echo $XYMON $XYMSRV "status $MACHINE.gputemp $gpu_color `date`
-    #`cat /tmp/gputemp.txt`
-    #"
-    $XYMON $XYMSRV "status $MACHINE.gputemp $gpu_color `date`
-    GPUTEMP:$gpu_temp
-    "
-  fi
-fi
-
-exit 0
\ No newline at end of file
diff --git a/abs/core/xymon/xymon-gputemp.sh b/abs/core/xymon/xymon-gputemp.sh
index cebea41..f8af649 100644
--- a/abs/core/xymon/xymon-gputemp.sh
+++ b/abs/core/xymon/xymon-gputemp.sh
@@ -55,7 +55,7 @@ crit_temp=`expr $max_temp - 5`
 warn_temp=`expr $crit_temp - 10`
 
 if test -x /usr/bin/nvidia-smi ; then
-  temp=`nvidia-smi -q -g 0 -d TEMPERATURE | grep -Ei 'Gpu[[:space:]]+:[[:space:]]+[[:digit:]]+ C'`
+  temp=`nvidia-smi -q -g 0 -d TEMPERATURE | grep -Ei 'GPU Current Temp[[:space:]]+:[[:space:]]+[[:digit:]]+ C'`
   gpu_temp=`echo $temp | sed -e 's/[^0-9]*//g'`
   #echo "GPUTEMP:$gpu_temp" > /tmp/gputemp.txt
   if test -n "$gpu_temp" ; then
@@ -80,4 +80,4 @@ if test -x /usr/bin/nvidia-smi ; then
   fi
 fi
 
-exit 0
\ No newline at end of file
+exit 0
-- 
cgit v0.12