From 9936b34b3782b3e163ae6f492523b722d180db90 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 4 Sep 2018 18:43:03 +0000
Subject: LinHES-config: mv_install.py: move mount2.28.2.tar.xz

change location to /root/linhes_install
---
 abs/core/LinHES-config/PKGBUILD      |  4 ++--
 abs/core/LinHES-config/mv_install.py | 12 ++++++------
 2 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index c744cac..424d709 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=8.5.2
-pkgrel=2
+pkgrel=3
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
 pkgdesc="Install and configure your system"
 depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -145,7 +145,7 @@ package() {
     install -o root -g root  -D -m 0755 blacklist_nouveau.conf $pkgdir/etc/modprobe.d/blacklist_nouveau.conf
 }
 
-md5sums=('7d8581ac5260617630078f2206d33117'
+md5sums=('49952a2375b8ee53d8673473f22f8d12'
          'bee51ac2c232ab134eec127f5c8846ad'
          'f6e9dd7bc6cf0aaa3bd203dab4cb79b9'
          '2596460462cf6c889cf8f95485537b20'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index 89dac8c..bf53476 100644
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -751,10 +751,10 @@ def mount_for_copy_it():
     #Versions of util-linux mount after 2.28.2 do not allow 1 image to be
     #    mounted to multiple loop devices.
     #Our ISO mounts airootfs.img to both / and /image_mount
-    cmd = 'tar -xvf /tmp/mount2.28.2.tar.xz -C /tmp/'
+    cmd = 'tar -xvf /root/linhes_install/mount2.28.2.tar.xz -C /root/linhes_install/'
     rc = runcmd(cmd)[0]
     if rc != 0 :
-        error_out("Failed to extract static mount from /tmp/mount2.28.2.tar.xz")
+        error_out("Failed to extract static mount from /root/linhes_install/mount2.28.2.tar.xz")
 
     mounts = {}
     mounts['/image_mount'] =  'airootfs'
@@ -763,7 +763,7 @@ def mount_for_copy_it():
             os.makedirs(image_mount)
         except:
             pass
-        cmd = '/tmp/mount /run/archiso/sfs/%s/%s.img %s' %(fsimage,fsimage,image_mount)
+        cmd = '/root/linhes_install/mount /run/archiso/sfs/%s/%s.img %s' %(fsimage,fsimage,image_mount)
         rc = runcmd(cmd)[0]
         if rc != 0 :
             error_out("Mount image %s" %fsimage)
@@ -773,7 +773,7 @@ def umount_for_copy_it():
     mounts = {}
     mounts['/image_mount'] =  'airootfs'
     for image_mount, fsimage in mounts.iteritems():
-        cmd='/tmp/umount %s' %(image_mount)
+        cmd='/root/linhes_install/umount %s' %(image_mount)
         rc = runcmd(cmd)[0]
         if rc != 0 :
             error_out("unMount image %s" %image_mount)
@@ -787,7 +787,7 @@ def copy_it(install_type):
     if ( install_type == "install"):
         logging.info("Transferring system")
 
-        cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig --exclude tmp/mount2.28.2.tar.xz /image_mount/* /new_boot']
+        cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig /image_mount/* /new_boot']
 
         for cmd in cmdlist:
             rc = runcmd(cmd)[0]
@@ -799,7 +799,7 @@ def copy_it(install_type):
     if ( install_type == "upgrade"):
         logging.info("Upgrading system")
 
-        cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig --exclude tmp/mount2.28.2.tar.xz --exclude /home --exclude /data/srv/mysql /image_mount/* /new_boot']
+        cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig --exclude /home --exclude /data/srv/mysql /image_mount/* /new_boot']
 
         for cmd in cmdlist:
             rc = runcmd(cmd)[0]
-- 
cgit v0.12