From e71f11d9865f691b2269d23d8dc66ef5cd1e3daa Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 21 Jan 2016 20:23:39 +0000
Subject: tilda: update to 1.3.1

---
 abs/core/tilda/PKGBUILD                 | 48 ++++++++------------
 abs/core/tilda/__changelog              |  6 ++-
 abs/core/tilda/config_0                 | 80 ++++++++++++++++++++++++++-------
 abs/core/tilda/tilda-conf-sigsegv.patch | 11 -----
 abs/core/tilda/tilda-fix.patch          | 24 ----------
 abs/core/tilda/tilda-glib2.patch        | 11 -----
 abs/core/tilda/tilda.changelog          | 52 ++++++++++++++++-----
 abs/core/tilda/tilda_hide.patch         | 38 ++++++++--------
 8 files changed, 148 insertions(+), 122 deletions(-)
 delete mode 100644 abs/core/tilda/tilda-conf-sigsegv.patch
 delete mode 100644 abs/core/tilda/tilda-fix.patch
 delete mode 100644 abs/core/tilda/tilda-glib2.patch

diff --git a/abs/core/tilda/PKGBUILD b/abs/core/tilda/PKGBUILD
index 814a5c3..6c4c7e7 100644
--- a/abs/core/tilda/PKGBUILD
+++ b/abs/core/tilda/PKGBUILD
@@ -1,49 +1,37 @@
-# $Id: PKGBUILD 71879 2012-06-02 18:37:37Z jlichtblau $
-# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# $Id$
+# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
 # Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
 # Contributor: William Rea <sillywilly@gmail.com>
 
 pkgname=tilda
-pkgver=0.9.6
-pkgrel=7
-pkgdesc="Linux terminal based on classic terminals from first person shooter games"
+pkgver=1.3.1
+pkgrel=2
+pkgdesc="A Gtk based drop down terminal for Linux and Unix"
 arch=('i686' 'x86_64')
-url="http://tilda.sourceforge.net"
+url="https://github.com/lanoxx/tilda"
 license=('GPL')
-depends=('vte' 'confuse' 'libglade')
-makedepends=('gawk')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
-tilda-fix.patch tilda-glib2.patch tilda-conf-sigsegv.patch config_0 tilda_hide.patch )
+depends=('vte3' 'confuse')
+changelog=$pkgname.changelog
+source=(https://github.com/lanoxx/$pkgname/archive/$pkgname-$pkgver.tar.gz
+        'tilda_hide.patch' 'config_0')
 
 build() {
-  cd $srcdir/$pkgname-$pkgver
-
-# gdk && desktop file fix FS#25762
-  patch -p0 -i ${srcdir}/$pkgname-fix.patch
-
-# glib2 fix
-  patch -p0 -i ${srcdir}/$pkgname-glib2.patch
-
-# fix segfaults on malformed config files FS#29754
-  patch -p0 -i ${srcdir}/$pkgname-conf-sigsegv.patch
+  cd $pkgname-$pkgname-$pkgver
 
   patch -p0 -i ${srcdir}/tilda_hide.patch
+  ./autogen.sh
   ./configure --prefix=/usr
   make
 }
 
 package() {
-  cd $srcdir/$pkgname-$pkgver
+  cd $pkgname-$pkgname-$pkgver
 
-  make DESTDIR=${pkgdir} install
+  make DESTDIR="${pkgdir}" install
 
   #default config
-  install -D -m 0755 $startdir/src/config_0 $startdir/pkg/etc/tilda_config
-
+  install -D -m 0755 ${srcdir}/config_0 ${pkgdir}/etc/tilda_config
 }
-md5sums=('b44ebe04fdfd312e9ddc5e0ed77f4289'
-         '6ca2c5ae5acd254b1e89b319b118b8e1'
-         'f1fc7009418c2ed7b506d5c555f072cb'
-         '3e08a0b2d48bba69cf96bef1faeca429'
-         '754753190e0990cd6fba27b3c931bd0e'
-         '0cc3020eabc74d939b0b978944d11693')
+md5sums=('2e1e40e73ccd4f03b3595b8842bb0397'
+         'eae07ef0ffb2e9dee3ba5eec3e87b920'
+         'e2fc4a2d0eb3205b1091e30f633b53f8')
diff --git a/abs/core/tilda/__changelog b/abs/core/tilda/__changelog
index b637dfd..153d015 100644
--- a/abs/core/tilda/__changelog
+++ b/abs/core/tilda/__changelog
@@ -1,2 +1,6 @@
 tilda_hide patch
-This stops tilda from showing the config wizard unless tilda is started with -C
+  This stops tilda from showing the config wizard unless tilda is started with -C
+
+add config_0 to /etc/tilda_config
+  /etc/X11/Session/LinHES will pull in /etc/tilda_config to ~/.config/tilda/
+    and adjust the height and width of the window based on screen size
diff --git a/abs/core/tilda/config_0 b/abs/core/tilda/config_0
index 198afd3..d3a7a33 100644
--- a/abs/core/tilda/config_0
+++ b/abs/core/tilda/config_0
@@ -1,28 +1,62 @@
-tilda_config_version = "0.9.6"
-# image = ""
+tilda_config_version = "1.3.1"
 # command = ""
-font = "Monospace 15"
+font = "DejaVu Sans Mono 14"
 key = "F3"
+addtab_key = "<Shift><Control>t"
+fullscreen_key = "F11"
+toggle_transparency_key = "F12"
+toggle_searchbar_key = "<Shift><Control>f"
+closetab_key = "<Shift><Control>w"
+nexttab_key = "<Control>Page_Down"
+prevtab_key = "<Control>Page_Up"
+movetableft_key = "<Shift><Control>Page_Up"
+movetabright_key = "<Shift><Control>Page_Down"
+gototab_1_key = "<Alt>1"
+gototab_2_key = "<Alt>2"
+gototab_3_key = "<Alt>3"
+gototab_4_key = "<Alt>4"
+gototab_5_key = "<Alt>5"
+gototab_6_key = "<Alt>6"
+gototab_7_key = "<Alt>7"
+gototab_8_key = "<Alt>8"
+gototab_9_key = "<Alt>9"
+gototab_10_key = "<Alt>0"
+copy_key = "<Shift><Control>c"
+paste_key = "<Shift><Control>v"
+quit_key = "<Shift><Control>q"
 title = "Tilda"
 background_color = "white"
 # working_dir = ""
-web_browser = "firefox"
-lines = 7000
-max_width = 1612
-max_height = 532
+web_browser = "google-chrome"
+increase_font_size_key = "<Control>equal"
+decrease_font_size_key = "<Control>minus"
+normalize_font_size_key = "<Control>0"
+# show_on_monitor = ""
+word_chars = "-A-Za-z0-9,./?%&#:_"
+lines = 8000
+max_width = 921
+max_height = 350
 min_width = 1
 min_height = 1
-transparency = 0
-x_pos = 1114
+x_pos = 51
 y_pos = 0
-tab_pos = 1
+tab_pos = 0
 backspace_key = 0
 delete_key = 1
 d_set_title = 3
 command_exit = 2
-scheme = 3
-slide_sleep_usec = 14607
+scheme = 0
+slide_sleep_usec = 10000
 animation_orientation = 0
+timer_resolution = 200
+auto_hide_time = 2000
+on_last_terminal_exit = 2
+palette_scheme = 0
+non_focus_pull_up_behaviour = 0
+cursor_shape = 0
+# show_on_monitor_number = 0
+title_max_length = 25
+palette = {11822, 13364, 13878, 52428, 0, 0, 20046, 39578, 1542, 50372, 41120, 0, 13364, 25957, 42148, 30069, 20560, 31611, 1542, 38944, 39578, 54227, 55255, 53199, 21845, 22359, 21331, 61423, 10537, 10537, 35466, 58082, 13364, 64764, 59881, 20303, 29298, 40863, 53199, 44461, 32639, 43176, 13364, 58082, 58082, 61166, 61166, 60652}
 scrollbar_pos = 2
 back_red = 0
 back_green = 0
@@ -30,12 +64,14 @@ back_blue = 0
 text_red = 65535
 text_green = 65535
 text_blue = 65535
-scroll_background = true
+cursor_red = 60395
+cursor_green = 47288
+cursor_blue = 7196
+scroll_history_infinite = false
 scroll_on_output = false
-notebook_border = true
+notebook_border = false
 antialias = true
 scrollbar = false
-use_image = false
 grab_focus = true
 above = true
 notaskbar = true
@@ -45,9 +81,21 @@ scroll_on_key = true
 bell = false
 run_command = false
 pinned = true
-animation = false
+animation = true
 hidden = true
+set_as_desktop = false
 centered_horizontally = true
 centered_vertically = false
 enable_transparency = false
 double_buffer = false
+auto_hide_on_focus_lost = false
+auto_hide_on_mouse_leave = false
+title_max_length_flag = true
+inherit_working_dir = true
+command_login_shell = false
+start_fullscreen = false
+# image = ""
+# scroll_background = false
+# use_image = false
+transparency = 0
+back_alpha = 65535
diff --git a/abs/core/tilda/tilda-conf-sigsegv.patch b/abs/core/tilda/tilda-conf-sigsegv.patch
deleted file mode 100644
index a48aad0..0000000
--- a/abs/core/tilda/tilda-conf-sigsegv.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/key_grabber.c	2008-04-08 00:12:31.000000000 +0200
-+++ src/key_grabber.c	2012-05-17 19:43:25.227699421 +0200
-@@ -257,7 +257,7 @@
- gboolean tilda_keygrabber_bind (const gchar *keystr, tilda_window *tw)
- {
-     /* Empty strings are no good */
--    if (strcmp ("", keystr) == 0)
-+    if (!keystr || strcmp ("", keystr) == 0)
-         return FALSE;
- 
-     return tomboy_keybinder_bind (keystr, onKeybindingPull, tw);
diff --git a/abs/core/tilda/tilda-fix.patch b/abs/core/tilda/tilda-fix.patch
deleted file mode 100644
index a6d273c..0000000
--- a/abs/core/tilda/tilda-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/key_grabber.c	2008-04-08 01:12:31.000000000 +0300
-+++ src/key_grabber.c	2009-10-16 17:39:16.399679408 +0300
-@@ -190,7 +190,7 @@
-          * Overriding the user time here seems to work a lot better than calling
-          * gtk_window_present_with_time() here, or at the end of the function. I have
-          * no idea why, they should do the same thing. */
--        gdk_x11_window_set_user_time (GTK_WIDGET(tw->window)->window,
-+        gdk_x11_window_set_user_time (GTK_WIDGET(tw->window),
-                                       tomboy_keybinder_get_current_event_time());
-         gtk_window_move (GTK_WINDOW(tw->window), config_getint ("x_pos"), config_getint ("y_pos"));
-         gtk_widget_show (GTK_WIDGET(tw->window));
-
---- tilda.desktop.in	2007-03-16 04:53:34.000000000 +0100
-+++ tilda.desktop.in	2011-08-28 19:08:53.000000000 +0200
-@@ -2 +1,0 @@
--Encoding=UTF-8
-@@ -4,2 +3,2 @@
--Exec=@BINDIR@/tilda
--Icon=@PIXMAPSDIR@/tilda.png
-+Exec=tilda
-+Icon=tilda
-@@ -8 +7 @@
--Categories=GNOME;GTK;Application;Utility;TerminalEmulator;
-+Categories=GNOME;GTK;Utility;TerminalEmulator;System;
diff --git a/abs/core/tilda/tilda-glib2.patch b/abs/core/tilda/tilda-glib2.patch
deleted file mode 100644
index 2d048e5..0000000
--- a/abs/core/tilda/tilda-glib2.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tomboykeybinder.h	2007-07-15 04:31:19.000000000 +0200
-+++ src/tomboykeybinder.h	2012-05-17 19:42:06.613150329 +0200
-@@ -2,7 +2,7 @@
- #ifndef __TOMBOY_KEY_BINDER_H__
- #define __TOMBOY_KEY_BINDER_H__
- 
--#include <glib/gtypes.h>
-+//#include <glib/gtypes.h>
- 
- G_BEGIN_DECLS
- 
diff --git a/abs/core/tilda/tilda.changelog b/abs/core/tilda/tilda.changelog
index 4248e9a..714a4ae 100644
--- a/abs/core/tilda/tilda.changelog
+++ b/abs/core/tilda/tilda.changelog
@@ -1,20 +1,52 @@
-2012-06-02  Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+2016-01-02 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.3.1-1
 
-	* FS#29754 fixed
+2015-11-18 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.3.0-1
 
-2011-08-28  Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+2015-06-28 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.2.4-1
 
-	* FS#25762 fixed
+2014-10-31 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.2.2-1
 
-2008-04-29  Mateusz Herych <heniekk@gmail.com>
+2014-10-17 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.2.1-1
 
-	* Updated for x86_64 - 0.9.6
+2014-10-16 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.2-1
 
-2008-04-28  Douglas Soares de Andrade  <dsa@aur.archlinux.org>
+2014-09-26 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.1.13-1
 
-	* Updated for i686 - 0.9.6
+2014-06-05 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.1.12-1
 
-2007-12-30  Douglas Soares de Andrade  <dsa@aur.archlinux.org>
+2013-12-14 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.1.10-1
 
-	* Updated to newer version - 0.9.5
+2013-11-17 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.1.8-1
+
+2013-08-22 Maxime Gauduin <alucryd@gmail.com>
+  * tilda 1.1.7-3
+  * Fixes FS#36542, FS#36516 and FS#36543
+
+2013-08-08 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * tilda 1.1.7-1
+
+2012-06-02 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * FS#29754 fixed
+
+2011-08-28 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+  * FS#25762 fixed
+
+2008-04-29 Mateusz Herych <heniekk@gmail.com>
+  * Updated for x86_64 - 0.9.6
+
+2008-04-28 Douglas Soares de Andrade <dsa@aur.archlinux.org>
+  * Updated for i686 - 0.9.6
+
+2007-12-30 Douglas Soares de Andrade <dsa@aur.archlinux.org>
+  * Updated to newer version - 0.9.5
 
diff --git a/abs/core/tilda/tilda_hide.patch b/abs/core/tilda/tilda_hide.patch
index 19d2869..a9d586f 100644
--- a/abs/core/tilda/tilda_hide.patch
+++ b/abs/core/tilda/tilda_hide.patch
@@ -1,35 +1,35 @@
---- src/tilda.c.orig	2012-12-10 13:11:23.336581090 -0600
-+++ src/tilda.c	2012-12-10 13:44:31.543784376 -0600
-@@ -582,11 +582,11 @@
-     if (access (tw->config_file, R_OK) == -1)
+--- src/tilda.c.orig	2016-01-21 18:11:13.800212725 +0000
++++ src/tilda.c	2016-01-21 18:17:31.901530136 +0000
+@@ -772,11 +772,11 @@
+     if (access (tw.config_file, R_OK) == -1)
      {
          /* We probably need a default key, too ... */
--        gchar *default_key = g_strdup_printf ("F%d", tw->instance+1);
-+        gchar *default_key = g_strdup_printf ("F%d", tw->instance+3);
+-        gchar *default_key = g_strdup_printf ("F%d", tw.instance+1);
++        gchar *default_key = g_strdup_printf ("F%d", tw.instance+3);
          config_setstr ("key", default_key);
          g_free (default_key);
  
 -        need_wizard = TRUE;
-+//         need_wizard = TRUE;
++//        need_wizard = TRUE;
      }
  
      /* Show the wizard if we need to.
-@@ -598,12 +598,12 @@
-     {
-         gint ret = tilda_keygrabber_bind (config_getstr ("key"), tw);
+@@ -788,12 +788,12 @@
+     } else {
+         gint ret = tilda_keygrabber_bind (config_getstr ("key"), &tw);
  
 -        if (!ret)
 -        {
 -            /* The key was unbindable, so we need to show the wizard */
--            show_invalid_keybinding_dialog (NULL);
--            wizard (tw);
+-            show_invalid_keybinding_dialog (NULL, _("The keybinding you chose for \"Pull Down Terminal\" is invalid. Please choose another."));
+-            wizard (&tw);
 -        }
-+//         if (!ret)
-+//         {
-+//             /* The key was unbindable, so we need to show the wizard */
-+//             show_invalid_keybinding_dialog (NULL);
-+//             wizard (tw);
-+//         }
++//        if (!ret)
++//        {
++//            /* The key was unbindable, so we need to show the wizard */
++//            show_invalid_keybinding_dialog (NULL, _("The keybinding you chose for \"Pull Down Terminal\" is invalid. Please choose another."));
++//            wizard (&tw);
++//        }
      }
  
-     if (config_getbool ("hidden"))
+     pull (&tw, config_getbool ("hidden") ? PULL_UP : PULL_DOWN, FALSE);
-- 
cgit v0.12