From c5d26982bf61f44fdc95fabdefe3d72a86705f27 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 2 Sep 2012 10:55:35 -0500
Subject: LinHES-system:  enhanced mode  remove fullscreen from mythtv windows
 when they start.  This allows them to be moved out of the way with the mouse.
  Should not cause any focus problems

---
 abs/core/LinHES-system/LinHES-session | 26 ++++++++++++++++++++++++++
 abs/core/LinHES-system/PKGBUILD       |  6 +++---
 2 files changed, 29 insertions(+), 3 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index ac90eff..902962f 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -264,6 +264,7 @@ function first_configure_mv(){
             then
                     /usr/MythVantage/bin/backend_control.sh stop BE 127.0.0.1
                      msg "MythTV setup is starting.\nPlease follow the steps for adding tuners and guide data."
+                    run_wmctrl &
                     /usr/bin/taskset -c 0 /usr/bin/mythtv-setup
                     /usr/MythVantage/bin/backend_control.sh start BE 127.0.0.1
             fi
@@ -303,6 +304,28 @@ function start_myth() {
 
     }
 
+function run_wmctrl(){
+    done="False"
+    for i in `seq 60`
+    do
+        for name in "MythTV Frontend" "MythTV Setup" "mythwelcome"
+        do
+            xwininfo -name "$name"
+            rc=$?
+            if [ $rc = 0 ]
+            then
+                wmctrl -r "$name" -b remove,fullscreen
+                done="True"
+            fi
+            if [ $done = "True" ]
+            then
+               break
+            fi
+         done
+        sleep 5
+    done
+
+}
 
 function run_myth(){
     if [ -f /tmp/nomfe ]
@@ -321,6 +344,8 @@ function run_myth(){
 
                 if [ x$STARTUP_STYLE = xenhanced ]
                 then
+
+                    run_wmctrl &
                     $STARTCMD 2>&1
                 else
                     $STARTCMD 2>&1 &
@@ -379,5 +404,6 @@ then
 fi
 
 
+wmctrl -r "MythTV Frontend" -b remove,fullscreen
 
 
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index d4f2173..f1e981e 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,12 +1,12 @@
 pkgname=LinHES-system
 pkgver=2
-pkgrel=76
+pkgrel=79
 arch=('i686' 'x86_64')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
 install=LinHES-system.install
 pkgdesc="scripts and things related to having an  automated system"
-depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo' 'python2-dbus' 'unclutter')
+depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo' 'python2-dbus' 'unclutter' 'wmctrl')
 backup=(etc/modprobe.d/alsa-base)
 binfiles="LinHES-start optimize_mythdb.py
  myth_mtc.py myth_mtc.sh LinHES-run
@@ -63,7 +63,7 @@ build() {
         mkdir $startdir/pkg/etc/logrotate.d
         cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
 }
-md5sums=('4921a6e21c71b263b8d23c51c24b939c'
+md5sums=('a941af97fe534731a507b1d57c0c2aed'
          '5881bdb43d578ec3a79d1f77ea58a3db'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
-- 
cgit v0.12