From 485e89f1ec966ac42a5f7dc9e3881157bee2acb8 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 7 Aug 2012 12:55:16 -0500
Subject: pinentry 0.8.1 -new

---
 abs/core/pinentry/PKGBUILD                  | 40 +++++++++++++++++++++++++++++
 abs/core/pinentry/pinentry.install          | 20 +++++++++++++++
 abs/core/pinentry/qt4-pinentry-window.patch | 28 ++++++++++++++++++++
 3 files changed, 88 insertions(+)
 create mode 100644 abs/core/pinentry/PKGBUILD
 create mode 100644 abs/core/pinentry/pinentry.install
 create mode 100644 abs/core/pinentry/qt4-pinentry-window.patch

diff --git a/abs/core/pinentry/PKGBUILD b/abs/core/pinentry/PKGBUILD
new file mode 100644
index 0000000..072a2b2
--- /dev/null
+++ b/abs/core/pinentry/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 160802 2012-06-06 10:36:53Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=pinentry
+pkgver=0.8.1
+pkgrel=4
+pkgdesc="a collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.gnupg.org/aegypten2"
+depends=('ncurses' 'libcap>=2.16')
+makedepends=('gtk2' 'qt')
+optdepends=('gtk2: for gtk2 backend'
+            'qt: for qt4 backend')  
+source=(ftp://ftp.gnupg.org/gcrypt/$pkgname/$pkgname-$pkgver.tar.gz
+        qt4-pinentry-window.patch)
+install=pinentry.install
+
+build() {
+  cd $srcdir/$pkgname-$pkgver
+  #fix: https://bugs.archlinux.org/task/29998
+  patch -Np1 -i ../qt4-pinentry-window.patch
+  for file in qt4/*.moc; do
+       /usr/bin/moc ${file/.moc/.h} > ${file}
+   done
+  ./configure --prefix=/usr \
+	--enable-pinentry-curses \
+        --disable-pinentry-gtk \
+        --disable-pinentry-qt \
+	--enable-pinentry-gtk2 \
+        --enable-pinentry-qt4 \
+	--enable-fallback-curses
+  make
+}
+
+package() {
+  cd $srcdir/$pkgname-$pkgver
+  make DESTDIR=${pkgdir} install 
+}
+md5sums=('81f99904daee5331eb6738408bb024b6'
+         '450b8713fe42f1bd93311ef84767c3d8')
diff --git a/abs/core/pinentry/pinentry.install b/abs/core/pinentry/pinentry.install
new file mode 100644
index 0000000..eed2c71
--- /dev/null
+++ b/abs/core/pinentry/pinentry.install
@@ -0,0 +1,20 @@
+infodir=usr/share/info
+filelist=(pinentry.info)
+
+post_install() {
+  [ -x usr/bin/install-info ] || return 0
+  for file in ${filelist[@]}; do
+    install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+  done
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+pre_remove() {
+  [ -x usr/bin/install-info ] || return 0
+  for file in ${filelist[@]}; do
+    install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
+  done
+}
diff --git a/abs/core/pinentry/qt4-pinentry-window.patch b/abs/core/pinentry/qt4-pinentry-window.patch
new file mode 100644
index 0000000..8f9faae
--- /dev/null
+++ b/abs/core/pinentry/qt4-pinentry-window.patch
@@ -0,0 +1,28 @@
+From c2ab12b3742c929a225c3753439438edc27bfa81 Mon Sep 17 00:00:00 2001
+From: Stanislav Ochotnicky <sochotnicky@redhat.com>
+Date: Tue, 1 Feb 2011 14:42:27 +0100
+Subject: [PATCH] Fix qt4 pinentry window created in the background
+
+This is probably just a workaround. Proper fix is being investigated.
+See:
+https://bugzilla.redhat.com/show_bug.cgi?id=589532
+http://stackoverflow.com/questions/2788518/calling-activatewindow-on-qdialog-sends-window-to-background
+---
+ qt4/pinentrydialog.cpp |    1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/qt4/pinentrydialog.cpp b/qt4/pinentrydialog.cpp
+index 541baf4..d634eb6 100644
+--- a/qt4/pinentrydialog.cpp
++++ b/qt4/pinentrydialog.cpp
+@@ -69,7 +69,6 @@ void raiseWindow( QWidget* w )
+     SetForegroundWindow( w->winId() );
+ #endif
+     w->raise();
+-    w->activateWindow();
+ }
+ 
+ QPixmap icon( QStyle::StandardPixmap which )
+-- 
+1.7.3.5
+
-- 
cgit v0.12