From 15753e5fe3531b87bbabd21d6ac789b8847ad656 Mon Sep 17 00:00:00 2001
From: Michael Hanson <mihanson@linhes.org>
Date: Tue, 21 Aug 2012 21:00:15 +0000
Subject: linhes-scripts: minor changes to myth2mkv

---
 abs/core/linhes-scripts/PKGBUILD | 4 ++--
 abs/core/linhes-scripts/myth2mkv | 7 +++++--
 2 files changed, 7 insertions(+), 4 deletions(-)

diff --git a/abs/core/linhes-scripts/PKGBUILD b/abs/core/linhes-scripts/PKGBUILD
index 0fb3dee..ebcc61b 100644
--- a/abs/core/linhes-scripts/PKGBUILD
+++ b/abs/core/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=7
-pkgrel=45
+pkgrel=46
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -106,6 +106,6 @@ md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
          'd8838461af9d446a1fd7e7883fdc75d1'
          'cc9cdabcdfc969c2829b58c0e513488c'
          '54a478660d0f8150fe10112a9ecf2740'
-         '8fa34662c686b210c9943324b7df2feb'
+         'bb8eae5de8a0d22f1722b3e7b2e32468'
          'b608044c9e7530a400d8f5b88fdfe6e6'
          'e2e24dd59d5d576cc33feafb329fa302')
diff --git a/abs/core/linhes-scripts/myth2mkv b/abs/core/linhes-scripts/myth2mkv
index f180b31..447e3c4 100644
--- a/abs/core/linhes-scripts/myth2mkv
+++ b/abs/core/linhes-scripts/myth2mkv
@@ -2,7 +2,7 @@
 #
 # Convert video to AVC-1 / h264
 #
-# version 0.25-002
+# version 0.25-003
 #
 # Prerequisites:
 #   - mythtv >= 0.25
@@ -204,10 +204,13 @@ if [[ ${QUALITY} = HQ ]] ; then
   if [[ -n ${CROP} ]] ; then
     CROP="--crop ${CROP}"
   else
-    CROP="--crop 0:0:0:0"
+    CROP="--crop 0:0:0:0 --strict-anamorphic"
   fi
   HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -x b-adapt=2:rc-lookahead=50 -b 5000 -2 -T ${WIDTH} ${HEIGHT} -r ${FPS} --cfr ${CROP} ${DEINT} -a 1 -E copy -s 1"
 else
+  if [[ ${CROP} = "--crop 0:0:0:0" ]] ; then
+    CROP="${CROP} --strict-anamorphic"
+  fi
   if [[ ${QUALITY} = LQ ]] ; then
     HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -b 1250 ${WIDTH} ${HEIGHT} -r ${FPS} --pfr ${CROP} ${DEINT} -a 1 -E lame -B 128 -Q 8 -6 stereo -s 1"
   else
-- 
cgit v0.12