From f0ee23059558e8bdc04fa7d70509fe74c978e30f Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 11 Feb 2023 15:16:13 -0500
Subject: linhes-system: add_storage.py: reconstrut check for symlink

---
 linhes/linhes-system/PKGBUILD       |  4 ++--
 linhes/linhes-system/add_storage.py | 11 +++++++----
 2 files changed, 9 insertions(+), 6 deletions(-)

diff --git a/linhes/linhes-system/PKGBUILD b/linhes/linhes-system/PKGBUILD
index 0336eed..59a45d0 100755
--- a/linhes/linhes-system/PKGBUILD
+++ b/linhes/linhes-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-system
 pkgver=9.0.0
-pkgrel=38
+pkgrel=39
 arch=('x86_64')
 #install=$pkgname.install
 pkgdesc="Everything that makes LinHES a system"
@@ -23,7 +23,7 @@ source=($binfiles
     '10-monitor.conf' 'x11vnc.override.conf' 'lh_lighttpd.conf' 'lh_php.ini'
     'system-sudo.rules' 'linhes-profile.sh' 'lh_sqlserver.cnf'
     'lh_system_start.sh.desktop' 'rc6_mce.toml' 'rsyslog.mythtv.conf')
-sha256sums=('7fd630d58a4268d98648eb7bdcf69a2d53ed326e3b58001d30a42305b04721ed'
+sha256sums=('525bfe29b63d3ec5a17a32fa29745e24070020490c3f5b6dd6b03250348fb324'
             '1ec3c266cafb0c1b231e88df88b97fec1a1b7465b5d95a0c1e64c8cb727b7c47'
             '97fe9e851c782fa9f85c5b69b110ccff2817dd4fa2a6d9ff6ee225dc558677e4'
             'ff261f41efec8a9963f9f59100cbe75f015028a2ed3a863ce0cb473f2ebb7b76'
diff --git a/linhes/linhes-system/add_storage.py b/linhes/linhes-system/add_storage.py
index 2d300a3..8821016 100755
--- a/linhes/linhes-system/add_storage.py
+++ b/linhes/linhes-system/add_storage.py
@@ -291,7 +291,7 @@ class disk_device:
 
         #determine options
         #new_options = self.find_options_type(fstab)[0]
-        new_options = "nofail,x-systemd.device-timeout=1"
+        new_options = "nofail,x-systemd.device-timeout=10"
 
         #find blkid
         self.block_partition="%s1" %self.block_path
@@ -908,8 +908,11 @@ class reconstruct_path:
     def symlink_disk(self):
         print("    Creating symlink for disk%s" %self.disk_num)
         disk_ln="%s/disk%s" %(self.top_mount_dir,self.disk_num)
-        cmd = "ln -s %s %s" %(self.mount_point,disk_ln)
-        runcmd(cmd)
+        if os.path.islink(disk_ln):
+            print("        Symlink %s exists. Skipping." %disk_ln)
+        else:
+            cmd = "ln -s %s %s" %(self.mount_point,disk_ln)
+            runcmd(cmd)
 
     def add_fstab(self):
         #new_fstab_list=['UUID=', 'mount_point', 'auto', 'defaults', '0', '1']
@@ -932,7 +935,7 @@ class reconstruct_path:
 
             #construct new line
             #new_options = self.find_options_type(fstab)[0]
-            new_options = "nofail,x-systemd.device-timeout=1"
+            new_options = "nofail,x-systemd.device-timeout=10"
             new_fstab_list[0]="UUID=%s" %self.uuid
             new_fstab_list[1]=self.mount_point
             new_fstab_list[3]=new_options
-- 
cgit v0.12