From 75a974500de1bb4b0bb84b726a9d7075d07e18b7 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 14 Mar 2009 13:38:20 -0500
Subject: Removing more cross repo makedepends. Moved the following packages
 from extra->core. nasm automake autoconf sharutils imake gperf/ yasm/
 setuptools/ libcaca/ libdca/ live-media/

There are still several cross repo make depends, but some packages just dont' belong in core.
For instance avahi and ca-certificates(core) depend on  mono and ruby(extra).  But really mono and ruby do not belong in core.
---
 abs/core-testing/autoconf/PKGBUILD          | 25 ++++++++++++++++++
 abs/core-testing/autoconf/autoconf.install  | 20 +++++++++++++++
 abs/core-testing/automake/PKGBUILD          | 25 ++++++++++++++++++
 abs/core-testing/automake/automake.install  | 20 +++++++++++++++
 abs/core-testing/gperf/PKGBUILD             | 20 +++++++++++++++
 abs/core-testing/imake/PKGBUILD             | 39 +++++++++++++++++++++++++++++
 abs/core-testing/imake/linuxconfig.patch    | 31 +++++++++++++++++++++++
 abs/core-testing/libcaca/PKGBUILD           | 20 +++++++++++++++
 abs/core-testing/libdca/PKGBUILD            | 22 ++++++++++++++++
 abs/core-testing/live-media/PKGBUILD        | 32 +++++++++++++++++++++++
 abs/core-testing/nasm/PKGBUILD              | 19 ++++++++++++++
 abs/core-testing/setuptools/PKGBUILD        | 23 +++++++++++++++++
 abs/core-testing/sharutils/PKGBUILD         | 20 +++++++++++++++
 abs/core-testing/yasm/PKGBUILD              | 23 +++++++++++++++++
 abs/extra-testing/autoconf/PKGBUILD         | 25 ------------------
 abs/extra-testing/autoconf/autoconf.install | 20 ---------------
 abs/extra-testing/automake/PKGBUILD         | 25 ------------------
 abs/extra-testing/automake/automake.install | 20 ---------------
 abs/extra-testing/gperf/PKGBUILD            | 20 ---------------
 abs/extra-testing/imake/PKGBUILD            | 39 -----------------------------
 abs/extra-testing/imake/linuxconfig.patch   | 31 -----------------------
 abs/extra-testing/libcaca/PKGBUILD          | 20 ---------------
 abs/extra-testing/libdca/PKGBUILD           | 22 ----------------
 abs/extra-testing/live-media/PKGBUILD       | 32 -----------------------
 abs/extra-testing/nasm/PKGBUILD             | 19 --------------
 abs/extra-testing/setuptools/PKGBUILD       | 23 -----------------
 abs/extra-testing/sharutils/PKGBUILD        | 20 ---------------
 abs/extra-testing/yasm/PKGBUILD             | 23 -----------------
 28 files changed, 339 insertions(+), 339 deletions(-)
 create mode 100644 abs/core-testing/autoconf/PKGBUILD
 create mode 100644 abs/core-testing/autoconf/autoconf.install
 create mode 100644 abs/core-testing/automake/PKGBUILD
 create mode 100644 abs/core-testing/automake/automake.install
 create mode 100644 abs/core-testing/gperf/PKGBUILD
 create mode 100644 abs/core-testing/imake/PKGBUILD
 create mode 100644 abs/core-testing/imake/linuxconfig.patch
 create mode 100644 abs/core-testing/libcaca/PKGBUILD
 create mode 100644 abs/core-testing/libdca/PKGBUILD
 create mode 100644 abs/core-testing/live-media/PKGBUILD
 create mode 100644 abs/core-testing/nasm/PKGBUILD
 create mode 100644 abs/core-testing/setuptools/PKGBUILD
 create mode 100644 abs/core-testing/sharutils/PKGBUILD
 create mode 100644 abs/core-testing/yasm/PKGBUILD
 delete mode 100644 abs/extra-testing/autoconf/PKGBUILD
 delete mode 100644 abs/extra-testing/autoconf/autoconf.install
 delete mode 100644 abs/extra-testing/automake/PKGBUILD
 delete mode 100644 abs/extra-testing/automake/automake.install
 delete mode 100644 abs/extra-testing/gperf/PKGBUILD
 delete mode 100644 abs/extra-testing/imake/PKGBUILD
 delete mode 100644 abs/extra-testing/imake/linuxconfig.patch
 delete mode 100644 abs/extra-testing/libcaca/PKGBUILD
 delete mode 100644 abs/extra-testing/libdca/PKGBUILD
 delete mode 100644 abs/extra-testing/live-media/PKGBUILD
 delete mode 100644 abs/extra-testing/nasm/PKGBUILD
 delete mode 100644 abs/extra-testing/setuptools/PKGBUILD
 delete mode 100644 abs/extra-testing/sharutils/PKGBUILD
 delete mode 100644 abs/extra-testing/yasm/PKGBUILD

diff --git a/abs/core-testing/autoconf/PKGBUILD b/abs/core-testing/autoconf/PKGBUILD
new file mode 100644
index 0000000..75bd7ef
--- /dev/null
+++ b/abs/core-testing/autoconf/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 12545 2008-09-15 12:33:36Z andyrtr $
+# Maintainer: Andreas Radke <adyrtr@archlinux.org>
+
+pkgname=autoconf
+pkgver=2.63
+pkgrel=1
+pkgdesc="A GNU tool for automatically configuring source code"
+arch=(i686 x86_64)
+license=('GPL2' 'GPL3')
+url="http://www.gnu.org/software/autoconf"
+groups=('base-devel')
+depends=('awk' 'm4' 'diffutils' 'bash')
+install=autoconf.install
+source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('43d76649fb86cd21d64f68c48d5abdcf')
+
+build() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+  rm -f ${pkgdir}/usr/share/info/dir
+  # conflict with bintuils
+  rm -f ${pkgdir}/usr/share/info/standards.info
+}
diff --git a/abs/core-testing/autoconf/autoconf.install b/abs/core-testing/autoconf/autoconf.install
new file mode 100644
index 0000000..6440ec6
--- /dev/null
+++ b/abs/core-testing/autoconf/autoconf.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(autoconf.info)
+
+post_install() {
+  for file in ${filelist[@]}; do
+    install-info $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+pre_remove() {
+  for file in ${filelist[@]}; do
+    install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/automake/PKGBUILD b/abs/core-testing/automake/PKGBUILD
new file mode 100644
index 0000000..2943f44
--- /dev/null
+++ b/abs/core-testing/automake/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 19545 2008-11-26 18:00:03Z andyrtr $
+# Contributor: judd <jvinet@zeroflux.org>
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=automake
+pkgver=1.10.2
+pkgrel=1
+pkgdesc="A GNU tool for automatically creating Makefiles"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.gnu.org/software/automake"
+groups=('base-devel')
+depends=('perl' 'bash' 'texinfo')
+install=automake.install
+source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('ede3e08c696861a01f4d2c6a2e822053')
+
+build() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+
+  rm -f ${pkgdir}/usr/share/info/dir
+}
diff --git a/abs/core-testing/automake/automake.install b/abs/core-testing/automake/automake.install
new file mode 100644
index 0000000..a1030e5
--- /dev/null
+++ b/abs/core-testing/automake/automake.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(automake.info automake.info-1 automake.info-2)
+
+post_install() {
+  for file in ${filelist[@]}; do
+    install-info $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+pre_remove() {
+  for file in ${filelist[@]}; do
+    install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+  done
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/gperf/PKGBUILD b/abs/core-testing/gperf/PKGBUILD
new file mode 100644
index 0000000..0521eb9
--- /dev/null
+++ b/abs/core-testing/gperf/PKGBUILD
@@ -0,0 +1,20 @@
+#$Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+#Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gperf
+pkgver=3.0.3
+pkgrel=1
+pkgdesc="Perfect hash function generator."
+arch=('x86_64' 'i686')
+url="http://www.gnu.org/software/gperf/"
+license=('GPL')
+depends=('gcc-libs')
+source=(ftp://ftp.gnu.org/gnu/gperf/${pkgname}-${pkgver}.tar.gz)
+md5sums=('cc20e58975a38075440423c8fb85fd00')
+
+build() {
+  cd $startdir/src/${pkgname}-${pkgver}
+  ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR=${startdir}/pkg install
+}
diff --git a/abs/core-testing/imake/PKGBUILD b/abs/core-testing/imake/PKGBUILD
new file mode 100644
index 0000000..ba2dc4c
--- /dev/null
+++ b/abs/core-testing/imake/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=imake
+pkgver=1.0.2
+pkgrel=3
+force=y
+pkgdesc="X.Org imake program and related utilities"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+depends=(glibc)
+makedepends=(pkgconfig xproto perl)
+source=(http://xorg.freedesktop.org/releases/individual/util/imake-1.0.2.tar.bz2
+	http://xorg.freedesktop.org/releases/individual/util/gccmakedep-1.0.2.tar.bz2
+	http://xorg.freedesktop.org/releases/individual/util/lndir-1.0.1.tar.bz2
+	http://xorg.freedesktop.org/releases/individual/util/makedepend-1.0.1.tar.bz2
+	http://xorg.freedesktop.org/releases/individual/util/xorg-cf-files-1.0.2.tar.bz2
+	linuxconfig.patch)
+
+build() {
+  cd ${startdir}/src/xorg-cf-files-*
+  patch -Np1 -i ${startdir}/src/linuxconfig.patch || return 1
+  cd ${startdir}/src
+  for i in *; do
+    if [ -d "${i}" ]; then
+      pushd "${i}"
+      ./configure --prefix=/usr
+      make || return 1
+      make DESTDIR=${startdir}/pkg install || return 1
+      popd
+    fi
+  done
+}
+md5sums=('02fea5a02ba2857c7d81820c8e8b8e6f'
+         'b533c0771dbbaf9b041ff35bb941d3a2'
+         'e274ea9f55dfd62afa0a7b1e1ab4ba96'
+         '54ab2549d723e51ff2b9cff4d8bf44d1'
+         '5f62dd5545b782c74f6e4e70d0e6552c'
+         '1b1d7653ac95d4b479784afcd61a889f')
diff --git a/abs/core-testing/imake/linuxconfig.patch b/abs/core-testing/imake/linuxconfig.patch
new file mode 100644
index 0000000..8e1c5a0
--- /dev/null
+++ b/abs/core-testing/imake/linuxconfig.patch
@@ -0,0 +1,31 @@
+--- xorg-cf-files-1.0.1/linux.cf.orig	2006-03-04 18:40:43.000000000 +0000
++++ xorg-cf-files-1.0.1/linux.cf	2006-03-04 18:41:48.000000000 +0000
+@@ -193,6 +193,13 @@
+ #define FSUseSyslog		YES
+ #endif
+ 
++#define FSUseSyslog		YES
++#define BuildRman		NO
++#define BuildHtmlManPages	NO
++#define ProjectRoot		/usr
++#define ManPath			/usr/man
++#define XappLoadDir		/usr/share/X11/app-defaults
++
+ #ifndef HasDevRandom
+ # define HasDevRandom YES
+ # ifndef RandomDeviceName
+--- xorg-cf-files-1.0.2/X11.tmpl.orig	2006-07-15 10:45:23.000000000 +0000
++++ xorg-cf-files-1.0.2/X11.tmpl	2006-07-15 10:46:19.000000000 +0000
+@@ -1502,10 +1502,10 @@
+ #define DocPdfDir $(DOCDIR)/PDF
+ #endif
+ #ifndef FontDir
+-#define FontDir $(LIBDIR)/fonts
++#define FontDir /usr/share/fonts
+ #endif
+ #ifndef FontEncDir
+-#define FontEncDir $(LIBDIR)/fonts/encodings
++#define FontEncDir /usr/share/fonts/encodings
+ #endif
+ #ifndef AdmDir
+ #define AdmDir /usr/adm
diff --git a/abs/core-testing/libcaca/PKGBUILD b/abs/core-testing/libcaca/PKGBUILD
new file mode 100644
index 0000000..f0c3710
--- /dev/null
+++ b/abs/core-testing/libcaca/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 9776 2008-08-19 00:46:51Z eric $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libcaca
+pkgver=0.9
+pkgrel=2
+pkgdesc="Color AsCii Art library"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://libcaca.zoy.org/"
+depends=('freetype2' 'imlib2' 'ncurses>=5.6-7')
+source=(http://libcaca.zoy.org/files/libcaca/${pkgname}-${pkgver}.tar.gz)
+md5sums=('97b0f526f39491389e159055f574c921')
+
+build() {
+  cd ${startdir}/src/${pkgname}-${pkgver}
+  ./configure --prefix=/usr --mandir=/usr/share/man --enable-shared --disable-doc
+  make || return 1
+  make DESTDIR=${startdir}/pkg install
+}
diff --git a/abs/core-testing/libdca/PKGBUILD b/abs/core-testing/libdca/PKGBUILD
new file mode 100644
index 0000000..4794c02
--- /dev/null
+++ b/abs/core-testing/libdca/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=libdca
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Free library for decoding DTS Coherent Acoustics streams"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.videolan.org/developers/libdca.html"
+source=(http://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
+md5sums=('dab6b2795c66a82a6fcd4f8343343021')
+provides=('libdts')
+replaces=('libdts')
+options=('!libtool' '!emptydirs')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR=$startdir/pkg install
+}
diff --git a/abs/core-testing/live-media/PKGBUILD b/abs/core-testing/live-media/PKGBUILD
new file mode 100644
index 0000000..f3f230d
--- /dev/null
+++ b/abs/core-testing/live-media/PKGBUILD
@@ -0,0 +1,32 @@
+#$Id: PKGBUILD 21746 2008-12-15 23:00:08Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Gilles CHAUVIN <gcnweb@gmail.com>
+
+pkgname=live-media
+pkgver=2008.12.20
+pkgrel=1
+pkgdesc="A set of C++ libraries for multimedia streaming"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://live555.com/liveMedia"
+depends=(gcc-libs)
+source=(http://live555.com/liveMedia/public/live.$pkgver.tar.gz)
+md5sums=('266d9b15f57ca952667780d9c2185e5e')
+
+build()
+{
+  cd $startdir/src/live
+  sed -i "s|COMPILE_OPTS =.*|COMPILE_OPTS = \$(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 $CFLAGS|g" config.linux
+  ./genMakefiles linux
+  make || return 1
+
+  for dir in BasicUsageEnvironment UsageEnvironment groupsock liveMedia; do
+    mkdir -p $startdir/pkg/usr/lib/$pkgname/$dir
+    cp -r $dir/*.a $dir/include $startdir/pkg/usr/lib/$pkgname/$dir
+  done
+
+  mkdir -p $startdir/pkg/usr/bin
+  for testprog in `find testProgs -type f -perm 755`; do
+    install $testprog $startdir/pkg/usr/bin
+  done
+}
diff --git a/abs/core-testing/nasm/PKGBUILD b/abs/core-testing/nasm/PKGBUILD
new file mode 100644
index 0000000..fbac564
--- /dev/null
+++ b/abs/core-testing/nasm/PKGBUILD
@@ -0,0 +1,19 @@
+# $Id: PKGBUILD,v 1.11 2005/03/01 07:53:53 dorphell Exp $
+# Maintainer: dorphell <dorphell@archlinux.org>
+# Committer: Judd Vinet <jvinet@zeroflux.org>
+pkgname=nasm
+pkgver=0.98.39
+pkgrel=1
+pkgdesc="80x86 assembler designed for portability and modularity"
+depends=('glibc')
+arch=i686
+source=(http://easynews.dl.sourceforge.net/sourceforge/nasm/nasm-$pkgver.tar.bz2)
+md5sums=('2032ad44c7359f7a9a166a40a633e772')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  ./configure --prefix=/usr
+  make || return 1
+  mkdir -p $startdir/pkg/usr/{bin,man/man1}
+  make prefix=$startdir/pkg/usr install
+}
diff --git a/abs/core-testing/setuptools/PKGBUILD b/abs/core-testing/setuptools/PKGBUILD
new file mode 100644
index 0000000..53c26a9
--- /dev/null
+++ b/abs/core-testing/setuptools/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 16826 2008-10-22 12:40:52Z douglas $
+# Maintainer: simo <simo@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+# Contributor: Todd Maynard <arch@toddmaynard.com>
+
+pkgname=setuptools
+pkgver=0.6c9
+pkgrel=2
+pkgdesc="setuptools is a collection of enhancements to the Python distutils"
+license=('PSF')
+arch=(i686 x86_64)
+url="http://peak.telecommunity.com/DevCenter/setuptools"
+depends=('python')
+source=(http://cheeseshop.python.org/packages/source/s/$pkgname/$pkgname-$pkgver.tar.gz)
+
+md5sums=('3864c01d9c719c8924c455714492295e')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  mkdir -p $startdir/pkg/usr/lib/python2.6/site-packages
+  python setup.py install --root=$startdir/pkg
+  echo "/usr/lib/python2.6/site-packages/$pkgname-$pkgver-py2.6.egg" > $startdir/pkg/usr/lib/python2.6/site-packages/setuptools.pth
+}
diff --git a/abs/core-testing/sharutils/PKGBUILD b/abs/core-testing/sharutils/PKGBUILD
new file mode 100644
index 0000000..6971668
--- /dev/null
+++ b/abs/core-testing/sharutils/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Kevin Piche <kevin@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=sharutils
+pkgver=4.6.3
+pkgrel=1
+pkgdesc="GNU shar makes so-called shell archives out of many files"
+arch=(i686 x86_64)
+depends=('gettext')
+source=(ftp://ftp.gnu.org/pub/gnu/$pkgname/REL-$pkgver/$pkgname-$pkgver.tar.gz)
+url="http://www.gnu.org/software/sharutils/"
+md5sums=('74127a560e59be6dfa8b59993eb0ca91')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  ./configure --prefix=/usr --disable-nls
+  make || return 1
+  make prefix=$startdir/pkg/usr install
+}
diff --git a/abs/core-testing/yasm/PKGBUILD b/abs/core-testing/yasm/PKGBUILD
new file mode 100644
index 0000000..fcbd935
--- /dev/null
+++ b/abs/core-testing/yasm/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 18746 2008-11-08 22:44:05Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
+
+pkgname=yasm
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A rewrite of NASM to allow for multiple syntax supported (NASM, TASM, GAS, etc.)"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.tortall.net/projects/yasm/"
+depends=('glibc')
+source=(http://www.tortall.net/projects/yasm/releases/$pkgname-$pkgver.tar.gz)
+options=('!libtool')
+md5sums=('cc9360593de5625dca286f0bfcb27dd5')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  ./configure --prefix=/usr
+  make || return 1
+  make DESTDIR=$startdir/pkg install
+  install -Dm644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/abs/extra-testing/autoconf/PKGBUILD b/abs/extra-testing/autoconf/PKGBUILD
deleted file mode 100644
index 75bd7ef..0000000
--- a/abs/extra-testing/autoconf/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# $Id: PKGBUILD 12545 2008-09-15 12:33:36Z andyrtr $
-# Maintainer: Andreas Radke <adyrtr@archlinux.org>
-
-pkgname=autoconf
-pkgver=2.63
-pkgrel=1
-pkgdesc="A GNU tool for automatically configuring source code"
-arch=(i686 x86_64)
-license=('GPL2' 'GPL3')
-url="http://www.gnu.org/software/autoconf"
-groups=('base-devel')
-depends=('awk' 'm4' 'diffutils' 'bash')
-install=autoconf.install
-source=(ftp://ftp.gnu.org/pub/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('43d76649fb86cd21d64f68c48d5abdcf')
-
-build() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  ./configure --prefix=/usr
-  make || return 1
-  make DESTDIR=${pkgdir} install || return 1
-  rm -f ${pkgdir}/usr/share/info/dir
-  # conflict with bintuils
-  rm -f ${pkgdir}/usr/share/info/standards.info
-}
diff --git a/abs/extra-testing/autoconf/autoconf.install b/abs/extra-testing/autoconf/autoconf.install
deleted file mode 100644
index 6440ec6..0000000
--- a/abs/extra-testing/autoconf/autoconf.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=/usr/share/info
-filelist=(autoconf.info)
-
-post_install() {
-  for file in ${filelist[@]}; do
-    install-info $infodir/$file $infodir/dir 2> /dev/null
-  done
-}
-
-post_upgrade() {
-  post_install $1
-}
-
-pre_remove() {
-  for file in ${filelist[@]}; do
-    install-info --delete $infodir/$file $infodir/dir 2> /dev/null
-  done
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/extra-testing/automake/PKGBUILD b/abs/extra-testing/automake/PKGBUILD
deleted file mode 100644
index 2943f44..0000000
--- a/abs/extra-testing/automake/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# $Id: PKGBUILD 19545 2008-11-26 18:00:03Z andyrtr $
-# Contributor: judd <jvinet@zeroflux.org>
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-
-pkgname=automake
-pkgver=1.10.2
-pkgrel=1
-pkgdesc="A GNU tool for automatically creating Makefiles"
-arch=(i686 x86_64)
-license=('GPL')
-url="http://www.gnu.org/software/automake"
-groups=('base-devel')
-depends=('perl' 'bash' 'texinfo')
-install=automake.install
-source=(ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('ede3e08c696861a01f4d2c6a2e822053')
-
-build() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  ./configure --prefix=/usr
-  make || return 1
-  make DESTDIR=${pkgdir} install || return 1
-
-  rm -f ${pkgdir}/usr/share/info/dir
-}
diff --git a/abs/extra-testing/automake/automake.install b/abs/extra-testing/automake/automake.install
deleted file mode 100644
index a1030e5..0000000
--- a/abs/extra-testing/automake/automake.install
+++ /dev/null
@@ -1,20 +0,0 @@
-infodir=/usr/share/info
-filelist=(automake.info automake.info-1 automake.info-2)
-
-post_install() {
-  for file in ${filelist[@]}; do
-    install-info $infodir/$file $infodir/dir 2> /dev/null
-  done
-}
-
-post_upgrade() {
-  post_install $1
-}
-
-pre_remove() {
-  for file in ${filelist[@]}; do
-    install-info --delete $infodir/$file $infodir/dir 2> /dev/null
-  done
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/extra-testing/gperf/PKGBUILD b/abs/extra-testing/gperf/PKGBUILD
deleted file mode 100644
index 0521eb9..0000000
--- a/abs/extra-testing/gperf/PKGBUILD
+++ /dev/null
@@ -1,20 +0,0 @@
-#$Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-#Maintainer: Jan de Groot <jgc@archlinux.org>
-
-pkgname=gperf
-pkgver=3.0.3
-pkgrel=1
-pkgdesc="Perfect hash function generator."
-arch=('x86_64' 'i686')
-url="http://www.gnu.org/software/gperf/"
-license=('GPL')
-depends=('gcc-libs')
-source=(ftp://ftp.gnu.org/gnu/gperf/${pkgname}-${pkgver}.tar.gz)
-md5sums=('cc20e58975a38075440423c8fb85fd00')
-
-build() {
-  cd $startdir/src/${pkgname}-${pkgver}
-  ./configure --prefix=/usr
-  make || return 1
-  make DESTDIR=${startdir}/pkg install
-}
diff --git a/abs/extra-testing/imake/PKGBUILD b/abs/extra-testing/imake/PKGBUILD
deleted file mode 100644
index ba2dc4c..0000000
--- a/abs/extra-testing/imake/PKGBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=imake
-pkgver=1.0.2
-pkgrel=3
-force=y
-pkgdesc="X.Org imake program and related utilities"
-arch=(i686 x86_64)
-url="http://xorg.freedesktop.org/"
-depends=(glibc)
-makedepends=(pkgconfig xproto perl)
-source=(http://xorg.freedesktop.org/releases/individual/util/imake-1.0.2.tar.bz2
-	http://xorg.freedesktop.org/releases/individual/util/gccmakedep-1.0.2.tar.bz2
-	http://xorg.freedesktop.org/releases/individual/util/lndir-1.0.1.tar.bz2
-	http://xorg.freedesktop.org/releases/individual/util/makedepend-1.0.1.tar.bz2
-	http://xorg.freedesktop.org/releases/individual/util/xorg-cf-files-1.0.2.tar.bz2
-	linuxconfig.patch)
-
-build() {
-  cd ${startdir}/src/xorg-cf-files-*
-  patch -Np1 -i ${startdir}/src/linuxconfig.patch || return 1
-  cd ${startdir}/src
-  for i in *; do
-    if [ -d "${i}" ]; then
-      pushd "${i}"
-      ./configure --prefix=/usr
-      make || return 1
-      make DESTDIR=${startdir}/pkg install || return 1
-      popd
-    fi
-  done
-}
-md5sums=('02fea5a02ba2857c7d81820c8e8b8e6f'
-         'b533c0771dbbaf9b041ff35bb941d3a2'
-         'e274ea9f55dfd62afa0a7b1e1ab4ba96'
-         '54ab2549d723e51ff2b9cff4d8bf44d1'
-         '5f62dd5545b782c74f6e4e70d0e6552c'
-         '1b1d7653ac95d4b479784afcd61a889f')
diff --git a/abs/extra-testing/imake/linuxconfig.patch b/abs/extra-testing/imake/linuxconfig.patch
deleted file mode 100644
index 8e1c5a0..0000000
--- a/abs/extra-testing/imake/linuxconfig.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- xorg-cf-files-1.0.1/linux.cf.orig	2006-03-04 18:40:43.000000000 +0000
-+++ xorg-cf-files-1.0.1/linux.cf	2006-03-04 18:41:48.000000000 +0000
-@@ -193,6 +193,13 @@
- #define FSUseSyslog		YES
- #endif
- 
-+#define FSUseSyslog		YES
-+#define BuildRman		NO
-+#define BuildHtmlManPages	NO
-+#define ProjectRoot		/usr
-+#define ManPath			/usr/man
-+#define XappLoadDir		/usr/share/X11/app-defaults
-+
- #ifndef HasDevRandom
- # define HasDevRandom YES
- # ifndef RandomDeviceName
---- xorg-cf-files-1.0.2/X11.tmpl.orig	2006-07-15 10:45:23.000000000 +0000
-+++ xorg-cf-files-1.0.2/X11.tmpl	2006-07-15 10:46:19.000000000 +0000
-@@ -1502,10 +1502,10 @@
- #define DocPdfDir $(DOCDIR)/PDF
- #endif
- #ifndef FontDir
--#define FontDir $(LIBDIR)/fonts
-+#define FontDir /usr/share/fonts
- #endif
- #ifndef FontEncDir
--#define FontEncDir $(LIBDIR)/fonts/encodings
-+#define FontEncDir /usr/share/fonts/encodings
- #endif
- #ifndef AdmDir
- #define AdmDir /usr/adm
diff --git a/abs/extra-testing/libcaca/PKGBUILD b/abs/extra-testing/libcaca/PKGBUILD
deleted file mode 100644
index f0c3710..0000000
--- a/abs/extra-testing/libcaca/PKGBUILD
+++ /dev/null
@@ -1,20 +0,0 @@
-# $Id: PKGBUILD 9776 2008-08-19 00:46:51Z eric $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-
-pkgname=libcaca
-pkgver=0.9
-pkgrel=2
-pkgdesc="Color AsCii Art library"
-arch=('i686' 'x86_64')
-license=('LGPL')
-url="http://libcaca.zoy.org/"
-depends=('freetype2' 'imlib2' 'ncurses>=5.6-7')
-source=(http://libcaca.zoy.org/files/libcaca/${pkgname}-${pkgver}.tar.gz)
-md5sums=('97b0f526f39491389e159055f574c921')
-
-build() {
-  cd ${startdir}/src/${pkgname}-${pkgver}
-  ./configure --prefix=/usr --mandir=/usr/share/man --enable-shared --disable-doc
-  make || return 1
-  make DESTDIR=${startdir}/pkg install
-}
diff --git a/abs/extra-testing/libdca/PKGBUILD b/abs/extra-testing/libdca/PKGBUILD
deleted file mode 100644
index 4794c02..0000000
--- a/abs/extra-testing/libdca/PKGBUILD
+++ /dev/null
@@ -1,22 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-
-pkgname=libdca
-pkgver=0.0.5
-pkgrel=1
-pkgdesc="Free library for decoding DTS Coherent Acoustics streams"
-arch=(i686 x86_64)
-license=('GPL')
-url="http://www.videolan.org/developers/libdca.html"
-source=(http://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
-md5sums=('dab6b2795c66a82a6fcd4f8343343021')
-provides=('libdts')
-replaces=('libdts')
-options=('!libtool' '!emptydirs')
-
-build() {
-  cd $startdir/src/$pkgname-$pkgver
-  ./configure --prefix=/usr
-  make || return 1
-  make DESTDIR=$startdir/pkg install
-}
diff --git a/abs/extra-testing/live-media/PKGBUILD b/abs/extra-testing/live-media/PKGBUILD
deleted file mode 100644
index f3f230d..0000000
--- a/abs/extra-testing/live-media/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-#$Id: PKGBUILD 21746 2008-12-15 23:00:08Z giovanni $
-# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
-# Contributor: Gilles CHAUVIN <gcnweb@gmail.com>
-
-pkgname=live-media
-pkgver=2008.12.20
-pkgrel=1
-pkgdesc="A set of C++ libraries for multimedia streaming"
-arch=('i686' 'x86_64')
-license=('LGPL')
-url="http://live555.com/liveMedia"
-depends=(gcc-libs)
-source=(http://live555.com/liveMedia/public/live.$pkgver.tar.gz)
-md5sums=('266d9b15f57ca952667780d9c2185e5e')
-
-build()
-{
-  cd $startdir/src/live
-  sed -i "s|COMPILE_OPTS =.*|COMPILE_OPTS = \$(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 $CFLAGS|g" config.linux
-  ./genMakefiles linux
-  make || return 1
-
-  for dir in BasicUsageEnvironment UsageEnvironment groupsock liveMedia; do
-    mkdir -p $startdir/pkg/usr/lib/$pkgname/$dir
-    cp -r $dir/*.a $dir/include $startdir/pkg/usr/lib/$pkgname/$dir
-  done
-
-  mkdir -p $startdir/pkg/usr/bin
-  for testprog in `find testProgs -type f -perm 755`; do
-    install $testprog $startdir/pkg/usr/bin
-  done
-}
diff --git a/abs/extra-testing/nasm/PKGBUILD b/abs/extra-testing/nasm/PKGBUILD
deleted file mode 100644
index fbac564..0000000
--- a/abs/extra-testing/nasm/PKGBUILD
+++ /dev/null
@@ -1,19 +0,0 @@
-# $Id: PKGBUILD,v 1.11 2005/03/01 07:53:53 dorphell Exp $
-# Maintainer: dorphell <dorphell@archlinux.org>
-# Committer: Judd Vinet <jvinet@zeroflux.org>
-pkgname=nasm
-pkgver=0.98.39
-pkgrel=1
-pkgdesc="80x86 assembler designed for portability and modularity"
-depends=('glibc')
-arch=i686
-source=(http://easynews.dl.sourceforge.net/sourceforge/nasm/nasm-$pkgver.tar.bz2)
-md5sums=('2032ad44c7359f7a9a166a40a633e772')
-
-build() {
-  cd $startdir/src/$pkgname-$pkgver
-  ./configure --prefix=/usr
-  make || return 1
-  mkdir -p $startdir/pkg/usr/{bin,man/man1}
-  make prefix=$startdir/pkg/usr install
-}
diff --git a/abs/extra-testing/setuptools/PKGBUILD b/abs/extra-testing/setuptools/PKGBUILD
deleted file mode 100644
index 53c26a9..0000000
--- a/abs/extra-testing/setuptools/PKGBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# $Id: PKGBUILD 16826 2008-10-22 12:40:52Z douglas $
-# Maintainer: simo <simo@archlinux.org>
-# Contributor: William Rea <sillywilly@gmail.com>
-# Contributor: Todd Maynard <arch@toddmaynard.com>
-
-pkgname=setuptools
-pkgver=0.6c9
-pkgrel=2
-pkgdesc="setuptools is a collection of enhancements to the Python distutils"
-license=('PSF')
-arch=(i686 x86_64)
-url="http://peak.telecommunity.com/DevCenter/setuptools"
-depends=('python')
-source=(http://cheeseshop.python.org/packages/source/s/$pkgname/$pkgname-$pkgver.tar.gz)
-
-md5sums=('3864c01d9c719c8924c455714492295e')
-
-build() {
-  cd $startdir/src/$pkgname-$pkgver
-  mkdir -p $startdir/pkg/usr/lib/python2.6/site-packages
-  python setup.py install --root=$startdir/pkg
-  echo "/usr/lib/python2.6/site-packages/$pkgname-$pkgver-py2.6.egg" > $startdir/pkg/usr/lib/python2.6/site-packages/setuptools.pth
-}
diff --git a/abs/extra-testing/sharutils/PKGBUILD b/abs/extra-testing/sharutils/PKGBUILD
deleted file mode 100644
index 6971668..0000000
--- a/abs/extra-testing/sharutils/PKGBUILD
+++ /dev/null
@@ -1,20 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Kevin Piche <kevin@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-
-pkgname=sharutils
-pkgver=4.6.3
-pkgrel=1
-pkgdesc="GNU shar makes so-called shell archives out of many files"
-arch=(i686 x86_64)
-depends=('gettext')
-source=(ftp://ftp.gnu.org/pub/gnu/$pkgname/REL-$pkgver/$pkgname-$pkgver.tar.gz)
-url="http://www.gnu.org/software/sharutils/"
-md5sums=('74127a560e59be6dfa8b59993eb0ca91')
-
-build() {
-  cd $startdir/src/$pkgname-$pkgver
-  ./configure --prefix=/usr --disable-nls
-  make || return 1
-  make prefix=$startdir/pkg/usr install
-}
diff --git a/abs/extra-testing/yasm/PKGBUILD b/abs/extra-testing/yasm/PKGBUILD
deleted file mode 100644
index fcbd935..0000000
--- a/abs/extra-testing/yasm/PKGBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# $Id: PKGBUILD 18746 2008-11-08 22:44:05Z aaron $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
-
-pkgname=yasm
-pkgver=0.7.2
-pkgrel=1
-pkgdesc="A rewrite of NASM to allow for multiple syntax supported (NASM, TASM, GAS, etc.)"
-arch=('i686' 'x86_64')
-license=('custom')
-url="http://www.tortall.net/projects/yasm/"
-depends=('glibc')
-source=(http://www.tortall.net/projects/yasm/releases/$pkgname-$pkgver.tar.gz)
-options=('!libtool')
-md5sums=('cc9360593de5625dca286f0bfcb27dd5')
-
-build() {
-  cd $startdir/src/$pkgname-$pkgver
-  ./configure --prefix=/usr
-  make || return 1
-  make DESTDIR=$startdir/pkg install
-  install -Dm644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
-}
-- 
cgit v0.12