From d1f77047874dae53231805117878c25ec240bb43 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 18 Nov 2010 01:56:07 +0000
Subject: python-netifaces: update/bump

---
 abs/core/python-netifaces/PKGBUILD | 31 +++++++++++++++++++------------
 1 file changed, 19 insertions(+), 12 deletions(-)

diff --git a/abs/core/python-netifaces/PKGBUILD b/abs/core/python-netifaces/PKGBUILD
index 13a424e..8f89bab 100644
--- a/abs/core/python-netifaces/PKGBUILD
+++ b/abs/core/python-netifaces/PKGBUILD
@@ -1,17 +1,24 @@
+#Maintainer: Gergely Imreh <imrehg(at)gmail(dot)com>
+#Contributor: Gergely Imreh <imrehg(at)gmail(dot)com>
 pkgname=python-netifaces
-__pkgname="netifaces"
+_orig_name=netifaces
 pkgver=0.5
-pkgrel=2
-pkgdesc="Python modules for network interfaces"
-arch=(i686 x86_64)
-license=('LGPL' 'MPL')
-depends=('python')
-makedepends=('setuptools' )
-source=(http://alastairs-place.net/2007/03/netifaces/netifaces-0.5.tar.gz)
+pkgrel=1
+pkgdesc="Portable module to access network interface information in Python."
+depends=('python2')
+makedepend=('gcc')
+arch=('i686' 'x86_64')
 url="http://alastairs-place.net/netifaces/"
-
+license=('MIT')
+provides=('netifaces' 'python-netifaces')
+source=("http://alastairs-place.net/2007/03/netifaces/${_orig_name}-${pkgver}.tar.gz")
 build() {
-  cd "${srcdir}/${__pkgname}-${pkgver}"
-  chmod -x -R netifaces.egg-info
-  yes "" | python setup.py install --root=$startdir/pkg --prefix=/usr
+  cd "${srcdir}/${_orig_name}-${pkgver}"
+  python2 setup.py install --root "${pkgdir}" || return 1
+
+  # Install license, that is inside the readme file
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 README "${pkgdir}/usr/share/licenses/${pkgname}/README" || return 1
 }
+md5sums=('ea662a4b4c7db5d1631cc33bf68eb030')
+
-- 
cgit v0.12