From b7c8512b6c3d33b807dc0d7014b01c148a0ddc6d Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 19 Aug 2011 16:20:57 -0500
Subject: LinHes-session: make it depend on  fluxbox and windowmaker

---
 abs/core/LinHES-system/LinHES-session | 8 +++++++-
 abs/core/LinHES-system/PKGBUILD       | 8 ++++----
 2 files changed, 11 insertions(+), 5 deletions(-)

diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index 52924d2..815c3d5 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -7,7 +7,13 @@ xhost +127.0.0.1
 xset -dpms s off
 export MALLOC_CHECK_=0
 #start fluxbox
-fluxbox > /var/log/fluxbox.log 2>&1
+if [ x$WM = "x" ]
+then
+	fluxbox > /var/log/fluxbox.log 2>&1
+
+else
+	$WM 2>&1
+fi
 
 
 
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index a3b4d62..9baad6e 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,12 +1,12 @@
 pkgname=LinHES-system
 pkgver=2
-pkgrel=4
+pkgrel=7
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
 install=LinHES.install
-pkgdesc="scripts and things related to having a automated system"
-depends=(linhes-sounds xdotool)
+pkgdesc="scripts and things related to having an  automated system"
+depends=(linhes-sounds xdotool fluxbox windowmaker)
 backup=(etc/modprobe.d/alsa-base)
 binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh tvterm.sh myth_mtc.lr smolt.cron mythfrontend-start"
 
@@ -37,7 +37,7 @@ build() {
         mkdir $startdir/pkg/etc/logrotate.d
         cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
 }
-md5sums=('19934a456d0e112298b8aac3279f9a16'
+md5sums=('c5f31e92bd94ffd8c5c67e544bbffd07'
          '5881bdb43d578ec3a79d1f77ea58a3db'
          'a875ee97f86e46f34a741c2bc455f894'
          '76b2637cac0452b3acdbeeb4e8a5474b'
-- 
cgit v0.12