From 9ced1c4f5ae6975c18e40d2ba6851298e01f0e07 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 9 Oct 2008 12:28:00 -0700
Subject: minor enhancements to live-installer.  Preparing for new features

---
 abs/core-testing/live-installer/PKGBUILD           | 12 ++-----
 .../live-installer/checkout_MythVantage.sh         | 37 ++++++++++++++++++++++
 .../live-installer/copy-to-mythbase.sh             | 12 -------
 .../templates/remotes/receiver_usb.id              | 37 +++++++++++++++++++---
 4 files changed, 72 insertions(+), 26 deletions(-)
 create mode 100755 abs/core-testing/live-installer/checkout_MythVantage.sh
 delete mode 100755 abs/core-testing/live-installer/copy-to-mythbase.sh

diff --git a/abs/core-testing/live-installer/PKGBUILD b/abs/core-testing/live-installer/PKGBUILD
index 5b41dcd..91affc1 100755
--- a/abs/core-testing/live-installer/PKGBUILD
+++ b/abs/core-testing/live-installer/PKGBUILD
@@ -1,24 +1,18 @@
 pkgname=live-installer
 pkgver=1.0
-pkgrel=26
+pkgrel=36
 pkgdesc="Install and configure your system"
-#depends=(bc mysql-python expect curl dnsutils)
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils)
 arch=('i686')
-#source=(mythinstall.bin install-ui.xml  bpopup-ui.xml  mythbeselect.bin install_proxy.sh install_functions.sh startx systemconfig.sh install_db_chroot.sh restore_default_settings.sh live-install.sh xconfig.sh timezip.py soundconfig.sh mythvantage-release issue autocard.py MythVantage.sh create_master.sh build_diskless.sh networkconfig.sh )
-
 
 source=(mythinstall.bin  file_time_offset.py install-ui.xml install_proxy.sh install_functions.sh systemconfig.sh install_db_chroot.sh restore_default_settings.sh xconfig.sh timezip.py soundconfig.sh LinHES-release issue MythVantage.sh create_master.sh build_diskless.sh networkconfig.sh )
 
 
 install=live.install
 build() {
-
-
     mkdir -p $startdir/pkg/etc
     mkdir -p $startdir/pkg/usr/share/mythtv/themes/default
 
-# new stuff
     MVDIR=$startdir/pkg/usr/MythVantage
     mkdir  $startdir/pkg/etc/profile.d
     install -m 0755 MythVantage.sh  $startdir/pkg/etc/profile.d/MythVantage.sh
@@ -27,7 +21,6 @@ build() {
     mkdir -p $MVDIR/etc
 
 #copy in all the installer specific stuff
-    #cp -rp ../templates $MVDIR/
     rsync -r --exclude=.svn ../templates $MVDIR/
     install -m 0755 install_proxy.sh  $MVDIR/bin/install_proxy.sh
     install -m 0755 install_functions.sh  $MVDIR/bin/install_functions.sh
@@ -45,11 +38,10 @@ build() {
     install -m 0755 file_time_offset.py $startdir/pkg/usr/bin/file_time_offset.py
     #copy in the branding stuff
     install -m 0755 LinHES-release $startdir/pkg/etc/LinHES-release
-     install -m 0755 issue $startdir/pkg/etc/issue
+    install -m 0755 issue $startdir/pkg/etc/issue
 
 # copy over the ui files
     install -m 0755 install-ui.xml $startdir/pkg/usr/share/mythtv/themes/default/
-#    install -m 0755 bpopup-ui.xml $startdir/pkg/usr/local/share/mythtv/themes/default/
 
 #copy in the binaries
     #install -g mythtv -m 4750 mythinstall.bin $MVDIR/bin/MythVantage
diff --git a/abs/core-testing/live-installer/checkout_MythVantage.sh b/abs/core-testing/live-installer/checkout_MythVantage.sh
new file mode 100755
index 0000000..8cb75e4
--- /dev/null
+++ b/abs/core-testing/live-installer/checkout_MythVantage.sh
@@ -0,0 +1,37 @@
+#!/bin/bash
+MYDIR=`pwd`
+
+function setup_links {
+rm mythinstall.bin
+rm mythbeselect.bin
+ln -s  $MYDIR/src/MythVantage-app/mythinstall/mythinstall ./mythinstall.bin
+ln -s  $MYDIR/src/MythVantage-app/mythbeselect/mythbeselect ./mythbeselect.bin
+}
+
+function dl_repo {
+mkdir src
+cd src
+if [ ! -d MythVantage-app ]
+then
+    git clone http://mythvantage.com/MythVantage-app.git/
+    cd MythVantage-app
+    git checkout --track -b  LinHES origin/LinHES
+    cd $MYDIR
+    setup_links
+    cd -
+else
+    git pull
+fi
+
+cd MythVantage-app
+git checkout LinHES
+#git checkout origin/LinHES
+
+}
+
+dl_repo
+cd $MYDIR/src/MythVantage-app/mythinstall && qmake
+make || exit 1
+cd $MYDIR/src/MythVantage-app/mythbeselect && qmake
+make ||exit 1
+
diff --git a/abs/core-testing/live-installer/copy-to-mythbase.sh b/abs/core-testing/live-installer/copy-to-mythbase.sh
deleted file mode 100755
index af89f52..0000000
--- a/abs/core-testing/live-installer/copy-to-mythbase.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/bash
-
-DATADIR="../mythtv/stable/mythtv/src/mythtv-0.21/programs"
-mkdir $DATADIR/mythinstall
-mkdir $DATADIR/mythbeselect
-rm mythinstall.bin
-rm mythbeselect.bin
-ln -n `pwd`/mythinstall/* $DATADIR/mythinstall
-ln -n `pwd`/mythbeselect/* $DATADIR/mythbeselect
-
-ln -s  $DATADIR/mythbeselect/mythbeselect ./mythbeselect.bin
-ln -s  $DATADIR/mythinstall/mythinstall ./mythinstall.bin
diff --git a/abs/core-testing/live-installer/templates/remotes/receiver_usb.id b/abs/core-testing/live-installer/templates/remotes/receiver_usb.id
index b99f91b..ec168ca 100644
--- a/abs/core-testing/live-installer/templates/remotes/receiver_usb.id
+++ b/abs/core-testing/live-installer/templates/remotes/receiver_usb.id
@@ -1,4 +1,33 @@
-0bc7:0005	snapstream_firefly	X10 Wireless Technology, Inc.
-0e9c:0000	streamzap	Streamzap, Inc. Streamzap Remote Control
-0471:0815	mceusb	Microsoft usb receiver_transmitter rc6
-	
+0bc7:0005	snapstream_firefly    "X10 Wireless Technology, Inc."
+0bc7:0008   SnapStream_Firefly    "SnapStream Firefly"
+10c4:0003   CommandIR_Tranceiver     " CommandIR Transceiver"
+0bc7:0004   ATI_Remote_Wonder    " ATI Remote Wonder"
+0e9c:0000   StreamZap    "Streamzap Remote"
+0fe9:9010   Dvico   "DVICO Remote:"
+6253:0100   Twinhan_USB  "the VisionPlus is a Twinhan clone "
+1509:9242   MCEUSB-new  "FIC eHome Infrared Transceiver 1509/9242"
+1934:0602   MCEUSB-new  "Fintek eHome Infrared Transceiver 1934/0602"
+147a:e015   MCEUSB-new  "Formosa eHome Infrared Transceiver 147a/e015"
+147a:e017   MCEUSB-new  "Formosa aim / Trust MCE Infrared Receiver147a/e017"
+147a:e018   MCEUSB-new  "Formosa Industrial Computing 147a/e018"
+107b:3009   MCEUSB-new  "Gateway eHome Infrared Transceiver 107b/3009"
+195d:7002   MCEUSB-new  "Itron ione Libra Q-11 195d/7002"
+043e:9803   MCEUSB-new  "LG eHome Infrared Transceiver 043e/9803"
+045e:00a0   MCEUSB-new  "Microsoft MCE Infrared Transceiver 045e/00a0"
+03ee:2501   MCEUSB-new  "Mitsumi 03ee/2501"
+0471:060c   MCEUSB-new  "Philips Infrared Transciever - HP branded 0471/060C"
+0471:060d   MCEUSB-new  "Philips SRM5100 0471/060d"
+0471:0815   MCEUSB-new  "Philips eHome Infrared Transciever 0471/0815"
+2304:0225   MCEUSB-new  "Pinnacle Systems, Inc. 2304/0225"
+179d:0010   MCEUSB-new  "Ricavision internal Infrared Transceiver 179d/0010"
+1308:c001   MCEUSB-new  "Shuttle eHome Infrared Transceiver 1308/c001"
+051c:c001   MCEUSB-new  "Shuttle2 eHome Infrared Transceiver 051c/c001"
+0609:031d   MCEUSB-new  "SMK/Toshiba G83C0004D410 0609/031d"
+0609:0322   MCEUSB-new  "SMK eHome Infrared Transceiver (Sony VAIO)0609/0322"
+0609:0334   MCEUSB-new  "SKM bundled with Hauppauge PVR-150 0609/0334"
+1460:9150   MCEUSB-new  "Tatung eHome Infrared Transceiver 1460/9150"
+1784:0001   MCEUSB-new  "Topseed eHome Infrared Transceiver 1784/0001"
+1784:0006   MCEUSB-new  "Topseed HP eHome Infrared Transceiver 1784/0006"
+1784:0007   MCEUSB-new  "Topseed HP eHome Infrared Transceiver 1784/0007"
+1784:0008   MCEUSB-new  "Topseed eHome Infrared Transceiver 1784/0008"
+045e:006d   MCEUSB-old  "USB Microsoft IR Transceiver Driver 045e/006d"
-- 
cgit v0.12