From 47758fbaab37b8505c3b5d02c1037e7b64a05bd8 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 31 Oct 2008 11:41:27 -0500
Subject: create initial media_dir pkg Create /myth/*

---
 abs/core-testing/media_dirs/PKGBUILD           | 68 ++++++++++++++++++++++++++
 abs/core-testing/media_dirs/media_dirs.install | 42 ++++++++++++++++
 2 files changed, 110 insertions(+)
 create mode 100644 abs/core-testing/media_dirs/PKGBUILD
 create mode 100644 abs/core-testing/media_dirs/media_dirs.install

diff --git a/abs/core-testing/media_dirs/PKGBUILD b/abs/core-testing/media_dirs/PKGBUILD
new file mode 100644
index 0000000..f3907fe
--- /dev/null
+++ b/abs/core-testing/media_dirs/PKGBUILD
@@ -0,0 +1,68 @@
+pkgname=media_dirs
+pkgver=1
+pkgrel=12
+pkgdesc="creates the dir layout for mythtv to use"
+url=""
+license=""
+depends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=media_dirs.install
+provides=()
+source=()
+md5sums=()
+arch=('i686')
+
+
+build() {
+	cd $startdir/src/
+	DIR_PREFIX=myth
+	while read dirname
+	do
+		mkdir -p "$startdir/src/$DIR_PREFIX/${dirname}"
+		touch "$startdir/src/$DIR_PREFIX/${dirname}/.media"
+	done <<EOF
+tv
+gallery
+music
+games/nes/roms
+games/nes/screens
+games/nes
+games/pc/screens
+games/pc
+games/snes/roms
+games/snes/screens
+games/snes
+games/xmame/cabs
+games/xmame/flyers
+games/xmame/hiscores
+games/xmame/history
+games/xmame/roms
+games/xmame/screens
+games/xmame
+games
+backup
+image_cache
+video/.covers
+video/archive
+video
+motion
+tmp
+archive
+stream
+phone/Voicemail
+phone/Photos
+phone
+pretty
+EOF
+
+
+	chown -R mythtv myth
+	chmod -R 777 myth
+	cp -rp myth $startdir/pkg/
+	cd $startdir/pkg
+
+}
+
diff --git a/abs/core-testing/media_dirs/media_dirs.install b/abs/core-testing/media_dirs/media_dirs.install
new file mode 100644
index 0000000..c709d79
--- /dev/null
+++ b/abs/core-testing/media_dirs/media_dirs.install
@@ -0,0 +1,42 @@
+# This is a default template for a post-install scriptlet.  You can
+# remove any functions you don't need (and this header).
+
+# arg 1:  the new package version
+pre_install() {
+	  /bin/true
+  }
+
+  # arg 1:  the new package version
+  post_install() {
+        chown -R mythtv:users /myth
+	#  ln -s /myth /data/media
+
+
+	}
+
+	# arg 1:  the new package version
+	# arg 2:  the old package version
+	pre_upgrade() {
+		  /bin/true
+	  }
+
+	  # arg 1:  the new package version
+	  # arg 2:  the old package version
+	  post_upgrade() {
+		      /bin/true
+		      post_install
+	      }
+
+	      # arg 1:  the old package version
+	      pre_remove() {
+		        /bin/true
+		}
+
+		# arg 1:  the old package version
+		post_remove() {
+			  /bin/true
+		  }
+
+		  op=$1
+		  shift
+		  $op $*
-- 
cgit v0.12