From c33585a62669e9f87553ba090b4714b22d4f220c Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 5 Sep 2012 10:25:34 -0500
Subject: Merge remote-tracking branch 'origin/testing' into testing

# By Britney Fransen (15) and others
# Via Britney Fransen
* origin/testing: (22 commits)
  LinHES-system: mythfrontend-start: revert fork of startcmd
  LinHES-system: misc_status_config.py: add SystemType check and only update db for Standalone and masterbackend
  LinHES-system: mythfrontend-start: fork start command so that mythfrontend-start will exit. closes #847
  mythtv: fixed and cleaned some menus. Closes #846
  v4l-dvb: fix conflicting kernel modules. refs #844
  mythdb-initial: add MiscStatusScript value to initial db. refs #845.
  LinHES-system: remove dup .install
  keylaunch: update .keylaunchrc to run mythtv-setup as user
  rsyslog: increase log retention to 2 weeks
  runit-scripts: enable cron logging to syslog
  premake:initial inclusion. closes #801
  libaacs-git:initial inclusion. closes #801
  aacskeys:initial inclusion. closes #801
  LinHES-system: Add scripts for misc status in MythWeb. closes #845.
  linhes-scripts: tweak myth2mkv. Update version to 0.25-004
  dvb-firmware: add xc5000c firmware. change xc5000 modprobe options. closes #844
  v4l-dvb: update to snapshot from 20120828. refs #844
  LinHES-system: update myth_status.py to work with tuners in error. closes #843
  curlftpfs: Initial Inclusion.
  linhes-scripts: minor changes to myth2mkv
  ...

Conflicts:
	abs/core/LinHES-config/LinHES-release
	abs/core/LinHES-config/PKGBUILD
	abs/core/LinHES-system/PKGBUILD
	abs/core/LinHES-system/mythfrontend-start
	abs/core/keylaunch/PKGBUILD
	abs/core/linhes-scripts/PKGBUILD
	abs/core/mythdb-initial/PKGBUILD
	abs/core/mythdb-initial/mc.sql
	abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
	abs/core/rsyslog/PKGBUILD
	abs/core/runit-scripts/PKGBUILD
---
 abs/core/LinHES-system/mythfrontend-start     | 4 ++--
 abs/core/linhes-scripts/limit-mythcommflag.sh | 4 ++--
 abs/core/linhes-scripts/pause-mythcommflag.sh | 2 +-
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/abs/core/LinHES-system/mythfrontend-start b/abs/core/LinHES-system/mythfrontend-start
index 9aac881..5cfc9b7 100755
--- a/abs/core/LinHES-system/mythfrontend-start
+++ b/abs/core/LinHES-system/mythfrontend-start
@@ -22,8 +22,8 @@ then
     mythvantage -Q "${question}"
     if [ $?  = 16 ] 
     then
-        $STARTCMD 2>&1 &        
+        $STARTCMD 2>&1
     fi
 else
-    $STARTCMD 2>&1 &
+    $STARTCMD 2>&1
 fi
diff --git a/abs/core/linhes-scripts/limit-mythcommflag.sh b/abs/core/linhes-scripts/limit-mythcommflag.sh
index 5cd81bb..63a2872 100755
--- a/abs/core/linhes-scripts/limit-mythcommflag.sh
+++ b/abs/core/linhes-scripts/limit-mythcommflag.sh
@@ -48,8 +48,8 @@ cpulimit_pid=0
 while true; do
     PROCCOMMFLAG=`pidof mythcommflag`
     if [ -n "${PROCCOMMFLAG}" ]; then
-        BACKENDCPU=`top -bn1u mythtv | grep -m 1 mythbackend | awk '{ print $9 }'`
-        FRONTENDCPU=`top -bn1u mythtv | grep -m 1 mythfrontend | awk '{ print $9 }'`
+        BACKENDCPU=`top -bn1u mythtv | grep -m 1 'mythbackend ' | awk '{ print $9 }'`
+        FRONTENDCPU=`top -bn1u mythtv | grep -m 1 'mythfrontend ' | awk '{ print $9 }'`
         if [ "$FRONTENDCPU" = "" ]; then
             FRONTENDCPU=0
         fi
diff --git a/abs/core/linhes-scripts/pause-mythcommflag.sh b/abs/core/linhes-scripts/pause-mythcommflag.sh
index 4da808b..1db6db6 100755
--- a/abs/core/linhes-scripts/pause-mythcommflag.sh
+++ b/abs/core/linhes-scripts/pause-mythcommflag.sh
@@ -29,7 +29,7 @@ while true; do
     PROCCOMMFLAG=`pidof mythcommflag`
     if [ -n "${PROCCOMMFLAG}" ]
     then
-        FRONTENDCPU=`top -bn1u mythtv | grep mythfrontend | awk '{ print $9 }'`
+        FRONTENDCPU=`top -bn1u mythtv | grep -m 1 'mythfrontend ' | awk '{ print $9 }'`
         if [ $COMMFLAGSTATE -eq 1 ]
     	then
 	        CPUTHRESHOLD1=$CPUTHRESHOLD
-- 
cgit v0.12