From 6ab0e85152731b2a0209e58016404cb605814921 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 6 Apr 2010 15:40:00 -0500
Subject: linhes-scripts: Add mythwelcome-config.py script

---
 abs/core-testing/linhes-scripts/PKGBUILD           | 32 +++++++++++++++++++++-
 .../linhes-scripts/mythwelcome-config.py           | 27 ++++++++++++++++++
 2 files changed, 58 insertions(+), 1 deletion(-)
 create mode 100755 abs/core-testing/linhes-scripts/mythwelcome-config.py

diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index a9d6f5b..6c9c085 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-scripts
 pkgver=1
-pkgrel=64
+pkgrel=65
 pkgdesc="Various scripts that help to make LinHES, LinHES."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -24,6 +24,7 @@ pause-mythcommflag.sh
 myth2x264
 770-wrapper.sh
 mythwelcome-set-alarm.sh
+mythwelcome-config.py
 pause_mythcommflag
 limit-mythcommflag.sh
 vdpau-detector
@@ -80,3 +81,32 @@ md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
          'd7c7914225ec86bf3ea46104a364f977'
          '25c1baeb97a49656456ae33f7e7a9f06'
          '2fb25aef03ffd1282414d8cca3df7056')
+md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
+         '623b6e9ba6cc4a19771005e750f337a7'
+         '9ae2cd7a0c42d57ad8b5f515d7d60196'
+         '1274bad3fb7296f00acd2d44804bad14'
+         'b4f858834ea92418208ab496ca39ad32'
+         '6b6e7d34a4bda6d608d150039adefd07'
+         '3fe554dbbf7d09e1f9925032ba888bf5'
+         '18263972b6326e140bbef0bb7dfa2da9'
+         '410795ef9039e4c6c0484e706ecfd567'
+         '0750d7c65109d12aa536f312a38410d1'
+         'ac2a4a6b4100f4d7bfb9ecd9356c8c6e'
+         'd2b475821f902c5e081e7da43a35e6ac'
+         '95c092f67036a361ef7a57436f44332e'
+         'a87e7394bfb3fcc5c2419a2f9ae9b9aa'
+         '3b776bbff68906ddc2f62b7e0dde3fe4'
+         '15f3143d2b1369da431e4268029aba40'
+         '3d0adf26280cde55a0c47188fff34826'
+         '93aaa2940e33ec9ebb305b839ac46a3e'
+         '27a8b3680f3c631a582064fd26ab8746'
+         'b527b01d119d3bc33b8fa69bdf1082bb'
+         'c537c44156d8404016cc4b405b092d45'
+         '4e66f302a77f1a857476e7f289d0c157'
+         'be324dba44ae96676973a74421944853'
+         'c9dc0dd07369622879a000247ac55074'
+         '65629302a4d2c3adf88cdf0ebc10d493'
+         'ea5492d4dab8271db20cb84416c001dc'
+         'd7c7914225ec86bf3ea46104a364f977'
+         '25c1baeb97a49656456ae33f7e7a9f06'
+         '2fb25aef03ffd1282414d8cca3df7056')
diff --git a/abs/core-testing/linhes-scripts/mythwelcome-config.py b/abs/core-testing/linhes-scripts/mythwelcome-config.py
new file mode 100755
index 0000000..c7bf10b
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/mythwelcome-config.py
@@ -0,0 +1,27 @@
+#!/usr/bin/env python
+
+# This script will configure the myth db to allow MythWelcome to wake and shutdown the system.
+
+from socket import gethostname
+from MythTV import MythDB
+mythdb = MythDB()
+localhostname = gethostname()
+
+# mythwelcome --setup
+mythdb.settings[localhostname].MythShutdownNvramCmd = u'sudo sh -c \"/usr/LH/bin/mythwelcome-set-alarm.sh $time\"'
+mythdb.settings[localhostname].MythShutdownWakeupTimeFmt = u'time_t'
+mythdb.settings[localhostname].MythShutdownNvramRestartCmd = u''
+mythdb.settings[localhostname].MythShutdownReboot = u'sudo /sbin/reboot'
+mythdb.settings[localhostname].MythShutdownPowerOff = u'sudo /sbin/poweroff'
+mythdb.settings[localhostname].MythShutdownXTermCmd = u'xterm'
+mythdb.settings[localhostname].MythWelcomeStartFECmd = u'/usr/LH/bin/mythfrontend-start'
+
+
+# mythtv-setup Shutdown/Wakeup options
+if mythdb.settings[localhostname].idleTimeoutSecs == u'0':
+    mythdb.settings[localhostname].idleTimeoutSecs = u'40'
+
+mythdb.settings.NULL.WakeupTimeFormat = u'yyyy-MM-ddThh:mm:ss'
+mythdb.settings.NULL.SetWakeuptimeCommand = u'/usr/bin/mythshutdown --setwakeup $time'
+mythdb.settings.NULL.ServerHaltCommand = u'/usr/bin/mythshutdown --shutdown'
+mythdb.settings.NULL.preSDWUCheckCommand = u'/usr/bin/mythshutdown --check'
-- 
cgit v0.12


From 4f591934854ce1ff4f1b0a49e5d609a04ba9884d Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verison.net>
Date: Tue, 6 Apr 2010 20:48:13 +0000
Subject: bluez: Updated to 4.63 and debugged associated services. closes #676

---
 abs/extra-testing/bluez/PKGBUILD      | 22 +++++++++-------------
 abs/extra-testing/bluez/bluez.install |  4 ++--
 abs/extra-testing/bluez/run.dund      |  4 ++--
 abs/extra-testing/bluez/run.hid2hci   | 15 ---------------
 abs/extra-testing/bluez/run.hidd      |  2 +-
 abs/extra-testing/bluez/run.pand      |  4 ++--
 abs/extra-testing/bluez/run.rfcomm    |  4 ++--
 abs/extra-testing/bluez/run.sdpd      | 14 --------------
 8 files changed, 18 insertions(+), 51 deletions(-)
 delete mode 100644 abs/extra-testing/bluez/run.hid2hci
 delete mode 100644 abs/extra-testing/bluez/run.sdpd

diff --git a/abs/extra-testing/bluez/PKGBUILD b/abs/extra-testing/bluez/PKGBUILD
index f39539a..83ad50d 100644
--- a/abs/extra-testing/bluez/PKGBUILD
+++ b/abs/extra-testing/bluez/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
 pkgname=bluez
-pkgver=4.62
-pkgrel=2
+pkgver=4.63
+pkgrel=1
 pkgdesc="Libraries and tools for the Bluetooth protocol stack"
 url="http://www.bluez.org/"
 arch=('i686' 'x86_64')
@@ -16,8 +16,8 @@ install='bluez.install'
 backup=(etc/bluetooth/{main,rfcomm,audio,network,input}.conf
         etc/conf.d/bluetooth)
 source=("http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
-        bluetooth.conf.d run.bluetoothd run.sdpd run.hidd run.dund run.pand
-        run.rfcomm run.hid2hci)
+        bluetooth.conf.d run.bluetoothd run.hidd run.dund run.pand
+        run.rfcomm)
 
 build() {
   cd "$srcdir/$pkgname-$pkgver"
@@ -49,19 +49,15 @@ build() {
   install -D -m644 "$srcdir/$pkgname-$pkgver/audio/audio.conf"     "$pkgdir/etc/bluetooth/" || return 1
   install -D -m644 "$srcdir/bluetooth.conf.d"                     "$pkgdir/etc/conf.d/bluetooth" || return 1
   install -D -m755 "$srcdir/run.bluetoothd"                       "$pkgdir/etc/sv/bluetoothd/run" || return 1
-  install -D -m755 "$srcdir/run.sdpd"                             "$pkgdir/etc/sv/sdpd/run" || return 1
   install -D -m755 "$srcdir/run.hidd"                             "$pkgdir/etc/sv/hidd/run" || return 1
   install -D -m755 "$srcdir/run.dund"                             "$pkgdir/etc/sv/dund/run" || return 1
   install -D -m755 "$srcdir/run.pand"                             "$pkgdir/etc/sv/pand/run" || return 1
   install -D -m755 "$srcdir/run.rfcomm"                           "$pkgdir/etc/sv/rfcomm/run" || return 1
-  install -D -m755 "$srcdir/run.hid2hci"                          "$pkgdir/etc/sv/hid2hci/run" || return 1
 }
-md5sums=('3c2187a97f5b43ae84b4bbd4b34671e0'
+md5sums=('bb388f3dbb69cd253f23fc32b0f49ffa'
          'd12be5b494525bb1ba6eac5c3983dd3e'
          '1c88fcd455920ad8ee0c7cae3fe15771'
-         'fc8cdfd1fb0044a674b79c41d5d88388'
-         '2483128d1cb93aeaf15d66058c052dc2'
-         '95bfe0ff91559d719e5feecb0388b4e1'
-         'b130f90a3cab7dd8a40c558d95c540a2'
-         'a416cdf7cc7c954f6b09d6c2a1d1c0d3'
-         'dd046ee5a232ba7cdbe8006d90b479e5')
+         'a9c1b4da8b5a3969865272bd0fb01da2'
+         '89c073f43a074844b87e28103e48623d'
+         '8ee99afea417561d01012b8047fd06d5'
+         '934a9eaa25c275d18115068101fb75e8')
diff --git a/abs/extra-testing/bluez/bluez.install b/abs/extra-testing/bluez/bluez.install
index 30bd262..f9b757b 100644
--- a/abs/extra-testing/bluez/bluez.install
+++ b/abs/extra-testing/bluez/bluez.install
@@ -2,12 +2,12 @@ post_install() {
     add_service.sh bluetoothd
     echo ">>> Only the bluetoothd daemon is started by default."
     echo ">>> You can optionally add the following as required:"
-    echo ">>> hidd dund pand sdpd rfcomm hid2hci"
+    echo ">>> hidd dund pand rfcomm"
     echo ">>> $ sudo add_service.sh <service_name>"
 }
 
 pre_remove() {
-    for d in { bluetoothd,hidd,dund,pand,sdpd,rfcomm,hid2hci } ; do
+    for d in { bluetoothd,hidd,dund,pand,rfcomm } ; do
       if [ -d /var/service/${d} ] ; then
         remove_servcie.sh $d
       fi
diff --git a/abs/extra-testing/bluez/run.dund b/abs/extra-testing/bluez/run.dund
index 2991813..c42cfa1 100644
--- a/abs/extra-testing/bluez/run.dund
+++ b/abs/extra-testing/bluez/run.dund
@@ -8,7 +8,7 @@
 
 [ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
 
-svwaitup 3 /var/service/bluetoothd || exit 1
+svwaitup -s 3 /var/service/bluetoothd || exit 1
 
     stat_runit "Starting BlueZ Bluetooth dial-up networking daemon"
-      exec /usr/bin/dund -n
+      exec /usr/bin/dund -n -s
diff --git a/abs/extra-testing/bluez/run.hid2hci b/abs/extra-testing/bluez/run.hid2hci
deleted file mode 100644
index 6ef1f47..0000000
--- a/abs/extra-testing/bluez/run.hid2hci
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-#
-# Start/stop the Bluetooth daemons
-#
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
-
-svwaitup 3 /var/service/bluetoothd || exit 1
-
-    stat_runit "Starting Bluetooth HID to HCI mode switching utility"
-      /usr/bin/hid2hci --tohci > /dev/null 2>&1 || true
-      /sbin/sv down .
diff --git a/abs/extra-testing/bluez/run.hidd b/abs/extra-testing/bluez/run.hidd
index 0887333..e4f66d3 100644
--- a/abs/extra-testing/bluez/run.hidd
+++ b/abs/extra-testing/bluez/run.hidd
@@ -8,7 +8,7 @@
 
 [ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
 
-svwaitup 3 /var/service/bluetoothd || exit 1
+svwaitup -s 3 /var/service/bluetoothd || exit 1
 
     stat_runit "Starting Bluetooth HID daemon:"
       exec /usr/bin/hidd -n --server
diff --git a/abs/extra-testing/bluez/run.pand b/abs/extra-testing/bluez/run.pand
index 937419f..ab15ef6 100644
--- a/abs/extra-testing/bluez/run.pand
+++ b/abs/extra-testing/bluez/run.pand
@@ -8,7 +8,7 @@
 
 [ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
 
-svwaitup 3 /var/service/bluetoohd || exit 1
+svwaitup -s 3 /var/service/bluetoothd || exit 1
 
     stat_runit "Starting BlueZ Bluetooth PAN daemon"
-      exec /usr/bin/pand -n
+      exec /usr/bin/pand -n -s
diff --git a/abs/extra-testing/bluez/run.rfcomm b/abs/extra-testing/bluez/run.rfcomm
index 72b3e0f..8bc619b 100644
--- a/abs/extra-testing/bluez/run.rfcomm
+++ b/abs/extra-testing/bluez/run.rfcomm
@@ -10,8 +10,8 @@
 
 RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
 
-svwaitup 3 /var/service/bluetoothd || exit 1
+svwaitup -s 3 /var/service/bluetoothd || exit 1
 
     stat_runit "Starting RFCOMM for the bluetooth subsystem"
-      /usr/bin/rfcomm  -f $RFCOMM_CONFIG bind all
+      /usr/bin/rfcomm -f $RFCOMM_CONFIG bind all
       /sbin/sv down .
diff --git a/abs/extra-testing/bluez/run.sdpd b/abs/extra-testing/bluez/run.sdpd
deleted file mode 100644
index aff51ac..0000000
--- a/abs/extra-testing/bluez/run.sdpd
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-#
-# Start/stop the Bluetooth daemons
-#
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
-
-svwaitup 3 /var/service/bluetoothd || exit 1
-
-    stat_runit "Starting bluetooth SDP daemon"
-      exec /usr/bin/sdpd -n
-- 
cgit v0.12