From 9bd1414fc727d98697851105ccb4e9061707b3af Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 28 Aug 2012 10:29:36 -0500
Subject: LinHES-system: update myth_status.py to work with tuners in error.
 closes #843

---
 abs/core/LinHES-system/PKGBUILD       |  4 ++--
 abs/core/LinHES-system/myth_status.py | 16 +++++++++-------
 2 files changed, 11 insertions(+), 9 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 6881e3c..cf2d688 100644
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=2
-pkgrel=52
+pkgrel=53
 arch=('i686')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
@@ -65,7 +65,7 @@ md5sums=('d1a5963c5a440a608031c6d750232633'
          '542e670e78d117657f93141e9689f54d'
          '48b763dba127aac6ab05c84643f83b71'
          'ba351b92e69bcaf26a9bf80417b09c3c'
-         '294e54209538018008323d164ce39fb3'
+         '4545eb39213d40b5a2bdeda5e066cdc4'
          '962a3e9eaba2d1466251b7ab0956705d'
          'd03aedeeeda0f5e9c1eb437411c88477'
          '94ce8f1d5085c0db7b267db8c2e9a3ff'
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index 4637b90..b4f4375 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -60,13 +60,15 @@ for i in a:
     type = results[0][0]
     hostname = results[0][1]
     id = i
-    c=be.getCurrentRecording(i)
-    if c.title ==  None:
-        current_recording = "Idle"
-    else:
-        current_recording = "Recording %s" %c.title
-    print "    Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
-
+    try:
+        c=be.getCurrentRecording(i)
+        if c.title ==  None:
+            current_recording = "Idle"
+        else:
+            current_recording = "Recording %s" %c.title
+        print "    Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
+    except:
+        print "    Tuner %s (%s) on %s : %s " %(id, type, hostname, "Tuner Error")
 
 print ""
 print "Upcoming Recordings (Next %s scheduled):" %(num_upcoming)
-- 
cgit v0.12