From acfc0d66dafc1e0a7536c9dbfc899eb0baafbe4f Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Thu, 2 Dec 2010 03:47:49 +0000
Subject: qscintilla: upgrade

---
 abs/extra/qscintilla/PKGBUILD                      | 79 ++++++++++++----------
 .../qscintilla/configure.py-objdir-support.diff    | 39 +++++++++++
 2 files changed, 81 insertions(+), 37 deletions(-)
 create mode 100644 abs/extra/qscintilla/configure.py-objdir-support.diff

diff --git a/abs/extra/qscintilla/PKGBUILD b/abs/extra/qscintilla/PKGBUILD
index 9b3bf94..9ba5a39 100644
--- a/abs/extra/qscintilla/PKGBUILD
+++ b/abs/extra/qscintilla/PKGBUILD
@@ -1,55 +1,60 @@
 # $Id: PKGBUILD 46926 2009-07-22 04:56:17Z pierre $
-# Maintainer: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
 # Contributor: Michal Krenek <mikos@sg1.cz>
-# Bug #8577 Modifications made by DaNiMoTh <jjdanimoth.aur@gmail.com>
+# Contributor: DaNiMoTh <jjdanimoth.aur@gmail.com>
 
-pkgname=qscintilla
-pkgver=2.4.0
-_pkgver=2.4
-pkgrel=1
+pkgbase=qscintilla
+pkgname=(qscintilla python-qscintilla)
+pkgver=2.4.5
+pkgrel=4
 license=('GPL')
-pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class."
 arch=('i686' 'x86_64')
-url="http://www.riverbankcomputing.co.uk/software/qscintilla/download"
-depends=('qt')
-provides=('qscintilla2')
-conflicts=('qscintilla2')
-replaces=('qscintilla2')
-source=(http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-$_pkgver.tar.gz)
-md5sums=('dd69520ec91f1acb97a4eb74ddde37c9')
+url="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+makedepends=('pyqt')
+source=(http://riverbankcomputing.com/static/Downloads/QScintilla2/QScintilla-gpl-${pkgver}.tar.gz
+        configure.py-objdir-support.diff)
+md5sums=('8063f8f933513959432c27c5ffecf56b'
+         '8cf9c06252e2f11ab00e62848e322fd3')
+
 
 build() {
-    cd $srcdir/QScintilla-gpl-$_pkgver/Qt4
-    sed -i "s|DESTDIR = .*|DESTDIR = $pkgdir/usr/lib|g" qscintilla.pro
-    sed -i "s|header.path = .*|header.path = $pkgdir/usr/include|g" qscintilla.pro
-    sed -i "s|trans.path = .*|trans.path = $pkgdir/usr/share/qt/translations|g" qscintilla.pro
-    sed -i "s|qsci.path = .*|qsci.path = $pkgdir/usr/share/qt/translations|g" qscintilla.pro
+    cd $srcdir/QScintilla-gpl-$pkgver
+    patch -Np1 -i "${srcdir}/configure.py-objdir-support.diff"
 
+    cd Qt4
     qmake qscintilla.pro
-    sed -i 's|$(MOVE) $(TARGET)|$(COPY) $(TARGET)|g' Makefile
-    make || return 1
-    make DESTDIR=$pkgdir install
+    make
     
     cd ../designer-Qt4
+    qmake designer.pro INCLUDEPATH+=../Qt4 QMAKE_LIBDIR+=../Qt4
+    make
 
-    # Qt4 designer qscintilla2 plugin
-    mkdir -p $pkgdir/usr/lib/qt/plugins/designer
+    cd ../Python
+    python2 configure.py -n ../Qt4/ -o ../Qt4 -c -p 4
+    make
+}
 
-    echo "INCPATH += ../Qt4" >> designer.pro
-    sed -i "s|LIBS.*|LIBS += -L../Qt4 -lqscintilla2|g" designer.pro
-    qmake designer.pro
-    make || return 1
-    cp libqscintillaplugin.so $pkgdir/usr/lib/qt/plugins/designer/ || return 1
+package_qscintilla() {
+    pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class"
+    provides=('qscintilla2')
+    conflicts=('qscintilla2')
+    replaces=('qscintilla2' 'qscintilla')
+    depends=('qt')
 
-    msg "Installing the libs to the right place"
+    cd ${srcdir}/QScintilla-gpl-${pkgver}/Qt4
+    make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
 
-    cd ../Qt4
+    cd ${srcdir}/QScintilla-gpl-${pkgver}/designer-Qt4
+    make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+}
 
-    cp libqscintilla2.so.5.1.0 $pkgdir/usr/lib/ || return 1
+package_python-qscintilla() {
+    pkgdesc="Python bindings for QScintilla2"
+    conflicts=('python-qscintilla2')
+    replaces=('python-qscintilla2')
+    depends=('qscintilla' 'pyqt')
 
-    pushd $pkgdir/usr/lib/
-        ln -s libqscintilla2.so.5.1.0 libqscintilla2.so
-        ln -s libqscintilla2.so.5.1.0 libqscintilla2.so.5
-        ln -s libqscintilla2.so.5.1.0 libqscintilla2.so.5.1
-    popd
+    cd "${srcdir}/QScintilla-gpl-${pkgver}/Python"
+    make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
 }
diff --git a/abs/extra/qscintilla/configure.py-objdir-support.diff b/abs/extra/qscintilla/configure.py-objdir-support.diff
new file mode 100644
index 0000000..b595de1
--- /dev/null
+++ b/abs/extra/qscintilla/configure.py-objdir-support.diff
@@ -0,0 +1,39 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02_configure.dpatch by Torsten Marek <shlomme@debian.org>
+##
+## DP: patch the configure script for the Python bindings to support object dir builds
+
+@DPATCH@
+Index: qscintilla2-2.4.2/Python/configure.py
+===================================================================
+--- qscintilla2-2.4.2.orig/Python/configure.py	2010-01-20 20:56:09.000000000 +0100
++++ qscintilla2-2.4.2/Python/configure.py	2010-01-27 22:54:35.603870417 +0100
+@@ -33,6 +33,7 @@
+ import glob
+ import optparse
+ 
++src_dir = os.path.dirname(os.path.abspath(__file__))
+ 
+ # Import SIP's configuration module so that we have access to the error
+ # reporting.  Then try and import the configuration modules for both PyQt3 and
+@@ -162,7 +163,7 @@
+     if os.access(sciglobal, os.F_OK):
+         # Get the QScintilla version string.
+         _, sciversstr = sipconfig.read_version(sciglobal, "QScintilla", "QSCINTILLA_VERSION", "QSCINTILLA_VERSION_STR")
+-
++        return # Debian: do not check for the installed version, we're good this way.
+         if glob.glob(os.path.join(opts.qscilibdir, "*qscintilla2*")):
+             # Because we include the Python bindings with the C++ code we can
+             # reasonably force the same version to be used and not bother about
+@@ -232,9 +233,9 @@
+     argv.append(buildfile)
+ 
+     if pyqt.pyqt_version >= 0x040000:
+-        argv.append("sip/qscimod4.sip")
++        argv.append(os.path.join(src_dir, "sip/qscimod4.sip"))
+     else:
+-        argv.append("sip/qscimod3.sip")
++        argv.append(os.path.join(src_dir, "sip/qscimod3.sip"))
+ 
+     os.system(" ".join(argv))
+ 
-- 
cgit v0.12