From e6a0ffcd96761ff1b705b283026114889cc891dc Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 21 Mar 2018 21:03:30 +0000
Subject: ffmpeg: update to 3.4.2

---
 abs/core/ffmpeg/PKGBUILD      | 41 +++++++++++++--------
 abs/core/ffmpeg/fs56089.patch | 84 +++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 110 insertions(+), 15 deletions(-)
 create mode 100644 abs/core/ffmpeg/fs56089.patch

diff --git a/abs/core/ffmpeg/PKGBUILD b/abs/core/ffmpeg/PKGBUILD
index 4e9be79..8e23c0f 100644
--- a/abs/core/ffmpeg/PKGBUILD
+++ b/abs/core/ffmpeg/PKGBUILD
@@ -6,30 +6,41 @@
 # Contributor: Paul Mattal <paul@archlinux.org>
 
 pkgname=ffmpeg
-pkgver=3.2.2
+pkgver=3.4.2
 pkgrel=2
 epoch=1
 pkgdesc='Complete solution to record, convert and stream audio and video'
-arch=('i686' 'x86_64')
+arch=('x86_64')
 url='http://ffmpeg.org/'
 license=('GPL3')
 depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
          'lame' 'libavc1394' 'libiec61883' 'libmodplug'
-         'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau'
-         'libwebp' 'libx11' 'libxcb' 'opencore-amr' 'openjpeg2' 'opus'
-         'schroedinger' 'sdl2' 'speex' 'v4l-utils' 'xz' 'zlib'
-         'libass.so' 'libbluray.so' 'libfreetype.so' 'libnetcdf.so'
-         'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
-         'libx264.so' 'libx265.so' 'libxvidcore.so')
-makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+         'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
+         'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
+         'speex' 'v4l-utils' 'xz' 'zlib'
+         'libomxil-bellagio'
+         'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
+         'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
+         'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so')
+makedepends=('ladspa' 'libvdpau' 'yasm')
 optdepends=('ladspa: LADSPA filters')
 provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
           'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
           'libswscale.so')
-source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc})
+source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
+        'fs56089.patch')
 validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
-sha256sums=('3f01bd1fe1a17a277f8c84869e5d9192b4b978cb660872aa2b54c3cc8a2fedfc'
-            'SKIP')
+sha256sums=('2b92e9578ef8b3e49eeab229e69305f5f4cbc1fdaa22e927fc7fca18acccd740'
+            'SKIP'
+            '0bfcd12d1992903f21c146ae56d9ad89b52818cfb2303197ee905347c25a5427')
+
+prepare() {
+  cd ffmpeg-${pkgver}
+
+  # https://bugs.archlinux.org/task/56089
+  # Backport of http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=a606f27f4c610708fa96e35eed7b7537d3d8f712
+  patch -Np1 -i ../fs56089.patch
+}
 
 build() {
   cd ffmpeg-${pkgver}
@@ -59,7 +70,6 @@ build() {
     --enable-libopenjpeg \
     --enable-libopus \
     --disable-libpulse \
-    --enable-libschroedinger \
     --enable-libsoxr \
     --enable-libspeex \
     --enable-libssh \
@@ -71,11 +81,12 @@ build() {
     --enable-libwebp \
     --enable-libx264 \
     --enable-libx265 \
+    --enable-libxcb \
+    --enable-libxml2 \
     --enable-libxvid \
-    --enable-netcdf \
     --enable-shared \
     --enable-version3 \
-    --enable-x11grab
+    --enable-omx
 
   make
   make tools/qt-faststart
diff --git a/abs/core/ffmpeg/fs56089.patch b/abs/core/ffmpeg/fs56089.patch
new file mode 100644
index 0000000..6aca38f
--- /dev/null
+++ b/abs/core/ffmpeg/fs56089.patch
@@ -0,0 +1,84 @@
+diff -rupN ffmpeg-3.4.orig/libavformat/aviobuf.c ffmpeg-3.4/libavformat/aviobuf.c
+--- ffmpeg-3.4.orig/libavformat/aviobuf.c	2017-11-02 14:57:16.078834563 +0100
++++ ffmpeg-3.4/libavformat/aviobuf.c	2017-11-02 15:02:52.549816990 +0100
+@@ -531,6 +531,24 @@ void avio_write_marker(AVIOContext *s, i
+     s->last_time = time;
+ }
+ 
++static int read_packet_wrapper(AVIOContext *s, uint8_t *buf, int size)
++{
++    int ret;
++
++    if (!s->read_packet)
++        return AVERROR_EOF;
++    ret = s->read_packet(s->opaque, buf, size);
++#if FF_API_OLD_AVIO_EOF_0
++    if (!ret && !s->max_packet_size) {
++        av_log(NULL, AV_LOG_WARNING, "Invalid return value 0 for stream protocol\n");
++        ret = AVERROR_EOF;
++    }
++#else
++    av_assert2(ret || s->max_packet_size);
++#endif
++    return ret;
++}
++
+ /* Input stream */
+ 
+ static void fill_buffer(AVIOContext *s)
+@@ -569,10 +587,7 @@ static void fill_buffer(AVIOContext *s)
+         len = s->orig_buffer_size;
+     }
+ 
+-    if (s->read_packet)
+-        len = s->read_packet(s->opaque, dst, len);
+-    else
+-        len = 0;
++    len = read_packet_wrapper(s, dst, len);
+     if (len <= 0) {
+         /* do not modify buffer if EOF reached so that a seek back can
+            be done without rereading data */
+@@ -644,8 +659,7 @@ int avio_read(AVIOContext *s, unsigned c
+         if (len == 0 || s->write_flag) {
+             if((s->direct || size > s->buffer_size) && !s->update_checksum) {
+                 // bypass the buffer and read data directly into buf
+-                if(s->read_packet)
+-                    len = s->read_packet(s->opaque, buf, size);
++                len = read_packet_wrapper(s, buf, size);
+ 
+                 if (len <= 0) {
+                     /* do not modify buffer if EOF reached so that a seek back can
+@@ -711,7 +725,7 @@ int avio_read_partial(AVIOContext *s, un
+         return -1;
+ 
+     if (s->read_packet && s->write_flag) {
+-        len = s->read_packet(s->opaque, buf, size);
++        len = read_packet_wrapper(s, buf, size);
+         if (len > 0)
+             s->pos += len;
+         return len;
+diff -rupN ffmpeg-3.4.orig/libavformat/avio.h ffmpeg-3.4/libavformat/avio.h
+--- ffmpeg-3.4.orig/libavformat/avio.h	2017-11-02 14:57:16.078834563 +0100
++++ ffmpeg-3.4/libavformat/avio.h	2017-11-02 14:59:15.602300896 +0100
+@@ -452,6 +452,8 @@ void avio_free_directory_entry(AVIODirEn
+  * @param write_flag Set to 1 if the buffer should be writable, 0 otherwise.
+  * @param opaque An opaque pointer to user-specific data.
+  * @param read_packet  A function for refilling the buffer, may be NULL.
++ *                     For stream protocols, must never return 0 but rather
++ *                     a proper AVERROR code.
+  * @param write_packet A function for writing the buffer contents, may be NULL.
+  *        The function may not change the input buffers content.
+  * @param seek A function for seeking to specified byte position, may be NULL.
+diff -rupN ffmpeg-3.4.orig/libavformat/version.h ffmpeg-3.4/libavformat/version.h
+--- ffmpeg-3.4.orig/libavformat/version.h	2017-11-02 14:57:16.082167807 +0100
++++ ffmpeg-3.4/libavformat/version.h	2017-11-02 15:04:01.704627612 +0100
+@@ -97,6 +97,9 @@
+ #ifndef FF_API_OLD_ROTATE_API
+ #define FF_API_OLD_ROTATE_API           (LIBAVFORMAT_VERSION_MAJOR < 58)
+ #endif
++#ifndef FF_API_OLD_AVIO_EOF_0
++#define FF_API_OLD_AVIO_EOF_0           (LIBAVFORMAT_VERSION_MAJOR < 58)
++#endif
+ 
+ 
+ #ifndef FF_API_R_FRAME_RATE
-- 
cgit v0.12