From bcb80f9deba36cf51079f1c6fd7992278f91ff7e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 26 Nov 2014 21:13:24 +0000
Subject: mythtv, mythplugins, mythinstall: recompile

---
 .../MythVantage-app/mythinstall/installsettings.cpp          | 12 ++++++++++++
 .../MythVantage-app/mythinstall/installsettings.h            |  1 +
 abs/core/mythinstall/PKGBUILD                                |  2 +-
 abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD             |  2 +-
 abs/core/mythtv/stable-0.27/mythtv/PKGBUILD                  |  2 +-
 .../mythtv/stable-0.27/mythtv/menu-xml/library.xml.patch     | 11 +++++------
 6 files changed, 21 insertions(+), 9 deletions(-)

diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 3592f09..ca809d4 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -1157,6 +1157,15 @@ static HostCheckBox *HostXBMC()
     return gc;
 };
 
+static HostCheckBox *HostPLEXHT()
+{
+    HostCheckBox *gc = new HostCheckBox("HostPLEXHT");
+    gc->setLabel(QObject::tr("Plex Home Theater"));
+    gc->setValue(false);
+    gc->setHelpText(QObject::tr("Plex organizes all of your personal media, wherever you keep it, so you can enjoy it on any device."));
+    return gc;
+};
+
 static HostComboBox *Hostfoldingusername()
 {
     // If there is an old R5.5 style folding directory /myth/folding@home, attempt
@@ -3993,6 +4002,7 @@ void writesettings ()
     hostparm.ThisHostHuluDesktop = gCoreContext->GetSetting("HostHuluDesktop");
     hostparm.ThisHostwebonlinhes = gCoreContext->GetSetting("HostWebonlinhes");
     hostparm.ThisHostXBMC = gCoreContext->GetSetting("HostXBMC");
+    hostparm.ThisHostPLEXHT = gCoreContext->GetSetting("HostPLEXHT");
 
     hostparm.ThisHostfoldingathome = gCoreContext->GetSetting("Hostfoldingathome");
     hostparm.ThisHostfoldingusername = gCoreContext->GetSetting("Hostfoldingusername");
@@ -4326,6 +4336,7 @@ void writesettings ()
     myfile << "webonlinhes=\"" + hostparm.ThisHostwebonlinhes + "\"\n";
     myfile << "huludesktop=\"" + hostparm.ThisHostHuluDesktop + "\"\n";
     myfile << "xbmc=\"" + hostparm.ThisHostXBMC + "\"\n";
+    myfile << "plex=\"" + hostparm.ThisHostPLEXHT + "\"\n";
     myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome  + "\"\n";
     myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername  + "\"\n";
     myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize  + "\"\n";
@@ -4748,6 +4759,7 @@ MythInstallSettings::MythInstallSettings()
                 //GridShowPlugin4->addChild(HostMiro());
                 //GridShowPlugin4->addChild(HostXine());
                 GridShowPlugin4->addChild(HostHuluDesktop());
+                GridShowPlugin4->addChild(HostPLEXHT());
                 GridShowPlugin4->addChild(Hostwebmin());
                 GridShowPlugin4->addChild(Hostwebonlinhes());
                 GridShowPlugin4->addChild(HostXBMC());
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
index 6ce0eff..cd2983b 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
@@ -524,6 +524,7 @@ struct HostParms
 //    QString ThisHostMiro;
     QString ThisHostwebonlinhes;
     QString ThisHostXBMC;
+    QString ThisHostPLEXHT;
     QString ThisHostHuluDesktop;
 
     QString ThisHostpluginmythgameMame;
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index c37757d..fd0ef2c 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Jams
 pkgname=mythinstall
 pkgver=8.2
-pkgrel=7
+pkgrel=8
 pkgdesc="LinHES installer/systemconfig GUI."
 arch=('i686' 'x86_64')
 depends=('mythtv>=0.27')
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
index 656d7c8..ac8f77b 100644
--- a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('mytharchive'
          'mythweather'
          'mythzoneminder')
 pkgver=0.27.4
-pkgrel=3
+pkgrel=4
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
diff --git a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
index ce809c0..500f68f 100644
--- a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.27.4
-pkgrel=3
+pkgrel=4
 commit_hash=`cat ../git_src/git_hash`
 pkgdesc="A Homebrew PVR project $commit_hash"
 arch=('i686' 'x86_64')
diff --git a/abs/core/mythtv/stable-0.27/mythtv/menu-xml/library.xml.patch b/abs/core/mythtv/stable-0.27/mythtv/menu-xml/library.xml.patch
index 8f80928..0c0177a 100644
--- a/abs/core/mythtv/stable-0.27/mythtv/menu-xml/library.xml.patch
+++ b/abs/core/mythtv/stable-0.27/mythtv/menu-xml/library.xml.patch
@@ -1,6 +1,6 @@
---- themes/defaultmenu/library.xml.orig	2012-06-10 08:02:54.000000000 +0000
-+++ themes/defaultmenu/library.xml	2012-06-10 08:03:38.000000000 +0000
-@@ -40,6 +40,13 @@
+--- themes/defaultmenu/library.xml.orig	2014-11-26 20:21:35.092552944 +0000
++++ themes/defaultmenu/library.xml	2014-11-26 20:22:43.103983263 +0000
+@@ -56,6 +56,13 @@
      </button>
  
      <button>
@@ -14,13 +14,12 @@
          <type>IMAGES</type>
          <text>Image Gallery</text>
          <description>Look at Pictures</description>
-@@ -51,8 +58,7 @@
+@@ -67,7 +74,7 @@
          <type>GAME</type>
          <text>Play Games</text>
          <description>Play video games</description>
 -        <action>PLUGIN mythgame</action>
--        <depends>mythgame</depends>
 +        <action>MENU game.xml</action>
+         <depends>mythgame</depends>
      </button>
  
- </mythmenu>
-- 
cgit v0.12