From 3ca405f85ad235d170859610b72fffba13b7f142 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 6 Aug 2011 00:52:22 -0500
Subject: htop: Bump to latest.

---
 abs/extra/htop/ChangeLog           | 21 +++++++++++++++------
 abs/extra/htop/PKGBUILD            | 35 ++++++++++++++++++++++++-----------
 abs/extra/htop/htop-treeview.patch | 12 ------------
 3 files changed, 39 insertions(+), 29 deletions(-)
 delete mode 100644 abs/extra/htop/htop-treeview.patch

diff --git a/abs/extra/htop/ChangeLog b/abs/extra/htop/ChangeLog
index 7d77d0b..ea57762 100644
--- a/abs/extra/htop/ChangeLog
+++ b/abs/extra/htop/ChangeLog
@@ -1,8 +1,17 @@
+2011-05-17  Angel Velasquez <angvp@archlinux.org>
+	* Added patch to fix --sort-key (closes FS#23224)
+
+2009-09-21  Eric Belanger  <eric@archlinux.org>
+
+	* htop 0.8.3-1
+	* Upstream update
+	* Built with vserver and openvz support (close FS#12755)
+
 2008-12-09  Alexander Fehr  <pizzapunk gmail com>
 
-  * htop-0.8.1-1:
-  New upstream release.
-  New maintainer.
-  Added patch to fix FS#12235.
-  Enabled Unicode support.
-  Added ChangeLog.
+	* htop-0.8.1-1:
+	* New upstream release
+	* New maintainer
+	* Added patch to fix FS#12235
+	* Enabled Unicode support
+	* Added ChangeLog
diff --git a/abs/extra/htop/PKGBUILD b/abs/extra/htop/PKGBUILD
index 95b9660..05c8826 100644
--- a/abs/extra/htop/PKGBUILD
+++ b/abs/extra/htop/PKGBUILD
@@ -1,22 +1,35 @@
-# $Id: PKGBUILD 21081 2008-12-09 17:41:11Z alexanderf $
-# Maintainer: Alexander Fehr <pizzapunk gmail com>
+# $Id$
+# Maintainer: Angel Velasquez <angvp@archlinux.org> 
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
 
 pkgname=htop
-pkgver=0.8.3
-pkgrel=1
+pkgver=0.9
+pkgrel=2
 pkgdesc="Interactive process viewer"
 arch=('i686' 'x86_64')
 url="http://htop.sourceforge.net/"
 license=('GPL')
 depends=('ncurses')
+makedepends=('python2')
 options=('!emptydirs')
-source=(http://downloads.sourceforge.net/htop/htop-$pkgver.tar.gz)
+changelog=ChangeLog
+source=(http://downloads.sourceforge.net/htop/${pkgname}-${pkgver}.tar.gz
+        htop.c.patch)
+md5sums=('7c5507f35f363f3f40183a2ba3c561f8'
+         '750e8ad8476c5d9738da2a2bc7a7c2b6')
 
 build() {
-  cd "$srcdir/htop-$pkgver"
-  sed -i 's|ncursesw/curses.h|curses.h|' RichString.h RichString.c || return 1
-  ./configure --prefix=/usr --enable-unicode || return 1
-  make || return 1
-  make DESTDIR="$pkgdir" install || return 1
+	cd ${srcdir}/${pkgname}-${pkgver}
+	sed -i 's|ncursesw/curses.h|curses.h|' RichString.h RichString.c configure 
+	sed -i 's|python|python2|' scripts/MakeHeader.py
+    patch -Np0 -i $srcdir/htop.c.patch
+	./configure --prefix=/usr --enable-unicode --enable-openvz \
+	    --enable-vserver 
+	make 
+}
+
+package() {
+	cd ${srcdir}/${pkgname}-${pkgver}
+	make DESTDIR=${pkgdir} install 
 }
-md5sums=('5c9f093f9eaddf6e77aa6d54c2116d0c')
diff --git a/abs/extra/htop/htop-treeview.patch b/abs/extra/htop/htop-treeview.patch
deleted file mode 100644
index bcf6334..0000000
--- a/abs/extra/htop/htop-treeview.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur htop-0.8.1.orig/ProcessList.c htop-0.8.1/ProcessList.c
---- htop-0.8.1.orig/ProcessList.c	2008-09-23 08:23:14.000000000 +0200
-+++ htop-0.8.1/ProcessList.c	2008-12-09 15:14:56.000000000 +0100
-@@ -331,7 +331,7 @@
- 
-    for (int i = Vector_size(this->processes) - 1; i >= 0; i--) {
-       Process* process = (Process*) (Vector_get(this->processes, i));
--      if (process->tgid == pid || (process->tgid == process->pid && process->ppid == pid)) {
-+      if (process->tgid == pid || process->ppid == pid) {
-          Process* process = (Process*) (Vector_take(this->processes, i));
-          Vector_add(children, process);
-       }
-- 
cgit v0.12