From bdfa23d3d3dfa3f946c90320c097cd877a6be9b0 Mon Sep 17 00:00:00 2001
From: Greg Frost <gregfrost1@bigpond.com>
Date: Sun, 26 Jul 2009 16:21:54 +0930
Subject: LinHES-timezone: set initial window position so it is full screen

---
 abs/core-testing/LinHES-timezone/PKGBUILD          |  4 ++--
 abs/core-testing/LinHES-timezone/linhes_timezone.c | 14 +++++++++++++-
 2 files changed, 15 insertions(+), 3 deletions(-)

diff --git a/abs/core-testing/LinHES-timezone/PKGBUILD b/abs/core-testing/LinHES-timezone/PKGBUILD
index 0b0d2ad..eedc364 100644
--- a/abs/core-testing/LinHES-timezone/PKGBUILD
+++ b/abs/core-testing/LinHES-timezone/PKGBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Greg Frost <gregfrost1@bigpond.com>
 pkgname=LinHES-timezone
 pkgver=1
-pkgrel=6
+pkgrel=7
 pkgdesc="GUI timezone selector used by LinHES-config."
 arch=i686
 depends=()
@@ -27,4 +27,4 @@ md5sums=('53976e51e938c555f84b43c933339051'
          '0d9e51af5f650dd329edce4531c42a58'
          'c01e2335603d8395004e32bae9060fde'
          'b20bd68272644f607fbfe7d50e7be42a'
-         '448ffca8f38b2dcd989e599ff2057399')
+         '8629268a4f2ca8391e4d1087a9734088')
diff --git a/abs/core-testing/LinHES-timezone/linhes_timezone.c b/abs/core-testing/LinHES-timezone/linhes_timezone.c
index ff75549..d295091 100644
--- a/abs/core-testing/LinHES-timezone/linhes_timezone.c
+++ b/abs/core-testing/LinHES-timezone/linhes_timezone.c
@@ -750,6 +750,17 @@ void remove_titlebar_and_borders ()
     (char *) &mwm_hints, 5);
 }
 
+void set_window_position (int x, int y)
+{
+  XSizeHints hints;
+
+  hints.flags = USPosition | PPosition;
+  hints.x = x;
+  hints.y = y;
+
+  XSetWMNormalHints(display, window, &hints);
+}
+
 int main (int argc, char *argv[])
 {
   XEvent xevent;
@@ -851,12 +862,13 @@ int main (int argc, char *argv[])
     radius = height;
 
   radius = 0.96 * radius / 2;
-  
+
   window = XCreateSimpleWindow (display,
              DefaultRootWindow(display), x, y, width, height, 0,
              land[0].pixel, ocean.pixel);
 
   remove_titlebar_and_borders ();
+  set_window_position (x, y);
 
   if (!window) 
   {
-- 
cgit v0.12