From 1863883b8ebddba0e45a88ed94d6e555cca31e91 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 7 Sep 2011 20:54:06 -0500
Subject: python-imaging: compile against python2.6 and libjpeg 8

---
 abs/core/python_modules/python-imaging/PKGBUILD    | 7 +++----
 abs/core/python_modules/python-imaging/__changelog | 3 +--
 2 files changed, 4 insertions(+), 6 deletions(-)

diff --git a/abs/core/python_modules/python-imaging/PKGBUILD b/abs/core/python_modules/python-imaging/PKGBUILD
index f0b5f3a..d644a4c 100644
--- a/abs/core/python_modules/python-imaging/PKGBUILD
+++ b/abs/core/python_modules/python-imaging/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=python-imaging
 pkgver=1.1.7
-pkgrel=5
+pkgrel=6
 pkgdesc="PIL. Provides image processing capabilities for python"
 arch=('i686' 'x86_64')
 url="http://www.pythonware.com/products/pil/index.htm"
@@ -20,15 +20,14 @@ md5sums=('fc14a54e1ce02a0225be8854bfba478e')
 
 build() {
   cd $srcdir/Imaging-$pkgver
-  sed -i "s#JPEG_ROOT\ =\ None#JPEG_ROOT\ =\ \"/opt/libjpeg6/lib\",\ \"/opt/libjpeg6/include\"#" setup.py
   python2 setup.py build_ext
 }
 
 package() {
   cd $srcdir/Imaging-$pkgver
   python2 setup.py install --root=$pkgdir
-  install -dm755 $pkgdir/usr/include/python2.7/
-  install -m644 -t $pkgdir/usr/include/python2.7/ libImaging/*.h 
+  install -dm755 $pkgdir/usr/include/python2.6/
+  install -m644 -t $pkgdir/usr/include/python2.6/ libImaging/*.h 
 
   # do not have files ending in .py in /usr/bin
   for f in pildriver pilprint pilconvert pilfile pilfont; do
diff --git a/abs/core/python_modules/python-imaging/__changelog b/abs/core/python_modules/python-imaging/__changelog
index 91214ed..de150f5 100644
--- a/abs/core/python_modules/python-imaging/__changelog
+++ b/abs/core/python_modules/python-imaging/__changelog
@@ -1,2 +1 @@
-__change so that it builds against libjpeg6 and not libjpeg7
-  sed -i "s#JPEG_ROOT\ =\ None#JPEG_ROOT\ =\ \"/opt/libjpeg6\"#" setup.py
+__change so that it builds against python2.6 instead of python2.7
-- 
cgit v0.12