From a98afe8102e3b69e3ccbf41b8f8d2c68999352d2 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 21 Apr 2012 21:30:46 -0500
Subject: LinHES-config: remove mythvideo/mythsmolt For installs, delay
 non-master database loads until after machine is configured.

---
 abs/core/LinHES-config/PKGBUILD       | 4 ++--
 abs/core/LinHES-config/mv_install.py  | 6 ++++--
 abs/core/LinHES-config/mv_software.py | 4 ++--
 3 files changed, 8 insertions(+), 6 deletions(-)

diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 602dc0b..903fbfe 100644
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -103,7 +103,7 @@ build() {
     install -m 0755 issue $startdir/pkg/etc/issue
 
 }
-md5sums=('ffd40d21a9a868364045368053cb69c9'
+md5sums=('18af4fe481e1fc2ae02050026eb5cd27'
          '16b98fcb3753ef6cfc35075c326d30e4'
          'e36da536dd651ef182e7642337889e77'
          '985891a43f7c4c983eb2a362162f1a0f'
@@ -133,7 +133,7 @@ md5sums=('ffd40d21a9a868364045368053cb69c9'
          '62b4ce94277c32f525db5c1480670acd'
          'ec6a9961e4d1b53ec1240c5979efff11'
          'fe5e31b833cc6707209e9d656b6eb53c'
-         'f0988a801216b44c96bf17e24a23e3a9'
+         '76140f4160ebb1790a24f9b51b542a7b'
          '23d0e12b7ca1cc6ea6b993c1d7ff20b9'
          'bce31dc826812d1b32003f77f9945ca9'
          '59dd4d49fd92a35f4111aa9b77fa21b6'
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index a7389ca..2e60ab7 100755
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -1138,8 +1138,8 @@ def full_install(hostoptions):
         cmd = "  chroot %s DISPLAY=127.0.0.1:0 %s/bin/MythVantage -t restore, default 1" %(data_config.MOUNTPOINT, MVROOT)
         runcmd(cmd)
 #       Need to check for to touch  /tmp/.dbsysfailed
-        cmd = "  chroot %s %s/bin/myth_settings_wrapper.sh -c restore  -t syssettings " %(data_config.MOUNTPOINT, MVROOT)
-        runcmd(cmd)
+        #cmd = "  chroot %s %s/bin/myth_settings_wrapper.sh -c restore  -t syssettings " %(data_config.MOUNTPOINT, MVROOT)
+        #runcmd(cmd)
         if ( 'x' == '1' ):
             logging.debug("touching /tmp/.dbsysfailed")
         else:
@@ -1148,6 +1148,8 @@ def full_install(hostoptions):
             rc = runcmd(cmd)[0]
             if rc != 0 :
                 error_out("Running systemconfig")
+            cmd = "chroot %s %s/bin/myth_settings_wrapper.sh -c restore  -t syssettings " %(data_config.MOUNTPOINT, MVROOT)
+            runcmd(cmd)
             cmd = "chroot %s %s/bin/myth_settings_wrapper.sh -c ACCESSCONTROL " %(data_config.MOUNTPOINT, MVROOT)
             runcmd(cmd)
         umount_bind_chroot()
diff --git a/abs/core/LinHES-config/mv_software.py b/abs/core/LinHES-config/mv_software.py
index b278e28..263ace3 100755
--- a/abs/core/LinHES-config/mv_software.py
+++ b/abs/core/LinHES-config/mv_software.py
@@ -21,14 +21,14 @@ def setup_software(systemconfig, data_config):
       default_disabled = ("mytharchive", "mythbrowser", "mythnews",
                           "mythgame",  "mythweather", "mythzoneminder","mythnetvision" )
 
-      default_installed=("mythgallery", "mythmusic", "mythsmolt", "mythvideo")
+      default_installed=("mythgallery", "mythmusic")
       other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome", "mythappletrailers", "mythstream", "mupen64")
     else:
       default_disabled = ("mytharchive", "mythbrowser", "mythnews",
                           "mythgame", "mythweather",
                           "mythappletrailers", "mythstream",  "mythzoneminder","mythnetvision" )
 
-      default_installed=("mythgallery", "mythmovies", "mythmusic", "mythsmolt", "mythvideo")
+      default_installed=("mythgallery", "mythmovies", "mythmusic")
       other_pkg=("miro", "mednafen", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome","mupen64")
 
     for pkg in default_disabled:
-- 
cgit v0.12