From 7c4c17e34fbf3da4024656a99643b4062719513b Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 16 Feb 2009 17:06:23 -0600
Subject: Add an  include patch for compat.h

---
 abs/core-testing/mythtv/stable/mythsmolt/PKGBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/mythtv/stable/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/stable/mythsmolt/PKGBUILD
index dfdd01b..25c91cf 100644
--- a/abs/core-testing/mythtv/stable/mythsmolt/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythsmolt/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythsmolt
 pkgver=0.21
-pkgrel=6
+pkgrel=8
 pkgdesc="mythsmolt, a hardware profileing tool"
 arch=('i686' 'x86_64')
 url="http://www.mythvantage.com"
@@ -16,6 +16,7 @@ build() {
    
    # use QT3 qmake
    export PATH=$QTDIR/bin:$PATH
+   echo "INCLUDEPATH += /usr/include/mythtv" >> mythsmolt.pro.usr
 
    qmake mythsmolt.pro.usr
    make qmake || return 1
-- 
cgit v0.12


From 52e7c7e6d99e3d515936d9c51f9fbe65179e5153 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 16 Feb 2009 22:54:11 -0600
Subject: Quick replacment shutdown command for runit. it accepts the -t -r -h
 commands like init shutdown and errors out for all others.

---
 abs/core-testing/runit/PKGBUILD        |  5 ++--
 abs/core-testing/runit/runit.install   | 12 +++++++--
 abs/core-testing/runit/shutdown.script | 46 ++++++++++++++++++++++++++++++++++
 3 files changed, 59 insertions(+), 4 deletions(-)
 create mode 100755 abs/core-testing/runit/shutdown.script

diff --git a/abs/core-testing/runit/PKGBUILD b/abs/core-testing/runit/PKGBUILD
index c0863bb..1303167 100755
--- a/abs/core-testing/runit/PKGBUILD
+++ b/abs/core-testing/runit/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=runit
 pkgver=1.8.0
-pkgrel=57
+pkgrel=61
 pkgdesc="A replacement for sysvinit, and other init schemes, with service supervision"
 url="http://smarden.org/runit/"
 license="BSD"
@@ -10,7 +10,7 @@ conflicts=()
 replaces=()
 backup=()
 install=runit.install
-source=(http://smarden.org/runit/$pkgname-$pkgver.tar.gz add_service.sh remove_service.sh halt.script reboot.script poweroff.script)
+source=(http://smarden.org/runit/$pkgname-$pkgver.tar.gz add_service.sh remove_service.sh halt.script reboot.script poweroff.script shutdown.script)
 arch=('i686')
 
 build() {
@@ -35,6 +35,7 @@ build() {
   install -m0755 $startdir/src/reboot.script $startdir/pkg/sbin
   install -m0755 $startdir/src/halt.script  $startdir/pkg/sbin
   install -m0755 $startdir/src/poweroff.script  $startdir/pkg/sbin
+  install -m0755 $startdir/src/shutdown.script  $startdir/pkg/sbin
 
   for i in `cat ../package/commands`; do
     install -m0755 $i $startdir/pkg/sbin/
diff --git a/abs/core-testing/runit/runit.install b/abs/core-testing/runit/runit.install
index 977841b..b6fcb07 100755
--- a/abs/core-testing/runit/runit.install
+++ b/abs/core-testing/runit/runit.install
@@ -4,9 +4,10 @@ pre_install () {
 if [ ! -f /sbin/halt-init ]
 then
    mv /sbin/halt  /sbin/halt-init
+   mv /sbin/shutdown  /sbin/shutdown-init
+fi
    rm -f /sbin/reboot
    rm -f /sbin/poweroff
-fi
 
 }
 
@@ -14,9 +15,14 @@ pre_upgrade () {
 if [ ! -f /sbin/halt-init ]
 then
    mv /sbin/halt  /sbin/halt-init
+fi
+
+if [ ! -f /sbin/shutdown-init ]
+then
+   mv /sbin/shutdown  /sbin/shutdown-init
+fi
    rm -f /sbin/reboot
    rm -f /sbin/poweroff
-fi
 
 }
 
@@ -28,6 +34,7 @@ post_install () {
   ln -s /sbin/poweroff.script /sbin/poweroff
   ln -s /sbin/halt-init /sbin/reboot.init
   ln -s /sbin/halt-init /sbin/poweroff.init
+  ln -s /sbin/shutdown.script /sbin/shutdown
 
 
 }
@@ -41,6 +48,7 @@ post_upgrade(){
   ln -s /sbin/poweroff.script /sbin/poweroff
   ln -s /sbin/halt-init /sbin/reboot.init
   ln -s /sbin/halt-init /sbin/poweroff.init
+  ln -s /sbin/shutdown.script /sbin/shutdown
 
 }
 
diff --git a/abs/core-testing/runit/shutdown.script b/abs/core-testing/runit/shutdown.script
new file mode 100755
index 0000000..3bcc5d3
--- /dev/null
+++ b/abs/core-testing/runit/shutdown.script
@@ -0,0 +1,46 @@
+#!/bin/bash
+. /etc/profile
+INIT=`ps -p 1 -o comm=`
+if [ x$INIT = xrunit ]
+then
+	reboot=""
+	halt=""
+	delay=""
+ 	while getopts rht:  name
+	do
+        	case $name in
+                  r)    reboot=1 ;;
+                  h)    halt=1 ;;
+                  t) delay="$OPTARG"
+                        if [ x$delay = "xnow" ]
+                        then
+                                delay=0
+                        fi
+                        ;;
+                *)
+                      exit 2;;
+                        esac
+	done
+	if [ x$delay = x ]
+	then
+	        echo "-t is mandatory"
+        	exit 4
+	fi
+
+	if [ x$reboot = x1 ]
+	then
+         wall "System will reboot in $delay seconds"
+                sleep $delay
+               /sbin/runit-init 6
+	fi
+
+	if [ x$halt = x1 ]
+	then
+                wall "System will poweroff  in $delay seconds"
+                sleep $delay
+               /sbin/runit-init 0
+	fi
+
+else
+     	/sbin/shutdown-init $@
+fi
-- 
cgit v0.12


From fb4e8e768d27649266771a63c1536ee9eeb0e821 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Mon, 16 Feb 2009 22:41:01 -0800
Subject: Gotta keep them Athlon's cool.

---
 abs/extra-testing/community/athcool/PKGBUILD | 19 +++++++++++++++
 abs/extra-testing/community/athcool/athcool  | 35 ++++++++++++++++++++++++++++
 2 files changed, 54 insertions(+)
 create mode 100644 abs/extra-testing/community/athcool/PKGBUILD
 create mode 100644 abs/extra-testing/community/athcool/athcool

diff --git a/abs/extra-testing/community/athcool/PKGBUILD b/abs/extra-testing/community/athcool/PKGBUILD
new file mode 100644
index 0000000..2f38191
--- /dev/null
+++ b/abs/extra-testing/community/athcool/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=athcool
+pkgver=0.3.12
+pkgrel=1
+pkgdesc="Small utility allowing to enable powersaving mode on AMD Duron/Athlon/Athlon XP processors."
+url="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html"
+depends=(pciutils)
+license="GPL"
+arch=(i686)
+source=(http://members.jcom.home.ne.jp/jacobi/linux/files/$pkgname-$pkgver.tar.gz
+	athcool)
+md5sums=('f2e0f4fbd04f5e1f09aa60a3ecb24645'
+	 'bbf32484cec6431568ccf51c2516f9e7')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  make || return 1
+  make DESTDIR=$startdir/pkg install
+  /bin/install -D -m0755 ../athcool $startdir/pkg/etc/rc.d/athcool
+}
diff --git a/abs/extra-testing/community/athcool/athcool b/abs/extra-testing/community/athcool/athcool
new file mode 100644
index 0000000..f49bd40
--- /dev/null
+++ b/abs/extra-testing/community/athcool/athcool
@@ -0,0 +1,35 @@
+#!/bin/bash
+ 
+. /etc/rc.conf
+. /etc/rc.d/functions
+ 
+ATHCOOL=/usr/sbin/athcool
+ 
+case "$1" in
+ start)
+  stat_busy "Enabling Athcool"
+  $ATHCOOL on > /dev/null
+  if [ $? -gt 0 ]; then
+  stat_fail
+  else
+  stat_done
+  fi
+  ;;
+ stop)
+  stat_busy "Disabling Athcool"
+  $ATHCOOL off > /dev/null
+  if [ $? -gt 0 ]; then
+  stat_fail
+  else
+  stat_done
+  fi
+  ;;
+ restart)
+  $0 stop
+  /bin/sleep 1
+  $0 start
+  ;;
+ *)
+  echo "Usage: $0 {start|stop|restart}"
+esac
+exit 0
-- 
cgit v0.12


From 683ebca6129bbab546cffbc5eb6ac8e585875c66 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Mon, 16 Feb 2009 22:49:02 -0800
Subject: Initial inclusion of X11VNC.

---
 abs/extra-testing/x11vnc/PKGBUILD | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 abs/extra-testing/x11vnc/PKGBUILD

diff --git a/abs/extra-testing/x11vnc/PKGBUILD b/abs/extra-testing/x11vnc/PKGBUILD
new file mode 100644
index 0000000..4c04573
--- /dev/null
+++ b/abs/extra-testing/x11vnc/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: damir <damir@archlinux.org>
+
+pkgname=x11vnc
+pkgver=0.9.7
+pkgrel=1
+pkgdesc="a VNC server for real X displays"
+arch=("i686" "x86_64")
+license=("GPL2")
+#source=(http://dl.sourceforge.net/sourceforge/libvncserver/$pkgname-$pkgver.tar.gz)
+url="http://www.karlrunge.com/x11vnc/"
+source=("http://x11vnc.sourceforge.net/dev/x11vnc-0.9.7.tar.gz")
+depends=('openssl' 'libjpeg' 'zlib' 'libx11' 'libxtst' 'libxinerama' 'libxdamage' 'libxrandr' 'avahi')
+
+build() {
+  cd $startdir/src/$pkgname-$pkgver
+  ./configure
+  make || return 1
+  make prefix=$startdir/pkg/usr install || return 1
+}
+
+md5sums=('0ed95ab69c1ccacab83c5a2abd5b43f5')
-- 
cgit v0.12


From 2bbd920f9746998f3425452d6a9ce7a8208af06c Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Mon, 16 Feb 2009 23:52:40 -0800
Subject: NVRAM-Wakeup.

---
 abs/extra-testing/nvram-wake/PKGBUILD | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/abs/extra-testing/nvram-wake/PKGBUILD b/abs/extra-testing/nvram-wake/PKGBUILD
index f4d3d38..8072eb4 100755
--- a/abs/extra-testing/nvram-wake/PKGBUILD
+++ b/abs/extra-testing/nvram-wake/PKGBUILD
@@ -1,11 +1,11 @@
-pkgname=nvram-wakeup
-pkgver=0.97
+pkgname=nvram-wakup
+pkgver=0.99b
 pkgrel=1
 pkgdesc="set the wakeup time of the localpc"
 license="GPL"
 arch=(i686)
-url="http://ahh.sourceforge.net/wol/"
-source=(http://easynews.dl.sourceforge.net/sourceforge/nvram-wakeup/nvram-wakeup-0.97.tar.bz2 )
+url="http://sourceforge.net/projects/nvram-wakeup/"
+source=(http://superb-west.dl.sourceforge.net/sourceforge/nvram-wakeup/nvram-wakup-0.99b.tar.gz )
 
 
 build() {
-- 
cgit v0.12


From f3795c03f9a71a6eaea16ac37838780804c974db Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Tue, 17 Feb 2009 00:31:49 -0800
Subject: Fix for compat.h.

---
 abs/core-testing/mythtv/stable/mythstream/PKGBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/abs/core-testing/mythtv/stable/mythstream/PKGBUILD b/abs/core-testing/mythtv/stable/mythstream/PKGBUILD
index 646e61a..275afa8 100644
--- a/abs/core-testing/mythtv/stable/mythstream/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythstream/PKGBUILD
@@ -4,7 +4,7 @@
 
 pkgname=mythstream
 pkgver=0.18_1
-pkgrel=7
+pkgrel=8
 pkgdesc="Unofficial MythTV plugin for Internet audio and video streams."
 arch=('i686' 'x86_64')
 url="http://home.kabelfoon.nl/~moongies/streamtuned.html"
@@ -25,6 +25,7 @@ build() {
 
    # use QT3 qmake
    export PATH=$QTDIR/bin:$PATH
+   echo "INCLUDEPATH += /usr/include/mythtv" >> mythstream/mythstream.pro
 
    qmake mythstream.pro
    make qmake || return 1
-- 
cgit v0.12


From cdc9423cc94f4936a776d845d89fad10a64bb5f4 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Tue, 17 Feb 2009 03:24:04 -0800
Subject: Cleaned up themes.  Used Glossy Crystal icon set.

---
 abs/core-testing/mythtv/stable/linhes-theme/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/abs/core-testing/mythtv/stable/linhes-theme/PKGBUILD b/abs/core-testing/mythtv/stable/linhes-theme/PKGBUILD
index 0eec33f..a81459f 100644
--- a/abs/core-testing/mythtv/stable/linhes-theme/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/linhes-theme/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=linhes-theme
 pkgver=1
-pkgrel=4
+pkgrel=5
 pkgdesc="Default LinHES theme."
 arch=('i686' 'x86_64')
 license=('GPL2')
-- 
cgit v0.12


From 9d327823ebe603376dce4001876c25149c388c8d Mon Sep 17 00:00:00 2001
From: Nathan Harris <nharris@eoimaging.com>
Date: Tue, 17 Feb 2009 11:46:53 -0500
Subject: finally works.  not fully testing.

---
 abs/core-testing/mythtv/trunk/mythtv/PKGBUILD | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)

diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 056a99e..4277f16 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -1,22 +1,24 @@
 pkgname=mythtv-svn
 pkgver=19974
-pkgrel=1
+pkgrel=3
 pkgdesc="A personal video recorder for Linux"
 url="http://www.mythtv.org"
 license="GPL"
-depends=('lame' 'libmysqlclient' 'alsa-lib'  'wget' 'qt' 'x-server' 'freetype2' 'libmpeg2' 'libxml2' 'libraw1394' 'lirc' 'perl-date-manip' 'libavc1394' 'libdc1394' 'libiec61883')
-makedepends=('subversion')
-conflicts=(mythtv)
+depends=('bash' 'mysql-clients>=5.0' 'qt' 'lame' 'lirc-utils' 'ffmpeg' \
+        'faad2' 'libxv' 'libxvmc' 'libavc1394' 'libdc1394' 'libiec61883')
+makedepends=('libgl' 'subversion')
+conflicts=('mythtv')
 replaces=()
+groups=('pvr')
 backup=()
-options=(!strip)
-MAKEFLAGS="-j6"
+#options=(!strip)
+#MAKEFLAGS="-j6"
 install='mythtv.install'
 
 patchs=('smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch' 'mpegrecorder-hdpvr-v2a.patch' 'hdpvr-livetv.patch')
 #patchs=('svn_main_menu_popup.patch' 'smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch' 'mpegrecorder-hdpvr-v2a.patch' 'hdpvr-livetv.patch')
 source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}` )
-arch=('i686')
+arch=('i686' 'x86_64')
 md5sums=()
 
 _svntrunk=http://cvs.mythtv.org/svn/trunk/mythtv
@@ -46,7 +48,7 @@ build() {
 	# configure
 	./configure --prefix=/usr --cpu=${ARCH} \
 	--enable-vdpau --enable-xvmc --enable-xvmc-pro \
-	--enable-opengl-vsync --enable-libfaad --enable-dvb --enable-firewire \
+	--enable-opengl-vsync --enable-libfaad --enable-dvb --disable-firewire \
 	--compile-type=release --with-bindings=perl,python \
 	--enable-audio-alsa --disable-audio-jack --disable-audio-arts || return 1
 
-- 
cgit v0.12