From e4a682fa8bb497bd662e984548908e5514b9f181 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 26 Mar 2009 12:44:43 -0500
Subject: php: modify php.ini to match system timezone on install. This
 shouldn't be needed, but php is what it is.

---
 abs/core-testing/php/PKGBUILD    |  2 +-
 abs/core-testing/php/__changelog |  1 +
 abs/core-testing/php/php.install | 58 ++++++++++++----------------------------
 3 files changed, 19 insertions(+), 42 deletions(-)

diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index ddc508e..b7b99c1 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=php
 pkgver=5.2.6
-pkgrel=16
+pkgrel=17
 _suhosinver=0.9.6.2
 pkgdesc='A high-level scripting language'
 arch=('i686' 'x86_64')
diff --git a/abs/core-testing/php/__changelog b/abs/core-testing/php/__changelog
index 64f924c..aac14ba 100644
--- a/abs/core-testing/php/__changelog
+++ b/abs/core-testing/php/__changelog
@@ -3,3 +3,4 @@ set base dir to /data/srv/httpd/htdocs
 added /data/srv/tmp to basedir
 added /usr/share/mythtv/mythweather/scripts/
 send errors to stderr 
+change .install file, timezone is modified on install
diff --git a/abs/core-testing/php/php.install b/abs/core-testing/php/php.install
index 0c7e289..ba55b54 100644
--- a/abs/core-testing/php/php.install
+++ b/abs/core-testing/php/php.install
@@ -1,44 +1,12 @@
 post_install() {
-  echo '
-    ==> PHP modules
-
-    PHP has been built with optional modules. To enable these modules,
-    uncomment the modules from php.ini
-
-    Some of them require extra packages to be installed:
-
-        * bz2                : bzip2
-        * curl               : curl
-        * dba                : gdbm
-        * gd                 : libpng, libjpeg, freetype2
-        * imap               : pam
-        * ldap               : libldap
-        * mcrypt             : mcrypt, libtool
-        * mysql/mysqli       : libmysqlclient
-        * odbc/pdo_odbc      : unixodbc
-        * openssl            : openssl
-        * pgsql/pdo_pgsql    : postgresql-libs
-        * pspell             : aspell
-        * snmp               : net-snmp
-        * sqlite             : sqlite3
-        * tidy               : tidyhtml
-        * xsl                : libxslt
-
-    ==> PHP-CGI and FCGI
-
-    There are several cgi relevant settings in your php.ini. Make sure to
-    adjust them according to your needs. At least you should activate the
-    cgi.fix_pathinfo directive in php.ini by uncommenting it.
-
-    ==> PHP and Apache HTTPD
-
-    To use mod_php with the Apache webserver, add this to your httpd.conf:
-
-        LoadModule php5_module modules/libphp5.so
-        [..]
-        Include conf/extra/php5_module.conf
-
-    '
+	if [ -f /etc/systemconfig ]
+	then
+		. /etc/systemconfig
+		if [ -f /etc/php/php.ini ]
+		then
+	       	    sed -i "s/^;date.timezone.*$/date.timezone=${timezone}/" /etc/php/php.ini
+		fi
+	fi
 }
 
 pre_upgrade() {
@@ -67,6 +35,14 @@ post_upgrade() {
     echo 'Restoring old php.ini...'
     mv /etc/php/php.ini /etc/php/php.ini.pacnew
     mv /etc/php.ini.pacsave.tmp /etc/php/php.ini
+    if [ -f /etc/systemconfig ]
+	then
+		. /etc/systemconfig
+		if [ -f /etc/php/php.ini ]
+		then
+	       	    sed -i "s/^;date.timezone.*$/date.timezone=${timezone}/" /etc/php/php.ini
+		fi
+	fi
     echo 'Updating extension dir...'
     sed -i -e 's#extension_dir = "/usr/lib/php/extensions/php/"#extension_dir = "/usr/lib/php/20060613/"#g' /etc/php/php.ini
     echo '
@@ -94,4 +70,4 @@ post_upgrade() {
 
 op=$1
 shift
-[ "$(type -t "$op")" = "function" ] && $op "$@"
\ No newline at end of file
+[ "$(type -t "$op")" = "function" ] && $op "$@"
-- 
cgit v0.12