From 0b162d606184851b4416d9f832d1ea2be4b329a5 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 6 May 2014 01:37:00 +0000
Subject: mythtv, mythplugins, mythweb: update to latest -fixes

---
 abs/core/mythtv/stable-0.27/git_src/git_hash       |  2 +-
 abs/core/mythtv/stable-0.27/git_src/git_hash_web   |  2 +-
 abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD   | 11 +++--
 .../stable-0.27/mythplugins/cdparanoia.patch       | 52 ++++++++++++++++++++++
 abs/core/mythtv/stable-0.27/mythtv/PKGBUILD        |  2 +-
 abs/core/mythtv/stable-0.27/mythweb/PKGBUILD       |  2 +-
 6 files changed, 64 insertions(+), 7 deletions(-)
 create mode 100644 abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch

diff --git a/abs/core/mythtv/stable-0.27/git_src/git_hash b/abs/core/mythtv/stable-0.27/git_src/git_hash
index 065c8e2..16ca17a 100644
--- a/abs/core/mythtv/stable-0.27/git_src/git_hash
+++ b/abs/core/mythtv/stable-0.27/git_src/git_hash
@@ -1 +1 @@
-ad2f1ffebde4fcb05856584a3411a45487cc4cf5
+e2acf0d940009b2b240d52e9b53a123e1309a134
diff --git a/abs/core/mythtv/stable-0.27/git_src/git_hash_web b/abs/core/mythtv/stable-0.27/git_src/git_hash_web
index 64220c6..90675ae 100644
--- a/abs/core/mythtv/stable-0.27/git_src/git_hash_web
+++ b/abs/core/mythtv/stable-0.27/git_src/git_hash_web
@@ -1 +1 @@
-b4983f178bc847bfe7647ce5b9f235f5d2cbe362
+a492e9343caff760e0081f785d540ca6a1fe39fa
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
index 45c4187..65a5578 100644
--- a/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythplugins/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('mytharchive'
          'mythweather'
          'mythzoneminder')
 pkgver=0.27
-pkgrel=13
+pkgrel=14
 arch=('i686' 'x86_64')
 url="http://www.mythtv.org"
 license=('GPL')
@@ -19,7 +19,8 @@ makedepends=('cdrkit' 'dcraw' 'dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'flac' 'libexi
              'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-sax'
              'perl-xml-simple' 'perl-xml-xpath' 'python-oauth' 'python-imaging'
              'python-pycurl' 'zlib')
-source=('mythburn.py-aspectratio.patch' 'archivemenu.xml.patch' 'archiveutils.xml.patch')
+source=('mythburn.py-aspectratio.patch' 'archivemenu.xml.patch' 'archiveutils.xml.patch'
+        'cdparanoia.patch')
 
 build() {
     if [ -e ${srcdir}/mythplugins ]
@@ -33,6 +34,9 @@ build() {
     cp -rp ../git_src/mythtv/mythplugins $srcdir
     cd ${srcdir}/${pkgbase}
 
+    msg "Patching configure"
+    patch -Np1 -i "$srcdir/cdparanoia.patch"
+
     msg "Configuring mythplugins"
     ./configure --prefix=/usr \
                 --enable-all \
@@ -117,4 +121,5 @@ package_mythzoneminder() {
 
 md5sums=('e98c2a09bcb051fdde959fb4bb2e5ab2'
          '0364d2613f22943f3d4c9d5ee43c1982'
-         '1063cf62878cd341476f28f63cb12782')
+         '1063cf62878cd341476f28f63cb12782'
+         '5de8dd79d0b8a2b006f3c3258938b6b7')
diff --git a/abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch b/abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch
new file mode 100644
index 0000000..b4d1449
--- /dev/null
+++ b/abs/core/mythtv/stable-0.27/mythplugins/cdparanoia.patch
@@ -0,0 +1,52 @@
+diff -Nru a/configure b/configure
+--- a/configure	2012-10-02 23:30:24.000000000 +1300
++++ b/configure	2013-01-09 14:54:40.448916370 +1300
+@@ -649,7 +649,7 @@
+         echo "MythMusic requires FLAC."
+     fi
+ 
+-    if ! check_lib cdio/cdio.h cdio_open -lcdio || ! check_lib cdio/cdda.h cdio_cddap_open -lcdio_cdda || ! check_lib cdio/paranoia.h cdio_paranoia_init -lcdio_paranoia ; then
++    if ! check_lib cdio/cdio.h cdio_open -lcdio || ! check_lib cdio/paranoia/cdda.h cdio_cddap_open -lcdio_cdda || ! check_lib cdio/paranoia/paranoia.h cdio_paranoia_init -lcdio_paranoia ; then
+         disable cdio
+     fi
+ 
+diff -Nru a/mythmusic/mythmusic/cddecoder.cpp b/mythmusic/mythmusic/cddecoder.cpp
+--- a/mythmusic/mythmusic/cddecoder.cpp	2012-10-02 23:30:24.000000000 +1300
++++ b/mythmusic/mythmusic/cddecoder.cpp	2013-01-09 14:53:37.031690618 +1300
+@@ -14,7 +14,7 @@
+ #include <QString>
+ 
+ // libcdio
+-#include <cdio/cdda.h>
++#include <cdio/paranoia/cdda.h>
+ #include <cdio/logging.h>
+ 
+ // MythTV
+diff -Nru a/mythmusic/mythmusic/cddecoder.h b/mythmusic/mythmusic/cddecoder.h
+--- a/mythmusic/mythmusic/cddecoder.h	2012-10-02 23:30:24.000000000 +1300
++++ b/mythmusic/mythmusic/cddecoder.h	2013-01-09 14:53:12.328140979 +1300
+@@ -11,8 +11,8 @@
+ #endif
+ 
+ #ifdef HAVE_CDIO
+-# include <cdio/cdda.h>
+-# include <cdio/paranoia.h>
++# include <cdio/paranoia/cdda.h>
++# include <cdio/paranoia/paranoia.h>
+ #endif
+ 
+ class Metadata;
+diff -Nru a/mythmusic/mythmusic/cdrip.cpp b/mythmusic/mythmusic/cdrip.cpp
+--- a/mythmusic/mythmusic/cdrip.cpp	2012-10-02 23:30:24.000000000 +1300
++++ b/mythmusic/mythmusic/cdrip.cpp	2013-01-09 14:54:11.815330268 +1300
+@@ -8,8 +8,8 @@
+ 
+ #include "config.h"
+ #ifdef HAVE_CDIO
+-# include <cdio/cdda.h>
+-# include <cdio/paranoia.h>
++# include <cdio/paranoia/cdda.h>
++# include <cdio/paranoia/paranoia.h>
+ #endif //def HAVE_CDIO
+ 
+ // C++ includes
diff --git a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
index fe05903..70eed29 100644
--- a/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythtv
 pkgver=0.27
-pkgrel=13
+pkgrel=14
 commit_hash=`cat ../git_src/git_hash`
 pkgdesc="A Homebrew PVR project $commit_hash"
 arch=('i686' 'x86_64')
diff --git a/abs/core/mythtv/stable-0.27/mythweb/PKGBUILD b/abs/core/mythtv/stable-0.27/mythweb/PKGBUILD
index d2d0808..7489e8a 100644
--- a/abs/core/mythtv/stable-0.27/mythweb/PKGBUILD
+++ b/abs/core/mythtv/stable-0.27/mythweb/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=mythweb
 pkgver=0.27
-pkgrel=3
+pkgrel=4
 commit_hash=`cat ../git_src/git_hash_web`
 pkgdesc="Web interface for MythTV's backend, $commit_hash"
 arch=('i686' 'x86_64')
-- 
cgit v0.12