From a06c3856f91bd466a61d2c13ba8260ef26c0cfb8 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 13 Nov 2008 12:45:30 -0600
Subject: During the upgrade process, /myth/* should be chowned to
 mythtv.mythtv. This should be followed by a chown of /myth/backup to
 root.root. This closes FS#10

---
 abs/core-testing/LinHES-config/PKGBUILD         |  2 +-
 abs/core-testing/LinHES-config/install_proxy.sh | 16 +++++++++++++---
 2 files changed, 14 insertions(+), 4 deletions(-)

diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index a489ba7..f3b73c8 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-config
 pkgver=1.0
-pkgrel=8
+pkgrel=9
 conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
 pkgdesc="Install and configure your system"
 depends=(bc libstatgrab  mysql-python expect curl dnsutils parted sg3_utils nmbscan)
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index a0630c6..86db000 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -225,11 +225,15 @@ function upgrade () {
         fi
         $run fstab_fix_it $disk UPGRADE
 
-    echo "Writing boot sector" > /tmp/.install_state
+	#this is here to copy in the systemconfig file as soon as possible.
+        cp -f /etc/systemconfig "$mountpoint"/etc
+
+        echo "Writing boot sector" > /tmp/.install_state
         progress 99
         sleep 1
         $run grub_it $disk
 
+
     echo "Configuring system" > /tmp/.install_state
         progress
         sleep 1
@@ -264,20 +268,26 @@ function upgrade () {
 
         chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,this_is_install
         #wrap this in a network check_network, no need to update the db if the import worked.
-#####  do I need to start mysql?
+        #####  do I need to start mysql?
         /etc/rc.d/mysqld stop
         chroot "$mountpoint"   "$MV_ROOT/bin/restore_km_db_chroot.sh"  >  /tmp/chrootdb_km.out
         if [  -f /tmp/etc/KnoppMyth-version ]
         then
             chroot "$mountpoint" $MV_ROOT/bin/restore_default_settings.sh -c restore -t hostsettings
+	    #change permissions of /myth (only needed on km->linhes)
+	    chown -R mythtv:mythtv $mountpoint/myth
+            chown -R root:root $mountpoint/myth/backup
         else
             chroot "$mountpoint" $MV_ROOT/bin/restore_default_settings.sh -c restore -t syssettings
         fi
         #
-    #Run second time
+        #Run second time
         chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh misc,hostype,network,advanced,this_is_install
         chroot "$mountpoint" $MV_ROOT/bin/systemconfig.sh advanced,this_is_install
         apply_new_auth
+
+
+
         umount "$mountpoint/dev"
         umount "$mountpoint/proc"
 
-- 
cgit v0.12