From e11fce5276ea7ca11a8cfb36beab0d10bd5d2047 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Sat, 13 Aug 2011 01:05:41 -0700
Subject: ceton:Initial inclusion. Drivers for InfinTV 4.

---
 abs/core/ceton/PKGBUILD      | 28 ++++++++++++++++++++++++++++
 abs/core/ceton/ceton.install | 23 +++++++++++++++++++++++
 2 files changed, 51 insertions(+)
 create mode 100644 abs/core/ceton/PKGBUILD
 create mode 100644 abs/core/ceton/ceton.install

diff --git a/abs/core/ceton/PKGBUILD b/abs/core/ceton/PKGBUILD
new file mode 100644
index 0000000..97eb417
--- /dev/null
+++ b/abs/core/ceton/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=ceton
+_kernver=2.6.39-LinHES
+pkgver=1.2
+pkgrel=3
+pkgdesc="Drivers for Ceton InfiniTV4"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://linuxtv.org/"
+depends=('kernel26')
+makedepends=(kernel-headers)
+install=ceton.install
+source=('http://www.cetoncorp.com/firmware/ceton_infinitv_linux_driver_1_2.tar.gz')
+
+build() {
+  cd $startdir/src/ceton_infinitv_linux_driver
+#  patch -p1 < ../hdpvr.diff
+  make
+  make install
+  mkdir -p $startdir/pkg/lib/modules/$_kernver/kernel/drivers/media/video
+  cp ctn91xx.ko $startdir/pkg/lib/modules/$_kernver/kernel/drivers/media/video
+  mkdir -p $pkgdir/etc/udev/rules.d
+  cp 98-ctn91xx.rules $pkgdir/etc/udev/rules.d/
+
+}
+md5sums=('7a014a32d88e0792231b439079c20acd')
diff --git a/abs/core/ceton/ceton.install b/abs/core/ceton/ceton.install
new file mode 100644
index 0000000..912a323
--- /dev/null
+++ b/abs/core/ceton/ceton.install
@@ -0,0 +1,23 @@
+# arg 1:  the new package version
+post_install() {
+  KERNEL_VERSION='2.6.39-LinHES'
+  depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1                
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+  KERNEL_VERSION='2.6.39-LinHES'
+  depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1        
+
+}
+
+# arg 1:  the old package version
+post_remove() {
+  KERNEL_VERSION='2.6.28-LinHES'
+  depmod -ae -v $KERNEL_VERSION  > /dev/null 2>&1        
+}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12